Написать программу на Pascal - В одномерном массиве целых чисел, содержащем 20 элементов, удалить k - ый элемент массива?

Информатика | 10 - 11 классы

Написать программу на Pascal - В одномерном массиве целых чисел, содержащем 20 элементов, удалить k - ый элемент массива.

Массив заполняется случайным образом числами от 0 до 50.

Ответить на вопрос
Ответы (1)
Paulinatrifonova 21 янв. 2020 г., 05:39:07

Const n = 20 ;

var a : array[1.

N] of integer ; i, k : integer ;

begin randomize ; writeln('Исходный массив : ') ; for i : = 1 to n do begin a[i] : = random(51) ; write(a[i], ' ') ; end ; writeln ; write('k = ') ; readln(k) ; if (k > ; n) or (k < ; 1) then begin writeln('элемента с таким индексом нет') ; readln ; Exit ; end ; for i : = k to n - 1 do a[i] : = a[i + 1] ; a[n] : = 0 ; writeln('Измененный массив : ') ; for i : = 1 to n - 1 do write(a[i], ' ') ; readln ; writeln ;

end.

Zau678 30 апр. 2020 г., 01:37:14 | 5 - 9 классы

Школьный уровень 1?

Школьный уровень 1.

Найти все элементы массива b(n), большие или равные 0.

На экран вывести номер элементов, их значения и количество.

2. В одномерном массиве целых чисел, содержащем 20 элементов, удалить k - ый элемент массива.

Массив заполняется случайным образом числами от 0 до 50.

VJGinger 8 авг. 2020 г., 22:37:09 | 5 - 9 классы

Пожалуйста помогите) 1) написать программу , заполняющую массив из 10 элементов числами от 10 до 1?

Пожалуйста помогите) 1) написать программу , заполняющую массив из 10 элементов числами от 10 до 1.

2)написать программу подсчитывающую количество нечетных элементов в массиве случайных чисел.

3) программа заполняет массив случайными числами от - 10 до 10 и находит сумму отрицательных и положительных элементов.

Ghjkknbbv 21 дек. 2020 г., 09:04:39 | 1 - 4 классы

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами?

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами.

Требуется вывести массив на экран компьютера и найти индекс последнего по счету в массиве отрицательного элемента.

Menshih5536 22 июн. 2020 г., 02:08:28 | 5 - 9 классы

Напишите программу, которая случайным образом заполняет массив из 10 элементов целыми числами из диапазона [ - 6 ; 9]?

Напишите программу, которая случайным образом заполняет массив из 10 элементов целыми числами из диапазона [ - 6 ; 9].

И вывести все элементы массива на экран.

Mariusik 22 июн. 2020 г., 23:41:38 | 5 - 9 классы

Как сложить все элементы одномерного массива в Pascal?

Как сложить все элементы одномерного массива в Pascal?

Aylovat40 16 окт. 2020 г., 08:55:54 | 10 - 11 классы

Дан одномерный массив из 12 чисел?

Дан одномерный массив из 12 чисел.

Элементами массива являются целые числа.

Найти максимальный элемент указанного массива.

Катюшащенок 21 нояб. 2020 г., 01:23:06 | 10 - 11 классы

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элемен?

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элементов массива, расположенных между максимальным и минимальным элементами.

Сформировать из этих элементов новый массив.

Irinamakeeva96 9 мар. 2020 г., 04:50:23 | 10 - 11 классы

Составьте программу вычисления суммы элементов одномерного массива А(N), меньших N?

Составьте программу вычисления суммы элементов одномерного массива А(N), меньших N.

Заполнить массив случайным образом.

Artem1918 1 янв. 2020 г., 05:23:47 | 10 - 11 классы

Создать два одномерных массива, состоящих из целых чисел?

Создать два одномерных массива, состоящих из целых чисел.

Элементы массива вводятся с клавиатуры.

В первом массиве найти номер первого нечетного элемента массива.

Во втором массиве найти первый четный элемент массива.

Решить на Pascal ABC (При решении задач обязательно использовать одномерные массивы и процедуры или функции работы с одномерными массивами.

).

Gubin20011 21 нояб. 2020 г., 08:01:00 | 5 - 9 классы

Написать программу, которая определяет в одномерном массиве, заполненном случайным образом, количество элементов, значения которых меньше числа, введенного с клавиатуры?

Написать программу, которая определяет в одномерном массиве, заполненном случайным образом, количество элементов, значения которых меньше числа, введенного с клавиатуры.

Если есть, то вывести эти элементы.

На странице вопроса Написать программу на Pascal - В одномерном массиве целых чисел, содержащем 20 элементов, удалить k - ый элемент массива? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.