Напишите программу в Паскаль : Для n произвольно введенных чисел с клавиатуры вычислить сумму и количество кратных 3 и не кратных 6 и произведение нечетных (на простом уровне)?

Информатика | 5 - 9 классы

Напишите программу в Паскаль : Для n произвольно введенных чисел с клавиатуры вычислить сумму и количество кратных 3 и не кратных 6 и произведение нечетных (на простом уровне).

Ответить на вопрос
Ответы (1)
Garmoshka 8 июн. 2021 г., 02:00:29

Program n1 ;

var i, a, sum, k, p, n : integer ;

begin

write('введите кол - во чисел : ') ;

readln(n) ;

sum : = 0 ;

k : = 0 ;

p : = 1 ;

for i : = 1 to n do

begin

write('введите ', i, ' число : ') ;

readln(a) ;

if (a mod 3 = 0) and (a mod 60)

then

begin

sum : = sum + a ;

k : = k + 1 ;

end ;

if a mod 20 then p : = p * a ;

end ;

writeln('сумма : ', sum) ;

writeln('количество : ', k) ;

writeln('произведение : ', p) ;

end.

Albina0795 8 янв. 2021 г., 03:37:32 | 5 - 9 классы

Напишите программу вычисления суммы чисел кратных 5 из натурального ряда чисел от 1 до n , и произведение чисел кратных к 3 (for)?

Напишите программу вычисления суммы чисел кратных 5 из натурального ряда чисел от 1 до n , и произведение чисел кратных к 3 (for).

Tatjanaesikova 12 июн. 2021 г., 20:55:46 | 5 - 9 классы

Напишите программу, которая для каждого из трех чисел, введенных чисел с клавиатуры пользователем, определяет является это число четным или нечетным, двузначное оно или нет и кратно ли оно 3?

Напишите программу, которая для каждого из трех чисел, введенных чисел с клавиатуры пользователем, определяет является это число четным или нечетным, двузначное оно или нет и кратно ли оно 3.

Тюльнева 11 мар. 2021 г., 02:44:26 | 10 - 11 классы

Составьте программу в ПаскалеНайдите сумму чисел, кратных 2 из диапазона от 1 до 38?

Составьте программу в Паскале

Найдите сумму чисел, кратных 2 из диапазона от 1 до 38.

Найдите произведение чисел , кратных 4 из диапазона от 2 до 25.

0992448003 12 мая 2021 г., 04:54:40 | 5 - 9 классы

Составить программу?

Составить программу!

На языке Паскаль

Подсчитать количество отрицательных чисел из 10 введенных с клавиатуры.

Найти количество чисел, не больше 100.

Zatsevaanka201 31 авг. 2021 г., 11:09:20 | 5 - 9 классы

Используя цикл For вычислить сумму 7 - ми произвольных чисел, введенных с клавиатуры?

Используя цикл For вычислить сумму 7 - ми произвольных чисел, введенных с клавиатуры.

Retih 16 янв. 2021 г., 16:41:13 | 5 - 9 классы

Паскаль, сумма нечетных чисел (1 - 100), кратных 3?

Паскаль, сумма нечетных чисел (1 - 100), кратных 3.

Olgasviribova 24 авг. 2021 г., 20:57:27 | 5 - 9 классы

Среди 10 чисел, введенных с клавиатуры, найти сумму тех, которые кратны 2?

Среди 10 чисел, введенных с клавиатуры, найти сумму тех, которые кратны 2.

Программа в паскале).

Алексей1999 28 янв. 2021 г., 23:21:12 | 10 - 11 классы

Найти сумму чисел введенных с клавиатуры количество чисел задать через оператор read?

Найти сумму чисел введенных с клавиатуры количество чисел задать через оператор read.

Паскаль, срочноо.

Руслан123438 12 дек. 2021 г., 16:35:29 | 5 - 9 классы

Используя цикл For вычислить сумму 7 - ми произвольных чисел, введенных с клавиатуры?

Используя цикл For вычислить сумму 7 - ми произвольных чисел, введенных с клавиатуры.

Составить для паскаль.

Помогите пожалуйста.

Буду очень благодарна.

Кристиан5 28 июн. 2021 г., 15:09:48 | 5 - 9 классы

Напишите программу которая находит сумму произведение и среднее арифметическое 4х чисел введеных с клавиатуры?

Напишите программу которая находит сумму произведение и среднее арифметическое 4х чисел введеных с клавиатуры.

На этой странице находится вопрос Напишите программу в Паскаль : Для n произвольно введенных чисел с клавиатуры вычислить сумму и количество кратных 3 и не кратных 6 и произведение нечетных (на простом уровне)?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.