Напишите программу, которая для каждого из трех чисел, введенных чисел с клавиатуры пользователем, определяет является это число четным или нечетным, двузначное оно или нет и кратно ли оно 3?

Информатика | 5 - 9 классы

Напишите программу, которая для каждого из трех чисел, введенных чисел с клавиатуры пользователем, определяет является это число четным или нечетным, двузначное оно или нет и кратно ли оно 3.

Ответить на вопрос
Ответы (1)
Андрей79rus 12 июн. 2021 г., 20:55:48

/ / прога на Pascal`e

var

a : array of int64 ;

n : longint ;

i : byte ;

begin

write ('Введите кол - во чисел : ') ;

readln (n) ;

setLength (a, n) ;

for i : = 0 to n - 1 do

begin

write ('Введите ', i + 1, ' число : ') ;

readln (a[i]) ;

end ;

for i : = 0 to n - 1 do

begin

writeln (' - - - - - - - - - - - - - - - - - - - - - - - ') ;

writeln ('Число ', a[i], ' : ') ;

if (a[i] mod 2) = 0 then writeln ('Четное') else writeln ('Нечетное') ;

if (a[i] mod 3) = 0 then writeln ('Кратно 3 - ем') else writeln ('Не кратно 3 - ем') ;

if (a[i]99) then writeln ('Не 2 - значное') else writeln ('2 - значное') ;

end ;

end.

Ник159753 30 мая 2021 г., 22:43:04 | 10 - 11 классы

Составить программу : С клавиатуры вводится три числа?

Составить программу : С клавиатуры вводится три числа.

Определите является ли произведение этих чисел числом четным и кратным 4.

Идиот8 18 мая 2021 г., 02:43:46 | 5 - 9 классы

Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3?

Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3.

Программа получает на выход целые числа.

Количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность ).

Количество чисел не превышает 20.

Введенные числа [ - 30 ; 30].

Программа должна вывести одно число : количество четных чисел, кратных 3.

Желательно с массивом в начале.

Буду признательна!

Мтчеларрпар 4 окт. 2021 г., 04:07:52 | 5 - 9 классы

Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3?

Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3.

Программа получает на выход целые числа.

Количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность ).

Количество чисел не превышает 20.

Введенные числа [ - 30 ; 30].

Программа должна вывести одно число : количество четных чисел, кратных 3.

Буду признательна!

Tanecka228 16 сент. 2021 г., 08:54:15 | 5 - 9 классы

Написать программу, которая проверяет, является ли четным введенное пользователем целое трехзначное число число?

Написать программу, которая проверяет, является ли четным введенное пользователем целое трехзначное число число.

Фатима147 8 июн. 2021 г., 02:00:26 | 5 - 9 классы

Напишите программу в Паскаль : Для n произвольно введенных чисел с клавиатуры вычислить сумму и количество кратных 3 и не кратных 6 и произведение нечетных (на простом уровне)?

Напишите программу в Паскаль : Для n произвольно введенных чисел с клавиатуры вычислить сумму и количество кратных 3 и не кратных 6 и произведение нечетных (на простом уровне).

Али122004 8 июн. 2021 г., 00:18:05 | 5 - 9 классы

Напишите программу, которая для последовательности целых чисел определяет количество четных чисел?

Напишите программу, которая для последовательности целых чисел определяет количество четных чисел.

Программа получает на вход количество чисел в последоввтельности, а затем сами числа.

Количество чисел не привышает 1000.

Введенные числа не привышвют 10000 и не меньше - 10000.

Программа должна вывести одно число - количество всех четных чисел в последоввтельности.

Если среди введенных чисел нет четных, то результат равен 0.

Rebelseven96 5 июн. 2021 г., 21:33:22 | 5 - 9 классы

Напишите программу, которая определяет, является ли введенное число двузначным, если в ней используются логические операции?

Напишите программу, которая определяет, является ли введенное число двузначным, если в ней используются логические операции.

Kirill221102 24 дек. 2021 г., 17:04:58 | 10 - 11 классы

Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3?

Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3.

Программа получает на вход целые числа.

Количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30000.

Программа должна вывести одно число : количество четных чисел, кратных 3.

Nutmas 19 апр. 2021 г., 11:03:09 | 5 - 9 классы

Напишите программу на Pascal?

Напишите программу на Pascal!

Является ли сумма трех чисел четным числом?

Katay09 23 июн. 2021 г., 05:43:36 | 5 - 9 классы

Напишите программу которая увеличивает введенные число с клавиатуры в 3 раза если оно отрицательное и уменьшает на 8 если оно положительное?

Напишите программу которая увеличивает введенные число с клавиатуры в 3 раза если оно отрицательное и уменьшает на 8 если оно положительное.

На этой странице находится вопрос Напишите программу, которая для каждого из трех чисел, введенных чисел с клавиатуры пользователем, определяет является это число четным или нечетным, двузначное оно или нет и кратно ли оно 3?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.