Паскаль 1?

Информатика | 5 - 9 классы

Паскаль 1.

Дана последовательность N целых чисел, введенных с клавиатуры.

Получить сумму и количество тех членов последовательности, которые :

а) имеют четное значение, четный номер и отрицательные ;

б) делятся на 3 и не делятся на 5 ;

в).

Ответить на вопрос
Ответы (1)
Rekryt987 14 июн. 2020 г., 05:44:59

А)uses crt ;

const n = 20 ;

var a : array[1.

N] of integer ;

i, s, k : integer ;

begin

randomize ;

s : = 0 ;

k : = 0 ;

for i : = 1 to n do

begin

a[i] : = random(100) - 50 ;

writeln(a[i]) ;

end ;

writeln ;

for i : = 1 to n do

begin

if (a[i] mod 2 = 0) and (i mod 2 = 0) and (a[i]< ; 0)

then

begin

inc(k) ;

s : = s + a[i] ;

end ;

end ;

writeln(s) ;

writeln(k) ;

end.

Б)uses crt ;

const n = 20 ;

var a : array[1.

N] of integer ;

i, s, k : integer ;

begin

randomize ;

s : = 0 ;

k : = 0 ;

for i : = 1 to n do

begin

a[i] : = random(100) - 50 ;

writeln(a[i]) ;

end ;

writeln ;

for i : = 1 to n do

begin

if (a[i]mod 3 = 0) and (a[i] mod 5< ; > ; 0) then

begin

s : = s + a[i] ;

inc(k) ;

end ;

end ;

writeln(s) ;

writeln(k) ;

end.

В)uses crt ;

const n = 20 ;

var a : array[1.

N] of integer ;

i, s, k : integer ;

begin

randomize ;

s : = 0 ;

k : = 0 ;

for i : = 1 to n do

begin

a[i] : = random(100) - 50 ;

writeln(a[i]) ;

end ;

writeln ;

for i : = 1 to n do

begin

if (abs(a[i]))> ; (i - 2)

then

begin

inc(k) ;

s : = s + a[i] ;

end ;

end ;

writeln(s) ;

writeln(k) ;

end.

Рысюля2014 4 апр. 2020 г., 14:36:41 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел находит сумму четных чисел в диапазоне от 5 до 25?

Напишите программу, которая в последовательности целых чисел находит сумму четных чисел в диапазоне от 5 до 25.

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30000.

Программа должна вывести одно число : сумму четных чисел в диапазоне от 5 до 25.

Входные данные : 4, 16, 17, 26, 0 Выходные данные : 16.

Evgeniya198 23 мар. 2020 г., 23:05:18 | 5 - 9 классы

(Паскаль)Заполнить с клавиатуры массив из 10 элементов?

(Паскаль)Заполнить с клавиатуры массив из 10 элементов.

Вывести на экран те элементы массива, которые имеют четный номер и четное значение .

Сень123 26 сент. 2020 г., 08:30:05 | 5 - 9 классы

ПОМОГИТЕ С ПАСКАЛЕМ?

ПОМОГИТЕ С ПАСКАЛЕМ.

С клавиатуры вводятся 7 целых чисел.

Вычислить количество отрицательных членов этой последовательности.

Svetlana3012642 23 дек. 2020 г., 01:36:59 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число?

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число.

Программа получает на вход целые числа, количество введенных данных неизвестно, последовательность чисел заканчивается числом 0.

На Паскале.

Olga050577 16 дек. 2020 г., 12:21:35 | 5 - 9 классы

Дана непустая последовательность положительный целых чисел, за которой следует 0?

Дана непустая последовательность положительный целых чисел, за которой следует 0.

Найти сумму всех четных чисел этой последовательности

Записать, как программу в паскале.

Medko 27 апр. 2020 г., 21:52:53 | 10 - 11 классы

Написать программу в Паскале?

Написать программу в Паскале.

Подсчитать сумму четных целых чисел находящихся от одного до значения введенного пользователем.

Anya2552 8 мар. 2020 г., 06:13:20 | 5 - 9 классы

Найти сумму первых 6 последовательных четных чисел по Турбо Паскалю?

Найти сумму первых 6 последовательных четных чисел по Турбо Паскалю.

Я112яя 23 июл. 2020 г., 22:35:13 | 5 - 9 классы

Дана последовательность чисел?

Дана последовательность чисел.

Найти произведение всех четных отрицательных чисел.

NRyabikovaNN 25 сент. 2020 г., 05:39:05 | 10 - 11 классы

Написать программу в Pascal даны целые числа а1?

Написать программу в Pascal даны целые числа а1.

Аn. Если в данной последовательности ни одно четное число не расположено после нечетного.

То получить все отрицательные члены последовательности иначе - положительное.

ГиперГолубь 19 апр. 2020 г., 15:49:51 | 10 - 11 классы

Напишите программу, которая вводит последовательность целых чисел заканчивающихся нулем, и определяет количество четных положительных чисел в этой последовательности?

Напишите программу, которая вводит последовательность целых чисел заканчивающихся нулем, и определяет количество четных положительных чисел в этой последовательности.

Вы перешли к вопросу Паскаль 1?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.