Написать программу в Pascal даны целые числа а1?

Информатика | 10 - 11 классы

Написать программу в Pascal даны целые числа а1.

Аn. Если в данной последовательности ни одно четное число не расположено после нечетного.

То получить все отрицательные члены последовательности иначе - положительное.

Ответить на вопрос
Ответы (1)
Klim1800 25 сент. 2020 г., 05:39:09

Var a : array[1.

50] of integer ; i, f, n : integer ;

begin write('n = ') ; readln(n) ; for i : = 1 to n do begin write('a', i, ' = ') ; readln(a[i]) ; end ; f : = 0 ; writeln ; for i : = 1 to n - 1 do if (a[i] mod 2 < ; > ; 0) and (a[i + 1] mod 2 = 0) then f : = 1 ; if f = 0 then begin for i : = 1 to n do if a[i] < ; 0 then write(a[i] : 4) ; end else for i : = 1 to n do if a[i] > ; 0 then write(a[i] : 4) ;

end.

Svetlana3012642 23 дек. 2020 г., 01:36:59 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число?

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число.

Программа получает на вход целые числа, количество введенных данных неизвестно, последовательность чисел заканчивается числом 0.

На Паскале.

Наталия1611 8 янв. 2020 г., 10:35:08 | 10 - 11 классы

Даны натуральное число n и последовательность целых чисел а1, а2, …, аn?

Даны натуральное число n и последовательность целых чисел а1, а2, …, аn.

Определить количество тех членов последовательности, которые нечетны .

Найти сумму членов последовательности, кратных 11.

Составить блок - схему алгоритма, написать программу.

Olga050577 16 дек. 2020 г., 12:21:35 | 5 - 9 классы

Дана непустая последовательность положительный целых чисел, за которой следует 0?

Дана непустая последовательность положительный целых чисел, за которой следует 0.

Найти сумму всех четных чисел этой последовательности

Записать, как программу в паскале.

Птспитт 17 мая 2020 г., 17:29:23 | 10 - 11 классы

Даны натуральное число n, действительные числа A1, A2, ?

Даны натуральное число n, действительные числа A1, A2, .

, An.

Получить : а) сумму отрицательных и количество положительных членов последовательности A 1, A2 , .

, An ;

Gshcgh 3 июн. 2020 г., 11:27:54 | 10 - 11 классы

Даны целые числа a1, …a50?

Даны целые числа a1, …a50.

Получить последовательность b1, …, b50, которая отличается от исходной последовательности тем, что все нечетные элементы удвоены.

Ksenijaksusha 20 окт. 2020 г., 22:51:03 | 10 - 11 классы

Помогите написать программу в с + + ?

Помогите написать программу в с + + .

Используя оператор if нужно написать программу , где пользователь вводит число , а программа отображает одно из трех сообщений : число является четным , положительным .

Или число является нечетным , положительным.

Или отрицательным.

Paramonoff4 14 июн. 2020 г., 06:59:12 | 10 - 11 классы

Задана последовательность из n целых чисел?

Задана последовательность из n целых чисел.

Определить среднее арифметическое отрицательных элементов последовательности.

Написать программу в Pascal.

Enerhdu45gdhhd 25 июн. 2020 г., 09:45:52 | 10 - 11 классы

Нужно составить программу С + + , - даны действительные числа А1, А2?

Нужно составить программу С + + , - даны действительные числа А1, А2.

Аn и натуральный число n, n - количество чисел, найти сумму отрицательных и количество положительных членов последовательности.

Alina30001 11 июн. 2020 г., 10:10:43 | 10 - 11 классы

Дано целое четырехзначное число?

Дано целое четырехзначное число.

Если число четное, найти произведение его цифр, иначе перевернуть число, записав его цифры в обратном порядке.

Написать программу в Паскале.

Zenkova929 24 июл. 2020 г., 13:36:47 | 10 - 11 классы

Pascal?

Pascal.

Дана последовательность чисел .

Вывести на экран суммы положительных и отрицательных чисел данной последовательности.

На этой странице сайта размещен вопрос Написать программу в Pascal даны целые числа а1? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.