Pascal?

Информатика | 10 - 11 классы

Pascal.

Вводится 2 натуральных числа.

Вывести их НОК.

Помогите пожалуйста!

Ответить на вопрос
Ответы (2)
Lord22811 25 мар. 2021 г., 05:40:16

/ / алгоритм Евклида

var

a, b : integer ;

function NOD (p1, p2 : integer) : integer ;

begin while p1p2 do if p1>p2 then p1 : = p1 - p2 else p2 : = p2 - p1 ; NOD : = p1 ;

end ;

function NOK (p1, p2 : integer) : integer ;

begin NOK : = (p1 * p2) div NOD(p1, p2) ;

end ;

begin

readln (a, b) ;

writeln ('НОК a, b = ', NOK(a, b)) ;

end.

Анимеschnица 25 мар. 2021 г., 05:40:17

Var

a, b, nok : integer ;

begin

readln (a, b) ;

nok : = (a * b) ;

while ab do

begin

if a>b then a : = a - b else b : = b - a ;

end ;

nok : = nok div a ;

write (nok) ;

end.

МаксаТракса 11 мар. 2021 г., 21:28:45 | 5 - 9 классы

Напишите програму, которая вводит натуральные числа a и b, и выводит квадраты натуральных чисел в диапазоне [ a b ] ?

Напишите програму, которая вводит натуральные числа a и b, и выводит квадраты натуральных чисел в диапазоне [ a b ] .

Язык Pascal.

Perov04 7 авг. 2021 г., 14:20:05 | 5 - 9 классы

Пользователь вводит число n, программа должна вывести число наоборот?

Пользователь вводит число n, программа должна вывести число наоборот.

Помогите пожалуйста!

(Pascal).

Наталья433 23 апр. 2021 г., 19:14:26 | 5 - 9 классы

Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел?

Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел.

Язык Pascal.

Зиновкина 30 янв. 2021 г., 17:54:49 | 1 - 4 классы

Вводится натуральное число N необходимо вывести все кубы натуральных чисел от N до 1 СРОЧНО?

Вводится натуральное число N необходимо вывести все кубы натуральных чисел от N до 1 СРОЧНО.

Ir24na 22 мар. 2021 г., 04:03:11 | 5 - 9 классы

Pascal1)Вычислить и вывести квадраты чисел натурального ряда от 1 до 102)?

Pascal

1)Вычислить и вывести квадраты чисел натурального ряда от 1 до 10

2).

В диапазоне от 1 до К вывести все нечётные числа

Помогите пожалуйста ((.

Demon132 12 мая 2021 г., 15:17:36 | 5 - 9 классы

Pascal ABCВ диапазоне от 1 до К вывести все нечётные числа Помогите пожалуйста ((?

Pascal ABC

В диапазоне от 1 до К вывести все нечётные числа Помогите пожалуйста ((.

Dl2004 12 сент. 2021 г., 12:21:35 | 5 - 9 классы

Вводятся два натуральных числа?

Вводятся два натуральных числа.

Если оба числа чётные, то вывести большее из них.

Если оба числа не чётные, то вывести меньшее из них.

Если одно чётное, а другое не чётное, то вывести их произведение на экран.

Lerasviridova15 18 мая 2021 г., 13:16:10 | 5 - 9 классы

Задание - составить программу в pascalвводишь два числа а и б?

Задание - составить программу в pascal

вводишь два числа а и б.

При чем а < б.

Надо вывести квадраты всех чисел между а и б.

Olegtishin 22 авг. 2021 г., 18:05:54 | 5 - 9 классы

Вводятся произвольные натуральные числа в количестве n ?

Вводятся произвольные натуральные числа в количестве n .

Вывести ('Да') если все числа являются четырехзначным и при этом начинаются с нечетных чисел.

КатяМай1 29 сент. 2021 г., 12:19:26 | 5 - 9 классы

Вводится натуральное число, не превышающее 1 млрд?

Вводится натуральное число, не превышающее 1 млрд.

Вывести количество четных чисел.

Программа на Pascal.

Перед вами страница с вопросом Pascal?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.