Вводится натуральное число, не превышающее 1 млрд?

Информатика | 5 - 9 классы

Вводится натуральное число, не превышающее 1 млрд.

Вывести количество четных чисел.

Программа на Pascal.

Ответить на вопрос
Ответы (1)
Avtosaydin 29 сент. 2021 г., 12:19:31

Program hhh54 ;

var x : longint ;

begin read (x) ; if x mod 2 = 0 then write ('1') else write ('0') ;

end.

Aiana2006 21 янв. 2021 г., 01:42:09 | 10 - 11 классы

Напишите программу, которая в последовательности натуральных чисел определяет количество однозначных чисел, кратных 3?

Напишите программу, которая в последовательности натуральных чисел определяет количество однозначных чисел, кратных 3.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Программа должна вывести одно число : количество однозначных чисел, кратных 3.

Ирина56 23 янв. 2021 г., 08:29:04 | 10 - 11 классы

Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO)?

Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO).

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 undefined признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести среднее арифметическое трёхзначных чисел или вывести «NO», если таких чисел нет.

Расписать программу в Паскаль abc.

Musabekovaaltina 10 авг. 2021 г., 20:04:18 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое двузначных чисел или сообщает, что таких чисел нет (выводит «NO»)?

Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое двузначных чисел или сообщает, что таких чисел нет (выводит «NO»).

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 100.

Введенные числа не превышают 300.

Программа должна вывести среднее арифметическое двузначных чисел или вывести «NO», если таких чисел нет.

Значение выводить с точностью до десятых.

PokemonYouTube 18 авг. 2021 г., 16:12:33 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел?

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30000.

Программа должна вывести два числа : длину последовательности и сумму чётных чисел.

Eotova 24 окт. 2021 г., 16:34:30 | 10 - 11 классы

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел , кратных 9, их сумму и среднее значение по модулю?

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел , кратных 9, их сумму и среднее значение по модулю.

Программа получает на вход целые числа, колличество введнных чисел неизвестно, последовательность чисел заканчиваеться числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30 000.

Программа должна вывести : количество четных чисел, кратных 9, их сумму и среднее значение по модулю.

Lerasviridova15 18 мая 2021 г., 13:16:10 | 5 - 9 классы

Задание - составить программу в pascalвводишь два числа а и б?

Задание - составить программу в pascal

вводишь два числа а и б.

При чем а < б.

Надо вывести квадраты всех чисел между а и б.

Александра981 6 мар. 2021 г., 01:26:07 | 5 - 9 классы

1. Напишите программу, которая в последовательности натуральных чисел определяет количество всех нечётных чисел, кратных 7?

1. Напишите программу, которая в последовательности натуральных чисел определяет количество всех нечётных чисел, кратных 7.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Программа должна вывести одно число : количество всех чётных чисел, кратных 7.

Gukolga 8 июн. 2021 г., 21:10:42 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число?

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число.

Программа получает на вход кол - во чисел в последовательности, а затем сами числа.

В последовательности всегда имеется четное число.

Кол - во чисел не превышает 1000.

Введенные числа не превышают 30 000.

Программа должна вывести одно число - максимальное четное число.

Пример работы программы : Входные данные Выходные данные 3 _______________42 10 99 42

ну чтобы она работала , ребят , и с writeln(.

А то не понятно что куда вводить.

Kirill221102 24 дек. 2021 г., 17:04:58 | 10 - 11 классы

Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3?

Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3.

Программа получает на вход целые числа.

Количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30000.

Программа должна вывести одно число : количество четных чисел, кратных 3.

Тамела 22 мар. 2021 г., 12:42:30 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет количество четных отрицательных чисел?

Напишите программу, которая в последовательности целых чисел определяет количество четных отрицательных чисел.

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа не превышают 30 000.

Программа должна вывести одно число : количество четных отрицательнх чисел

Пример работы программы

Входные данные - 17 2 - 6 0

Выходные данные

1

С.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Вводится натуральное число, не превышающее 1 млрд?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.