Вводятся два натуральных числа?

Информатика | 5 - 9 классы

Вводятся два натуральных числа.

Если оба числа чётные, то вывести большее из них.

Если оба числа не чётные, то вывести меньшее из них.

Если одно чётное, а другое не чётное, то вывести их произведение на экран.

Ответить на вопрос
Ответы (2)
Лера3405 12 сент. 2021 г., 12:21:37

Program n1 ;

var a, b : integer ;

begin

readln(a, b) ;

if(a mod 2 = 0) and (b mod 2 = 0) then

if a>b then write(a) else if b>a then write(b) ;

if(a mod 20) and (b mod 20)

then if a.

Zarinazetenova 12 сент. 2021 г., 12:21:38

Var

a, b : integer ;

begin

write('Введите 2 натуральных числа : ') ;

readln(a, b) ;

if (a > 0) and (b > 0) then

begin

if (a mod 2 = 0) and (b mod 2 = 0) then

if a > b then writeln(a)

else writeln(b)

else if (a mod 2 = 1) and (b mod 2 = 1) then

if a < b then writeln(a)

else writeln(b)

else writeln(a * b) ;

end

else

writeln('Натуральное число - это все целые числа больше 0!

') ;

end.

Greenroo 19 февр. 2021 г., 10:05:22 | 5 - 9 классы

Паскаль ЗАДАЧА 1 Найти и вывести на экран все чётные числа из промежутка от 30 до 48 ЗАДАЧА 2 Найти и вывести на экран числа кратные 3 из промежутка от 30 до 55?

Паскаль ЗАДАЧА 1 Найти и вывести на экран все чётные числа из промежутка от 30 до 48 ЗАДАЧА 2 Найти и вывести на экран числа кратные 3 из промежутка от 30 до 55.

Genyaenot 9 февр. 2021 г., 04:47:15 | 10 - 11 классы

Сначала вводится кол - во чисел?

Сначала вводится кол - во чисел.

Затем вводятся сами числа.

Вывести кол - во чётные.

Написать в JavaScript.

A1a3a4a5a6a7a8a9 14 янв. 2021 г., 00:19:13 | 10 - 11 классы

Блок схема алгоритма - задача такая, нужно вывести все чётные числа от а до б включительно?

Блок схема алгоритма - задача такая, нужно вывести все чётные числа от а до б включительно.

DressT 28 июн. 2021 г., 00:33:58 | 5 - 9 классы

Написать программу в паскале : Вывести на экран натуральные чётные числа от 10 до 80(While)?

Написать программу в паскале : Вывести на экран натуральные чётные числа от 10 до 80(While).

Aliyaturdieva 24 мар. 2021 г., 13:22:21 | 5 - 9 классы

Нужно вывести на экран натуральные числа и их квадраты до указанного целого числа n?

Нужно вывести на экран натуральные числа и их квадраты до указанного целого числа n.

Mowennik 26 июн. 2021 г., 20:02:33 | 5 - 9 классы

В первой строке вводится натуральное чило nВывести на экран - произведение нечетных цифр числа(считается, что хотя бы одна нечетная цифра в числе имеется) На C + + пж?

В первой строке вводится натуральное чило n

Вывести на экран - произведение нечетных цифр числа

(считается, что хотя бы одна нечетная цифра в числе имеется) На C + + пж.

Nensi133 10 авг. 2021 г., 10:51:22 | 10 - 11 классы

Вывести на экран чётные элементы массива?

Вывести на экран чётные элементы массива.

Рассчитать и вывести их произведение

СДЕЛАТЬ ПРОГРАММУ И БЛОК - СХЕМУ!

ПОЖАЛУЙСТА, ПОМОГИТЕ!

Юля1996гр 19 сент. 2021 г., 04:30:50 | 5 - 9 классы

Помогите пожалуйста с задачей с массивом :Задан одномерный массив А (10), заполненный целыми числами?

Помогите пожалуйста с задачей с массивом :

Задан одномерный массив А (10), заполненный целыми числами.

Вывести на экран только чётные его элементы.

P. S.

Числа вводим с клавиатуры.

Natysyaaa 24 июн. 2021 г., 01:06:14 | 5 - 9 классы

Вводится два целых числа a и b ; вывести, какое из них большее?

Вводится два целых числа a и b ; вывести, какое из них большее.

Если числа равны, тогда вывести "числа равны".

Целочисленный тип - integer.

Taticool505 12 дек. 2021 г., 21:20:14 | 5 - 9 классы

С клавиатуры вводится натуральное чётное число n, не превосходящее 180?

С клавиатуры вводится натуральное чётное число n, не превосходящее 180.

Определите n - ую цифру в ряду : 1011121314…9899.

В данном ряду подряд выписаны все двузначные числа.

На экран вывести одно число – искомую цифру.

Если вам необходимо получить ответ на вопрос Вводятся два натуральных числа?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.