Составить процедуру - функцию и основную программу для вычисления значения выражения и вывода их на экран : при x = 0, 1 ; 0 ; 1, 5?

Информатика | 5 - 9 классы

Составить процедуру - функцию и основную программу для вычисления значения выражения и вывода их на экран : при x = 0, 1 ; 0 ; 1, 5.

Написать программу нужно в Pascal ABC (важно именно ABC).

Ответить на вопрос
Ответы (1)
Оксанана 5 июн. 2020 г., 07:11:25

PascalABC.

Net с максимумом "фишек" :

function f(x : double) : double ;

begin result : = (3 * x + 2 * x + 5) / (cos(x) - sin(x)) + power(x, 3) { Cкорее всего, в условии ошибка и должно быть не 3х, а 3x ^ 2, тогда надо числитель писать как (3 * sqr(x) + 2 * x + 5) }

end ;

var x : double ;

begin foreach x in [0.

1, 0, 1.

5] do Writeln('x = ', x : 3 : 1, ' y = ', f(x) : 0 : 5)

end.

Результат выполнения программы :

x = 1.

5 y = - 10.

11288

x = 0.

1 y = 6.

14508

x = 0.

0 y = 5.

00000

Обратите внимание, что порядок следования х не такой,

как указан в программе : элементы множества

считаются неупорядоченными и компилятор вправе

располагать их произвольно.

Более традиционное решение

function f(x : double) : double ;

begin result : = (3 * x + 2 * x + 5) / (cos(x) - sin(x)) + power(x, 3) { Cкорее всего, в условии ошибка и должно быть не 3х, а 3x ^ 2, тогда надо числитель писать как (3 * sqr(x) + 2 * x + 5) }

end ;

const a : array[1.

3] of double = (0.

1, 0, 1.

5) ;

var i : integer ;

begin for i : = 1 to 3 do Writeln('x = ', a[i] : 3 : 1, ' y = ', f(a[i]) : 0 : 5)

end.

Результат выполнения программы :

x = 0.

1 y = 6.

14508

x = 0.

0 y = 5.

00000

x = 1.

5 y = - 10.

11288.

Laisrem13 8 дек. 2020 г., 23:51:41 | 10 - 11 классы

Pascal abc Написать программу, которая бы вводила с клавиатуры два символа и выводила на экран тот, код которого больше (использовать операцию сравнения символов)?

Pascal abc Написать программу, которая бы вводила с клавиатуры два символа и выводила на экран тот, код которого больше (использовать операцию сравнения символов).

Maxkz 9 нояб. 2020 г., 18:58:30 | 10 - 11 классы

Pascal ABC написать программу?

Pascal ABC написать программу.

LIZA061299 7 мая 2020 г., 11:59:26 | 5 - 9 классы

Задача по информатике, нужно решить на pascal ABC?

Задача по информатике, нужно решить на pascal ABC.

И я не понимаю!

Помогите!

Условие :

составить программу, которая выводит на экран значение выражения X - в десятой степени, при условии X< ; 5

?

Evashva 22 нояб. 2020 г., 02:20:56 | 5 - 9 классы

Составить программу, которая запрашивает предложение и выводит на экран все его буквы "и"?

Составить программу, которая запрашивает предложение и выводит на экран все его буквы "и".

Программу составить при помощи Pascal ABC.

Sabrinakotsk1 27 сент. 2020 г., 00:02:27 | 5 - 9 классы

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC?

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу, которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.

121399 24 июл. 2020 г., 15:12:27 | 10 - 11 классы

Pascal ABC : процедура Составьте программу вычисления выражения y = , используя процедуру?

Pascal ABC : процедура Составьте программу вычисления выражения y = , используя процедуру.

Жранкель 28 февр. 2020 г., 01:03:04 | 5 - 9 классы

Составьте программу (в Pascal ABC), которая выводит на экран дату в рамке ?

Составьте программу (в Pascal ABC), которая выводит на экран дату в рамке :

Katerinaasanov 26 июн. 2020 г., 15:48:47 | 10 - 11 классы

Помогите с информатикой, пожалуйстааа Нужно написать программу в Pascal ABC?

Помогите с информатикой, пожалуйстааа Нужно написать программу в Pascal ABC.

09877012 23 нояб. 2020 г., 17:03:47 | 5 - 9 классы

Написать программы в PASCAL ABC?

Написать программы в PASCAL ABC.

Galyam 11 дек. 2020 г., 06:51:18 | 5 - 9 классы

Написать программу в Pascal ABC?

Написать программу в Pascal ABC.

Вычисление квадратного корня.

Данные ввести с клавиатуры.

Вопрос Составить процедуру - функцию и основную программу для вычисления значения выражения и вывода их на экран : при x = 0, 1 ; 0 ; 1, 5?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.