Выяснить, есть ли в массиве, заданном случайным образом, чётные числа и выдать на экран эти элементы массива?

Информатика | 5 - 9 классы

Выяснить, есть ли в массиве, заданном случайным образом, чётные числа и выдать на экран эти элементы массива.

(Паскаль).

Ответить на вопрос
Ответы (1)
Жан1111111 21 авг. 2021 г., 02:38:19

Const max = 100 ;

var a : array[1.

Max] of integer ; i, k, n : integer ;

begin write('размер массива n = ') ; readln(n) ; randomize ; writeln('массив : ') ; for i : = 1 to n do begin a[i] : = random( - 50, 50) ; write(a[i], ' ') ; end ; writeln ; k : = 0 ; writeln('четные числа : ') ; for i : = 1 to n do if a[i] mod 2 = 0 then begin write(a[i], ' ') ; k : = k + 1 ; end ; if k = 0 then writeln('нет четных чисел') ;

end.

Denverrr93 21 мар. 2021 г., 00:22:47 | 5 - 9 классы

1. Задать массив М(9) случайными числами от 21 до 47?

1. Задать массив М(9) случайными числами от 21 до 47.

2. Уменьшить на 3 элементы массива.

3. Увеличить на 50 элементы массива.

Сабриник 30 янв. 2021 г., 10:40:35 | 5 - 9 классы

Опишите на Паскале алгоритм вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из ?

Опишите на Паскале алгоритм вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и чётные, и нечётные элементы).

Criroi 8 авг. 2021 г., 00:07:25 | 1 - 4 классы

Заполните массив 15 случайными целыми числами из промежутка [1, 20]?

Заполните массив 15 случайными целыми числами из промежутка [1, 20].

Выведите на экран элементы массива через 2 пробела .

Найдите количество элементов массива , равных 3.

(Pascal ABC).

Ростелек 8 сент. 2021 г., 00:48:08 | 1 - 4 классы

Заполните массив 12 случайными целыми числами из промежутка [ - 10, 10]?

Заполните массив 12 случайными целыми числами из промежутка [ - 10, 10].

Выведите на экран элементы массива через пробел .

Найдите сумму элементов массива , находящихся на четных позициях.

Юля1996гр 19 сент. 2021 г., 04:30:50 | 5 - 9 классы

Помогите пожалуйста с задачей с массивом :Задан одномерный массив А (10), заполненный целыми числами?

Помогите пожалуйста с задачей с массивом :

Задан одномерный массив А (10), заполненный целыми числами.

Вывести на экран только чётные его элементы.

P. S.

Числа вводим с клавиатуры.

ValeryaN2002 8 июн. 2021 г., 06:33:35 | 5 - 9 классы

ПЖЖЖЖЖ?

ПЖЖЖЖЖ.

Одномерные Массивы.

Через паскаль abc.

Найти сумму элементов массива с четными номерами, содержащего 12 элементов.

Элементы вводятся случайным образом.

Наумыч 4 авг. 2021 г., 20:44:03 | 5 - 9 классы

Нужна помощь : )Напишите программу вывода на экран элементов одномерного целочисленного массива из 25 - ти элементов и нахождения числа элементов этого массива, которые при делении на 5 дают остаток 2?

Нужна помощь : )

Напишите программу вывода на экран элементов одномерного целочисленного массива из 25 - ти элементов и нахождения числа элементов этого массива, которые при делении на 5 дают остаток 2.

Элементы массива задаются генератором случайных чисел.

Len46 4 июл. 2021 г., 22:23:57 | 5 - 9 классы

Одномерный целочисленный массив из 15 элементов задан случайным образом на отрезке от 0 до 200 найдите минимальный элемент этого массива?

Одномерный целочисленный массив из 15 элементов задан случайным образом на отрезке от 0 до 200 найдите минимальный элемент этого массива!

Maksutova75 27 дек. 2021 г., 22:48:00 | 10 - 11 классы

Найти сумму элементов массива, кратных заданному числу?

Найти сумму элементов массива, кратных заданному числу.

Использовать для заполнения массива датчик случайных чисел.

Использовать клавиатурный ввод для заданного числа.

Распечатывать все введенные элементы массива.

Anastasiyafrenov 18 нояб. 2021 г., 06:43:58 | студенческий

Помогите пожалуйста, срочно?

Помогите пожалуйста, срочно!

Подсчитать количество чётных элементов массива, заданного датчиком случайных чисел.

Паскаль.

На этой странице находится вопрос Выяснить, есть ли в массиве, заданном случайным образом, чётные числа и выдать на экран эти элементы массива?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.