Дан массив из 16 целых чисел, заполнить его так что бы первый был равен 1, второй - 2 а каждый следующий сумме двух предыдущих?

Информатика | 5 - 9 классы

Дан массив из 16 целых чисел, заполнить его так что бы первый был равен 1, второй - 2 а каждый следующий сумме двух предыдущих.

Ответить на вопрос
Ответы (1)
Fenomenov777 30 нояб. 2020 г., 07:26:57

Var i : integer ;

a : array [1.

16] of integer ;

begin

a[1] : = 1 ;

a[2] : = 2 ;

for i : = 3 to 16 do

a[i] : = a[i - 1] + a[i - 2] ;

for i : = 1 to 16 do

write(a[i], ' ') ;

end.

Седдааа 7 апр. 2020 г., 01:01:43 | 5 - 9 классы

Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три?

Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три.

Ziraa 25 авг. 2020 г., 00:45:56 | 10 - 11 классы

Среди чисел последовательности 1 , 2, 3, 5, 8, 13?

Среди чисел последовательности 1 , 2, 3, 5, 8, 13.

(каждый следующий член последовательности равен сумме двух предыдущих ) найдите количество чисел до первого 6 - значного Pascal abc.

Владленка76 28 мая 2020 г., 03:15:05 | 10 - 11 классы

Напишите программу формирования и вывода массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен сумме двух предыдущих элементов?

Напишите программу формирования и вывода массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен сумме двух предыдущих элементов.

Два первых элемента задайте с клавиатуры.

Напишите программу формирования и вывода массива размером 6х3, каждые три последовательных элемента в строке которого составлены по следующему правилу : 1 - й - равен случайному числу, отличному от нуля ; 2 - й - равен квадрату предыдущего элемента ; 3 - й - равен целой части частного от деления двух предыдущих элементов.

Лялясик 7 дек. 2020 г., 12:26:44 | 10 - 11 классы

Помогите разобраться, пожалуйста Заполните массив из 10 чисел через генератор случайных чисел в диапазоне от 1 до 10 и найдите, на сколько сумма первых 5 чисел больше суммы вторых?

Помогите разобраться, пожалуйста Заполните массив из 10 чисел через генератор случайных чисел в диапазоне от 1 до 10 и найдите, на сколько сумма первых 5 чисел больше суммы вторых.

Заполните массив из 10 чисел через генератор случайных чисел в диапазоне от 1 до 10 и найдите разность между первым и последним элементами.

Заполните массив из 10 чисел через генератор случайных чисел в диапазоне от 1 до 10 и найдите квадратный корень из суммы первых 2 элементов

Заполните массив из 10 чисел вручную и найдите, частное первого и последнего элементов.

Заполните массив из 10 чисел вручную и найдите, частное суммы первого и последнего элементов на пятый элемент.

Пингвин8 6 сент. 2020 г., 06:55:47 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

ПОМОГИТЕ ПОЖАЛУЙСТА!

Получить и записать в массив первые 10 чисел Фибоначчи (первые два числа равны 1, а каждое последующее - сумме двух предыдущих).

Glebdrokin 27 янв. 2020 г., 18:50:45 | 10 - 11 классы

Напишите программу, Дан целый одномерный массив А, неотрицательных чисел, с индексами от 1 до 6?

Напишите программу, Дан целый одномерный массив А, неотрицательных чисел, с индексами от 1 до 6.

Заполнить данный массив с клавиатуры, найти и вывести наименьшую нечетную сумму двух соседних элементов массива.

AikaEf 24 мая 2020 г., 19:16:02 | 5 - 9 классы

Дана последовательность чисел : первый элемент равен 1, каждый следующий в 2 раза больше предыдущего?

Дана последовательность чисел : первый элемент равен 1, каждый следующий в 2 раза больше предыдущего.

Найдите сумму первых 10 членов последовательности.

Иными словами S = 1 + 2 + 4.

+ 512.

Kagazbaeva 5 мар. 2020 г., 11:06:41 | 10 - 11 классы

(Pascal) Дан двухмерный массив целых чисел?

(Pascal) Дан двухмерный массив целых чисел.

Определить является ли сумма элементов первого столбца нечетным числом.

Annaborash2003 19 сент. 2020 г., 13:21:30 | 10 - 11 классы

Помогите решить задачу в Pascal Дан массив целых чисел, состоящий из 30 элементов?

Помогите решить задачу в Pascal Дан массив целых чисел, состоящий из 30 элементов.

Заполнить его датчиком случайных чисел.

Найти сумму отрицательных элементов.

Anzhelika190320 5 дек. 2020 г., 06:52:12 | 5 - 9 классы

Создать одномерный массив A из 10 целых чисел (по формуле - первый член равен 5, а каждый следующий больше предыдущего на 22)?

Создать одномерный массив A из 10 целых чисел (по формуле - первый член равен 5, а каждый следующий больше предыдущего на 22).

Перед вами страница с вопросом Дан массив из 16 целых чисел, заполнить его так что бы первый был равен 1, второй - 2 а каждый следующий сумме двух предыдущих?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.