Напишите программу формирования и вывода массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен сумме двух предыдущих элементов?

Информатика | 10 - 11 классы

Напишите программу формирования и вывода массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен сумме двух предыдущих элементов.

Два первых элемента задайте с клавиатуры.

Напишите программу формирования и вывода массива размером 6х3, каждые три последовательных элемента в строке которого составлены по следующему правилу : 1 - й - равен случайному числу, отличному от нуля ; 2 - й - равен квадрату предыдущего элемента ; 3 - й - равен целой части частного от деления двух предыдущих элементов.

Ответить на вопрос
Ответы (1)
Afon9l 28 мая 2020 г., 03:15:07

1. var a : array [1.

100] of integer ;

i, n : integer ;

begin

read(n) ; {количество эл.

Массива}

read (a[1], a[2]) ;

for i : = 3 to n do

a[i] : = a[i - 1] + a[i - 2] ;

for i : = 1 to n do

write (a[i], ' ' ) ;

end.

2. const m = 6 ; n = 3 ;

var a : array [1.

100, 1.

100] of integer ;

i, j : integer ;

begin

for i : = 1 to m do

read (a[i, 1]) ;

for i : = 1 to m do

begin

j : = 1 ;

a[i, j + 1] : = sqr(a[i, j]) ;

a[i, j + 2] : = a[i, j] div a[i, j + 1] ; {это условие мне не совсем понятно}

end ;

for i : = 1 to m do

begin

for j : = 1 to n do

write (a[i, j] : 3) ;

writeln ; end ;

end.

Boginskayavp 17 мар. 2020 г., 15:31:22 | 5 - 9 классы

Составьте программу , которая позволяет вводить с клавиатуры элементы массива а [1?

Составьте программу , которая позволяет вводить с клавиатуры элементы массива а [1.

12], а затем выводит на экран в первую строку первые пять элементов массива, во вторую - остальные пять элементов.

Katrin2008 19 июл. 2020 г., 23:46:05 | 10 - 11 классы

ПАСКАЛЬ АБС?

ПАСКАЛЬ АБС!

СРОЧНО!

ПОМОГИТЕ ПОЖАЛУЙСТА!

1. напишите программу формирования массива размером 5 * 5 с помощью датчика случайных чисел.

Замените в нем нечетные значения элементов максимальным.

Выведите на экран исходный и измененный массивы.

2. Составьте программу формирования и вывода на печать одномерного массива, состоящего из максимальных элементов строк двумерного массива, заданного с помомщью датчика случайных чисел.

Класс2003 31 июл. 2020 г., 05:56:09 | 10 - 11 классы

Напишите программу формирования и вывода двумерного массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен сумме двух предыдущих элементов?

Напишите программу формирования и вывода двумерного массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен сумме двух предыдущих элементов.

Два первых элемента задайте с клавиатуры.

Anastasia1995ZZZ 7 нояб. 2020 г., 01:55:16 | 5 - 9 классы

Напишите программу ввода элементов массива случайным образом и вывода элементов только тех которые кратны 5?

Напишите программу ввода элементов массива случайным образом и вывода элементов только тех которые кратны 5.

LapshovaMasha 11 мая 2020 г., 20:44:59 | 10 - 11 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

1. Сформируйте и выведите на экран массив из девяти элементов.

Каждые три последовательных элемента которого составлены по следующему правилу : 1 - й равен случайному трехзначному числу, деленному на 2 ; 2 - й равен текущему индексу, уменьшенному в 10 раз ; 3 - й равен сумме двух предыдущих элементов ; 2.

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел.

Получите новый массив, каждый элемент которого равен сумме соответствующего исходного элемента и его индекса исходного массива.

В полученном массиве удвойте элементы, которые меньше заданного с клавиатуры числа А, и найдите их сумму.

Выведите на экран исходные и полученные результаты.

Vika19973 10 февр. 2020 г., 04:51:12 | 10 - 11 классы

Pascal ABC?

Pascal ABC.

Написать программу, которая находит сумму четных элементов массива произвольного размера (размер и элементы массива вводятся с клавиатуры).

Popinono 22 янв. 2020 г., 04:19:33 | 5 - 9 классы

Сформулируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлен по следующему правилу : первый равен 500 ; второй равен целой части квадратного ко?

Сформулируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлен по следующему правилу : первый равен 500 ; второй равен целой части квадратного корня из предыдущего элемента ; третий равен целой части от деления текущего индекса на три части (если она равна нулю, то соответствующий элемент массива делать равным 1).

Lyubaosharovo4 11 дек. 2020 г., 20:38:50 | 5 - 9 классы

Напишите программу, которая заполняет массив размерностью 40 следующими данными : Элемент №1 - №5 - целыми числа, введенные пользователем Элемент №6 - №10 - случайными целыми числами (из диапазона от ?

Напишите программу, которая заполняет массив размерностью 40 следующими данными : Элемент №1 - №5 - целыми числа, введенные пользователем Элемент №6 - №10 - случайными целыми числами (из диапазона от 0 до 10) Элемент №11 - №15 - случайными целыми числами (из диапазона от - 10 до 0) Элемент №16 - №20 - случайными целыми числами (из диапазона от 20 до 50) Элемент №21 - №25 - случайные целые числа (из диапазона от - 50 до - 20) Элемент №21 - №25 - правило заполнения : каждый элемент массива равен сумме двух следующих.

Элемент №31 - №40 - правило заполнения : каждый элемент массива равен квадрату своего индекса.

Весь массив выводится на экран в одну строку.

Текст программы прислать в ответ на данное задание.

Маша1203 28 авг. 2020 г., 13:18:59 | 5 - 9 классы

Составьте программу ввода с клавиатуры элементов массива а [1?

Составьте программу ввода с клавиатуры элементов массива а [1.

10] и вывода элементов массива на экран в столбец.

Люда256 22 нояб. 2020 г., 18:07:49 | 5 - 9 классы

Составьте программу для создания и вывода на экран массива из 15 элементов, каждый элемент которого записывается следующим образом : первый элемент равен 10, а каждый последующий элемент равен квадрат?

Составьте программу для создания и вывода на экран массива из 15 элементов, каждый элемент которого записывается следующим образом : первый элемент равен 10, а каждый последующий элемент равен квадрату предыдущего.

На этой странице находится ответ на вопрос Напишите программу формирования и вывода массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен сумме двух предыдущих элементов?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.