Инвертированное к некоторому натуральному числу X - это число, в котором все цифры исходного числа Х заптсаны в обратном порядке, если у результата есть лидирующие нули, они отбрасываются?

Информатика | 10 - 11 классы

Инвертированное к некоторому натуральному числу X - это число, в котором все цифры исходного числа Х заптсаны в обратном порядке, если у результата есть лидирующие нули, они отбрасываются.

Обозначим такое число Х1.

Наришите прогрпмму которая сравнивает Х и Х1.

Ответить на вопрос
Ответы (1)
Dimasbozhko08 12 апр. 2021 г., 04:04:04

/ / PascalABC.

NET 3.

2 сборка 1318

Var x, x1, i : integer ; xs : string ; c : char ;

begin

readln(x) ;

xs : = inttostr(x) ;

for i : = 1 to length(xs) div 2 do begin c : = xs[i] ; xs[i] : = xs[length(xs) - i + 1] ; xs[length(xs) - i + 1] : = c ; end ;

x1 : = strtoint(xs) ;

if x1> ; x then writeln(x1, '> ; ', x) else if x1< ; x then writeln(x, '> ; ', x1) else writeln(x1, ' = ', x) ;

end.

Пример ввода :

1230

Пример вывода :

1230> ; 321.

Xezer 14 июн. 2021 г., 02:19:27 | 10 - 11 классы

ПОМОГИТЕ ПОЖАЛУЙСТА?

ПОМОГИТЕ ПОЖАЛУЙСТА!

ОЧЕНЬ СРОЧНО!

Решить с использованием подпрограммы.

Заменить данное натуральное число на число, которое получается из исходного записью его цифр в обратном порядке (например, дано число 156, нужно получить 651).

PopovaEkaterin 5 июл. 2021 г., 02:19:13 | 10 - 11 классы

В файле “data?

В файле “data.

Pas” хранятся натуральные числа, разделенные пробелами.

Прочитать первое натуральное число и вывести запись цифр числа в обратном порядке.

Желательно делфи.

Galysa 11 июл. 2021 г., 07:41:11 | 5 - 9 классы

6. Некоторый алгоритм из одного числа получает новое число следующим образом?

6. Некоторый алгоритм из одного числа получает новое число следующим образом.

Сначала записывается исходное число, а затем к нему приписываются цифры исходного числа в обратном порядке, а в конец числа дописывается столько единиц, сколько нечётных цифр в исходном числе.

Получившееся число является результатом работы алгоритма.

Например, если исходное число было 325, то результатом работы алгоритма будет число 32552311.

Дано число 25.

Сколько единиц будет содержаться в итоговом числе, если к исходному числу применить описанный алгоритм трижды (т.

Е. применить алгоритм к данному числу, а затем к результату вновь применить алгоритм и т.

Д. )?

Круть12 2 мая 2021 г., 16:32:38 | 5 - 9 классы

Некоторый алгоритм из одного числа получает новое число следующим образом?

Некоторый алгоритм из одного числа получает новое число следующим образом.

Сначала записывается исходное число, а затем к нему приписываются цифры исходного числа в обратном порядке, а в конец числа дописывается столько единиц, сколько нечётных цифр в исходном числе.

Получившееся число является результатом работы алгоритма.

Например, если исходное число было 325, то результатом работы алгоритма будет число 32552311.

Дано число 25.

Сколько единиц будет содержаться в итоговом числе, если к исходному числу применить описанный алгоритм трижды (т.

Е. применить алгоритм к данному числу, а затем к результату вновь применить алгоритм и т.

Д. )?

Зачетка 24 июл. 2021 г., 10:25:22 | 10 - 11 классы

Автомат получает на вход четырёхзначное число?

Автомат получает на вход четырёхзначное число.

По этому числу строится новое число по следующим правилам.

1. Складываются первая и вторая, а также третья и четвёртая цифры исходного числа.

2. Полученные два числа записываются друг за другом в порядке возрастания (без разделителей).

Укажите минимальное число, в результате обработки которого, автомат выдаст число 79.

Kovalenkoki 6 мар. 2021 г., 09:10:17 | 10 - 11 классы

Для данного натурального числа найдите число число, цифры которого записаны в обратном порядке?

Для данного натурального числа найдите число число, цифры которого записаны в обратном порядке.

(vba).

Sashalisagrey 10 янв. 2021 г., 22:49:45 | 10 - 11 классы

Автомат получает на вход трёхзначное число?

Автомат получает на вход трёхзначное число.

По этому числу строится новое число по следующим правилам.

1. Складываются первая и вторая, а также вторая и третья цифры исходного числа.

2. Полученные два числа записываются друг за другом в порядке убывания (без разделителей).

Пример.

Исходное число : 348.

Суммы : 3 + 4 = 7 ; 4 + 8 = 12.

Результат : 127.

Укажите наименьшее число, в результате обработки которого автомат выдаст число 81.

Tsidipowatan 17 апр. 2021 г., 21:06:51 | студенческий

Написать программу , которая выводит на экран натуральные числа от 1 до n в обратном порядке?

Написать программу , которая выводит на экран натуральные числа от 1 до n в обратном порядке.

Число можно ввести с клавиатуры.

PASCAL.

Kirik223 5 мая 2021 г., 14:42:59 | 10 - 11 классы

Написать программу, которая выводит числа от 1 до К (К - натуральное число) в убывающем порядке?

Написать программу, которая выводит числа от 1 до К (К - натуральное число) в убывающем порядке.

Asqwzx1 6 окт. 2021 г., 22:24:20 | 10 - 11 классы

Дано число а (0?

Дано число а (0.

999999999)

Вывести это число в обратном порядке.

Пример

а = 12345

Результат : 54321.

На этой странице находится вопрос Инвертированное к некоторому натуральному числу X - это число, в котором все цифры исходного числа Х заптсаны в обратном порядке, если у результата есть лидирующие нули, они отбрасываются?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.