ПОМОГИТЕ ПОЖАЛУЙСТА?

Информатика | 10 - 11 классы

ПОМОГИТЕ ПОЖАЛУЙСТА!

ОЧЕНЬ СРОЧНО!

Решить с использованием подпрограммы.

Заменить данное натуральное число на число, которое получается из исходного записью его цифр в обратном порядке (например, дано число 156, нужно получить 651).

Ответить на вопрос
Ответы (1)
Diana1h 14 июн. 2021 г., 02:19:31

Var

N : integer ;

procedure Change(varn) ;

var

n2, n3, i : integer ;

begin

i : = 1 ;

n2 : = n ;

n : = 0 ;

while n2> ; 0 begin n3 : = n2 mod 10 ; n2 : = n2 div 10 ; n : = n * i + n3 ; i : = i * 10 ; end ;

end ;

begin readln(N) ; Change(N) ; writeln(N) ;

end.

Али1998 18 янв. 2021 г., 00:05:37 | 5 - 9 классы

Даны два натуральных числа m и n?

Даны два натуральных числа m и n.

Проверить, есть ли в записи числа m цифры, одинаковые с цифрами в записи числа n.

P. S.

На языке паскаль.

Galysa 11 июл. 2021 г., 07:41:11 | 5 - 9 классы

6. Некоторый алгоритм из одного числа получает новое число следующим образом?

6. Некоторый алгоритм из одного числа получает новое число следующим образом.

Сначала записывается исходное число, а затем к нему приписываются цифры исходного числа в обратном порядке, а в конец числа дописывается столько единиц, сколько нечётных цифр в исходном числе.

Получившееся число является результатом работы алгоритма.

Например, если исходное число было 325, то результатом работы алгоритма будет число 32552311.

Дано число 25.

Сколько единиц будет содержаться в итоговом числе, если к исходному числу применить описанный алгоритм трижды (т.

Е. применить алгоритм к данному числу, а затем к результату вновь применить алгоритм и т.

Д. )?

BFaqPkgoEzmbL 31 мар. 2021 г., 09:42:12 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Найдите первую цифру числа.

Napalkova01 30 мая 2021 г., 11:14:25 | 10 - 11 классы

ПОМОГИТЕ, ПОЖАЛУЙСТА?

ПОМОГИТЕ, ПОЖАЛУЙСТА!

ОЧЕНЬ СРОЧНО!

Найти все натуральные числа, не превосходящие заданного n, которые делятся на каждую из своих цифр.

С использованием подпрограммы.

Круть12 2 мая 2021 г., 16:32:38 | 5 - 9 классы

Некоторый алгоритм из одного числа получает новое число следующим образом?

Некоторый алгоритм из одного числа получает новое число следующим образом.

Сначала записывается исходное число, а затем к нему приписываются цифры исходного числа в обратном порядке, а в конец числа дописывается столько единиц, сколько нечётных цифр в исходном числе.

Получившееся число является результатом работы алгоритма.

Например, если исходное число было 325, то результатом работы алгоритма будет число 32552311.

Дано число 25.

Сколько единиц будет содержаться в итоговом числе, если к исходному числу применить описанный алгоритм трижды (т.

Е. применить алгоритм к данному числу, а затем к результату вновь применить алгоритм и т.

Д. )?

Nik8754 30 мар. 2021 г., 00:07:17 | 5 - 9 классы

Дано натуральное число n?

Дано натуральное число n.

Найдите минимальное натуральное число, которое ровно в n раз больше суммы своих цифр Паскаль срочно.

Kovalenkoki 6 мар. 2021 г., 09:10:17 | 10 - 11 классы

Для данного натурального числа найдите число число, цифры которого записаны в обратном порядке?

Для данного натурального числа найдите число число, цифры которого записаны в обратном порядке.

(vba).

Solomnikovigor 6 февр. 2021 г., 16:08:53 | 5 - 9 классы

С клавиатуры вводится натуральное число ?

С клавиатуры вводится натуральное число .

Найдите последнюю цифру числа.

Входные данные : введите натуральное число : 371.

Выходные данные : последняя цифра 1.

Паскаль.

Пожалуйста.

Срочно.

Bobiklolik2014 10 авг. 2021 г., 17:40:31 | 10 - 11 классы

Язык Python (питон)?

Язык Python (питон)!

Очень срочно нужно!

Заранее спасибо.

1)Напишите программу, которая вводит четырёхзначное натуральное число и переставляет его первую и последнюю цифры, например, из числа 1234 должно получится число 4231.

2)Напишите программу, которая вводит четырёхзначное натуральное число и "вырезает" из него вторую цифру с начала, например, из числа 1234 должно получиться число 134.

3)Напишите программу, которая вводит четырёхзначное натуральное число и "вырезает" из него первую и последнюю цифры, например, из числа 1234 должно получиться число 23.

GameBox 25 июн. 2021 г., 01:33:01 | 5 - 9 классы

Дано натуральное число N?

Дано натуральное число N.

Сколько цифр в том числе?

Задачу решить с использованием операторов организации циклов.

Во входном потоке дано число N (N.

На этой странице вы найдете ответ на вопрос ПОМОГИТЕ ПОЖАЛУЙСТА?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.