В файле “data?

Информатика | 10 - 11 классы

В файле “data.

Pas” хранятся натуральные числа, разделенные пробелами.

Прочитать первое натуральное число и вывести запись цифр числа в обратном порядке.

Желательно делфи.

Ответить на вопрос
Ответы (1)
Klounrus686 5 июл. 2021 г., 02:19:14

Имена процедур для Delphi - после / /

var f : text ; / / TextFile

c : char ; s : string ; i : integer ;

begin

Randomize ;

assign(f, 'data.

Pas') ; / / AssignFile

reset(f) ;

s : = '' ;

c : = '0' ;

while c' ' do

begin

read(f, c) ;

s : = s + c ;

end ;

for i : = length(s) - 1 downto 1 do write(s[i]) ;

writeln ;

close(f) ; / / CloseFile

end.

Пример :

Файл data.

Pas :

130384565486 10254 658

Результат работы программы :

684565483031.

KamiVal12 4 янв. 2021 г., 01:46:47 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется сначала вывести все четные элементы, затем — нечетные.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести элементы массива в заданном порядке.

Viola11 14 июл. 2021 г., 06:51:34 | 10 - 11 классы

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр?

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Входные данные Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Числа разделяются пробелами.

Примеры Входные данные 10 20 Выходные данные 11 12 15 На паскале.

BFaqPkgoEzmbL 31 мар. 2021 г., 09:42:12 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Найдите первую цифру числа.

Sonikpanasonik33 26 мая 2021 г., 11:04:28 | 10 - 11 классы

Дано n натуральное?

Дано n натуральное.

Найти и вывести все числа в интервале от 10 до n - 1, у которых произведение всех цифр совпадает с суммой цифр данного числа.

Если таких чисел нет вывести "Нет".

Паскаль.

RuslanaBahilova 6 янв. 2021 г., 11:42:50 | 5 - 9 классы

С клавиатуры вводится натуральное число z?

С клавиатуры вводится натуральное число z.

Вычислить : количество цифр в числе z ; сумму цифр числа z ; первую и последнюю цифры числа z.

Kovalenkoki 6 мар. 2021 г., 09:10:17 | 10 - 11 классы

Для данного натурального числа найдите число число, цифры которого записаны в обратном порядке?

Для данного натурального числа найдите число число, цифры которого записаны в обратном порядке.

(vba).

Aliyaturdieva 24 мар. 2021 г., 13:22:21 | 5 - 9 классы

Нужно вывести на экран натуральные числа и их квадраты до указанного целого числа n?

Нужно вывести на экран натуральные числа и их квадраты до указанного целого числа n.

Mowennik 26 июн. 2021 г., 20:02:33 | 5 - 9 классы

В первой строке вводится натуральное чило nВывести на экран - произведение нечетных цифр числа(считается, что хотя бы одна нечетная цифра в числе имеется) На C + + пж?

В первой строке вводится натуральное чило n

Вывести на экран - произведение нечетных цифр числа

(считается, что хотя бы одна нечетная цифра в числе имеется) На C + + пж.

NextProd777 9 мая 2021 г., 07:59:44 | 5 - 9 классы

Введите семизначное натуральное число?

Введите семизначное натуральное число.

Выведите все его цифры в обратном порядке на экран.

Использовать циклический алгоритм.

Пример : Введите натуральное число : 1234567 Цифры : 7, 6, 5, 4, 3, 2, 1.

Nonm 12 дек. 2021 г., 11:56:58 | 5 - 9 классы

Задача А?

Задача А.

Двузначные числа

Вася, скучая на уроке математики, писал в тетради различные двузначные числа.

Наугад выбирая

три числа, он проверял, можно ли, суммируя первые два числа, получить третье.

Сосед по парте

отличник Костя, усложнив задачу, написал программу, которая позволяет проверить можно ли

перестановкой цифр в числах a и b, записанных Васей, получить их сумму равную c.

Входные данные

Входной файл содержит три натуральных числа : a, b, c (9< a, b, c < 100).

Числа разделены

пробелом.

Выходные данные

Если искомая перестановка цифр невозможна, вывести в выходной файл два нуля, разделенных

пробелом.

При положительном ответе необходимо вывести число x, получаемое перестановкой

цифр числа a, и число y, получаемое перестановкой цифр числа b, сумма которых равна c.

Числа x

и y выводятся в порядке неубывания и разделяются пробелом.

На этой странице находится ответ на вопрос В файле “data?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.