Дан массив, содержащий N элементов и заполненный случайными числами от - 10 до 9?

Информатика | 5 - 9 классы

Дан массив, содержащий N элементов и заполненный случайными числами от - 10 до 9.

Сформировать новый массив из значений элементов, стоящих на четных местах.

Подсчитать количество отрицательных и положительных значений элементов в новом массиве.

Ответить на вопрос
Ответы (1)
Sveraegorova 15 февр. 2020 г., 08:34:36

Var a, b : array of integer ; n, i, p, o : integer ;

begin

readln(n) ;

setlength(a, n) ;

for i : = 0 to n - 1 do a[i] : = random( - 10, 9) ;

n : = n div 2 ;

setlength(b, n) ;

for i : = 0 to n - 1 do begin b[i] : = a[2 * i] ; if b[i]> ; 0 then p + = 1 else if b[i]< ; 0 then o + = 1 ; write(b[i], ' ') ;

end ;

writeln() ;

writeln('Положительных ', p) ;

writeln('Отрицательных ', o) ;

end.

Марта221 11 сент. 2020 г., 01:42:13 | 10 - 11 классы

Заполнить двумерный массив случайными числами?

Заполнить двумерный массив случайными числами.

Размерность массива и диапазон генерации вводятся с клавиатуры.

Составить программу, которая вычисляет сумму всех элементов массива.

Затем организовать новый массив В, в котором заменить отрицательные элементы исходного массива на 1, а значения остальных элементов оставить без изменения.

Подсчитать количество замен.

Jijilow 25 июн. 2020 г., 16:50:10 | 10 - 11 классы

Дан массив из двадцати элементов, заполненный целыми числами от - 15 до 45?

Дан массив из двадцати элементов, заполненный целыми числами от - 15 до 45.

Определить количество четных элементов массива.

Klublena2011 27 июн. 2020 г., 01:58:52 | 5 - 9 классы

Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран?

Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран.

1) подсчитать количество элементов в массиве, значения которых больше 3.

2) найти сумму всех отрицательных элементов массива.

3) заменить все отрицательные элементы массива их индексами.

Вывести новый массив на экран

4)найти максимальный элемент.

Moskvina04 31 авг. 2020 г., 07:25:56 | 10 - 11 классы

Дан массив А(к)?

Дан массив А(к).

Из элементов массива А сформировать массив В таким образом : сначала поместить все отрицательные массивы элемента А, потом равные нулю, а положительные в конце.

Daryanovikova4 8 мар. 2020 г., 02:43:17 | 10 - 11 классы

Решить задачу на языке Pascal?

Решить задачу на языке Pascal.

Дан массив LL, содержащий 12 элементов вещественного типа – положительных, отрицательных и равных нулю.

Сосчитать количество ненулевых элементов массива и сформировать из них новый массив.

Найти модуль сумы элементов нового массива.

Индексацию элементов заданного массива начать с 0.

Для перебора элементов массива использовать оператор While.

154685 24 февр. 2020 г., 16:50:24 | 5 - 9 классы

Дан массив А(30)?

Дан массив А(30).

Сформировать новый массив из значений элементов массива А кратных 5.

RiGa 17 февр. 2020 г., 15:40:45 | 5 - 9 классы

Дан массив из 15 чисел заполненный случайными числами из интервала [ - 20 ; 20]?

Дан массив из 15 чисел заполненный случайными числами из интервала [ - 20 ; 20].

Определить , что больше среднее арифметическое элементов стоящих на четных местах или среднее арифметическое положительных элементов массива.

Катюшащенок 21 нояб. 2020 г., 01:23:06 | 10 - 11 классы

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элемен?

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элементов массива, расположенных между максимальным и минимальным элементами.

Сформировать из этих элементов новый массив.

Angelina21237 28 июн. 2020 г., 11:26:28 | 5 - 9 классы

Дан массив А [12] Подсчитать сумму отрицательных элементов массива?

Дан массив А [12] Подсчитать сумму отрицательных элементов массива.

Значения элементов массива целые числа от - 20 до 20 СРОЧНО!

Pro100zheka 5 нояб. 2020 г., 16:50:49 | 5 - 9 классы

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100?

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100.

Найти :

a) наименьший элемент массива и его порядковый номер ;

b) наибольший элемент массива и его порядковый номер ;

c) сумму отрицательных и положительных элементов массива ;

d) среднее арифметическое отрицательных и положительных элементов массива ;

e) количество значений отрицательных, положительных и равных нулю элементов массива ;

На этой странице сайта вы найдете ответы на вопрос Дан массив, содержащий N элементов и заполненный случайными числами от - 10 до 9?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.