Решить задачу на языке Pascal?

Информатика | 10 - 11 классы

Решить задачу на языке Pascal.

Дан массив LL, содержащий 12 элементов вещественного типа – положительных, отрицательных и равных нулю.

Сосчитать количество ненулевых элементов массива и сформировать из них новый массив.

Найти модуль сумы элементов нового массива.

Индексацию элементов заданного массива начать с 0.

Для перебора элементов массива использовать оператор While.

Ответить на вопрос
Ответы (1)
Radmir4444532 8 мар. 2020 г., 02:43:21

Var i, e : Integer ; s : Real ; LL : array [0.

11] of Real ; LL2 : array of Real ;

begin

for i : = 0 to 11 do LL[i] : = Random(101) - 100 ; i : = 0 ; e : = 0 ; while i < ; = 11 do begin if LL[i] < ; > ; 0 then begin inc(e) ; SetLength(LL2, e) ; LL2[e - 1] : = LL[i] ; s : = s + LL[i] ; end ; inc(i) ; end ; Writeln('Кол - во ненулевых элементов = ', e) ; if s < ; 0 then s : = s * - 1 ; Writeln('Mодуль сумы элементов нового массива = ', s : 0 : 3, #10#13) ; for i : = 0 to e - 1 do Write(LL2[i] : 0 : 1, ' ') ; ReadLn ;

end.

Katya43618 8 авг. 2020 г., 08:23:59 | 5 - 9 классы

Помогите решить, буду очень благодарен?

Помогите решить, буду очень благодарен.

1. Дан массив, найти произведение отрицательных элементов массива.

2. Дан массив, заменить все отрицательные элементы массива их модулями.

Primd 15 февр. 2020 г., 08:34:32 | 5 - 9 классы

Дан массив, содержащий N элементов и заполненный случайными числами от - 10 до 9?

Дан массив, содержащий N элементов и заполненный случайными числами от - 10 до 9.

Сформировать новый массив из значений элементов, стоящих на четных местах.

Подсчитать количество отрицательных и положительных значений элементов в новом массиве.

Vanoli4 11 февр. 2020 г., 07:27:15 | 10 - 11 классы

Написать программу на С + + или паскаль?

Написать программу на С + + или паскаль.

Помогите пожалуйста!

В одномерном массиве, состоящем из n вещественных элементов, вычислить : - максимальный элемент массива ; - сумма элементов массива, расположенных до последнего положительного элемента .

Сжать массив, удалив из него все элементы, модуль которых находится в интервале (a.

B). Освободившийся в конце массива элементы заполнить нулями.

Zarolik 23 авг. 2020 г., 08:39:14 | 5 - 9 классы

Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива?

Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива.

Длина массива N задается пользователем как константное выражение.

Исходные данные задать вручную или с помощью генератора случайных чисел, учитывая формат элементов массива А.

Тип результата определяется из контекста.

- Вычислить количество отрицательных элементов массива ; - сумму модулей элементов массива, расположенных после максимального элемента.

Настя2005 3 янв. 2020 г., 06:37:14 | 5 - 9 классы

Дан одномерный массив, состоящий из вещественных элементов?

Дан одномерный массив, состоящий из вещественных элементов.

Найти сумму элементов массива, расположенных до последнего положительного элемента.

Qleb 12 июн. 2020 г., 21:57:19 | 5 - 9 классы

Дан массив состоящий из 30 элементов?

Дан массив состоящий из 30 элементов.

Найти в массиве максимальный элемент, вывести его значение и номер на экран.

Отрицательный элемент массива заменить на равные по модулю положительные элементы.

Moskvina04 31 авг. 2020 г., 07:25:56 | 10 - 11 классы

Дан массив А(к)?

Дан массив А(к).

Из элементов массива А сформировать массив В таким образом : сначала поместить все отрицательные массивы элемента А, потом равные нулю, а положительные в конце.

Vikavvavel 2 сент. 2020 г., 17:18:02 | 5 - 9 классы

Написать решение на языке Pascal / Определить частное от деления суммы положительных элементов массива на модуль суммы отрицательных элементов?

Написать решение на языке Pascal / Определить частное от деления суммы положительных элементов массива на модуль суммы отрицательных элементов.

Массивы только начали проходить, написать как можно проще.

Катюшащенок 21 нояб. 2020 г., 01:23:06 | 10 - 11 классы

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элемен?

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элементов массива, расположенных между максимальным и минимальным элементами.

Сформировать из этих элементов новый массив.

Pro100zheka 5 нояб. 2020 г., 16:50:49 | 5 - 9 классы

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100?

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100.

Найти :

a) наименьший элемент массива и его порядковый номер ;

b) наибольший элемент массива и его порядковый номер ;

c) сумму отрицательных и положительных элементов массива ;

d) среднее арифметическое отрицательных и положительных элементов массива ;

e) количество значений отрицательных, положительных и равных нулю элементов массива ;

На странице вопроса Решить задачу на языке Pascal? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.