Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элемен?

Информатика | 10 - 11 классы

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элементов массива, расположенных между максимальным и минимальным элементами.

Сформировать из этих элементов новый массив.

Ответить на вопрос
Ответы (1)
Gkjjay2 21 нояб. 2020 г., 01:23:13

/ / PascalABC.

NET 3.

1, сборка 1219 от 16.

04. 2016

begin var a : = ArrRandomReal(15, - 10, 10) ; a.

Println ; Writeln ; var m : = a.

IndexMax ; var n : = a.

IndexMin ; if m> ; n then (m, n) : = (n, m) ; var b : = a[m + 1 : n] ; b.

Println ; if b.

Length> ; 0 then Writeln('П = ', b.

Aggregate(1.

0, (p, x) - > ; p * x)) else Writeln('Нет элементов между минимумом и максимумом')

end.

Тестовое решение :

8.

14904220316049 - 7.

97861530351388 6.

22268662612079 - 4.

04729378132489 - 1.

70455696606289 2.

5380224606665 9.

52389909863653 6.

96433030858838 3.

31410986991325 4.

31776128444716 - 3.

9021073439634 - 1.

69448156454343 - 8.

68306868648299 7.

89553786529952 - 0.

403709360586344

6.

96433030858838 3.

31410986991325 4.

31776128444716 - 3.

9021073439634 - 1.

69448156454343

П = 658.

932534926112.

Leto7707 19 апр. 2020 г., 12:39:50 | 5 - 9 классы

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО?

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!

1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от - 15 до 35.

Найти сумму элементов данного массива.

2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от - 15 до 35.

Найти значение максимального элемента массива.

FroZen007 14 нояб. 2020 г., 19:08:11 | 10 - 11 классы

Напишите программу пожалуйста в паскалепроизведение элементов массива, расположенных между максимальным и минимальным элементами ?

Напишите программу пожалуйста в паскале

произведение элементов массива, расположенных между максимальным и минимальным элементами ;

Vanoli4 11 февр. 2020 г., 07:27:15 | 10 - 11 классы

Написать программу на С + + или паскаль?

Написать программу на С + + или паскаль.

Помогите пожалуйста!

В одномерном массиве, состоящем из n вещественных элементов, вычислить : - максимальный элемент массива ; - сумма элементов массива, расположенных до последнего положительного элемента .

Сжать массив, удалив из него все элементы, модуль которых находится в интервале (a.

B). Освободившийся в конце массива элементы заполнить нулями.

Ssv1973 23 апр. 2020 г., 13:58:22 | 10 - 11 классы

Задача 1 В одномерном массиве , состоящем из n вещественных элементов , вычислить ; 1) номер минимального элемента ; 2) сумму элементов массива ; Преобразовать массив таким образом , чтобы сначала рас?

Задача 1 В одномерном массиве , состоящем из n вещественных элементов , вычислить ; 1) номер минимального элемента ; 2) сумму элементов массива ; Преобразовать массив таким образом , чтобы сначала располагались все элементы , модуль которых не превышает 1 , а потом - все остальные .

Задача 2 В одномерном массиве , состоящем из n вещественных элементов , вычислить ; !

) минимальный по модулю элемент массива ; 2) сумму модулей элементов массива , расположенных после первого элемента , равного нулю .

Преобразовать массив таким образом , чтобы в первой его половине располагались элементы в четных позивиях , а во второй половине - элементы , стоявшие в нечетных позициях.

Zarolik 23 авг. 2020 г., 08:39:14 | 5 - 9 классы

Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива?

Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива.

Длина массива N задается пользователем как константное выражение.

Исходные данные задать вручную или с помощью генератора случайных чисел, учитывая формат элементов массива А.

Тип результата определяется из контекста.

- Вычислить количество отрицательных элементов массива ; - сумму модулей элементов массива, расположенных после максимального элемента.

Рома127 11 апр. 2020 г., 09:47:12 | 10 - 11 классы

Посчитать сумму элементов массива, заполненного случайными числами, и произведение максимального и минимального элементов?

Посчитать сумму элементов массива, заполненного случайными числами, и произведение максимального и минимального элементов.

Настя2005 3 янв. 2020 г., 06:37:14 | 5 - 9 классы

Дан одномерный массив, состоящий из вещественных элементов?

Дан одномерный массив, состоящий из вещественных элементов.

Найти сумму элементов массива, расположенных до последнего положительного элемента.

Lisaweta 28 апр. 2020 г., 00:54:56 | 10 - 11 классы

В одномерном массиве, состоящем из n вещественных элементов, вычислить : 1) номер минимального элемента массива?

В одномерном массиве, состоящем из n вещественных элементов, вычислить : 1) номер минимального элемента массива.

010827ELINA 2 нояб. 2020 г., 22:43:09 | 5 - 9 классы

Заданы массивы А и В из N чисел (N = 10) случайным образом?

Заданы массивы А и В из N чисел (N = 10) случайным образом.

Сформировать новый массив, каждый элемент которого равен минимальному из соответствующих элементов этих массивов.

DeadGirl5 6 сент. 2020 г., 01:59:41 | 10 - 11 классы

Turbo Pascal * * * * (Дан одномерный числовой массив?

Turbo Pascal * * * * (Дан одномерный числовой массив.

Определить произведение элементов массива, расположенных между максимальным и «центральным» элементами массива (предполагается, что число элементов – нечетное и максимальный единственный).

На этой странице находится вопрос Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элемен?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.