Написать программу которая задает массив случайным образом и ищет минимальный элемент?

Информатика | 5 - 9 классы

Написать программу которая задает массив случайным образом и ищет минимальный элемент.

Ответить на вопрос
Ответы (1)
Tusumov1965 5 нояб. 2020 г., 19:32:53

Const n = 10 ;

var a : array[1.

N] of integer ;

min, i : integer ;

begin

Randomize ;

for i : = 1 to n do begin

a[i] : = random(51) ;

write(a[i], ' ') ;

end ;

writeln ;

min : = a[1] ;

for i : = 2 to n do

if a[i]< ; min then min : = a[i] ;

writeln('min = ', min) ;

end.

Пример :

26 23 27 25 35 8 40 17 43 23

min = 8.

Kayumovaadelin 7 февр. 2020 г., 19:32:14 | 5 - 9 классы

Написать программу, которая формирует случайным образом массив из N целых чисел, лежащих в диапазоне от 1 до 5, после чего на экран выводится сам массив и номера элементов, совпадающих с первым элемен?

Написать программу, которая формирует случайным образом массив из N целых чисел, лежащих в диапазоне от 1 до 5, после чего на экран выводится сам массив и номера элементов, совпадающих с первым элементом.

Lorik77 11 мая 2020 г., 06:31:08 | 10 - 11 классы

Написать двумерный массив?

Написать двумерный массив.

Найдите среднее арифметическое элементов массива заданных случайным образом [0.

20].

Menshih5536 22 июн. 2020 г., 02:08:28 | 5 - 9 классы

Напишите программу, которая случайным образом заполняет массив из 10 элементов целыми числами из диапазона [ - 6 ; 9]?

Напишите программу, которая случайным образом заполняет массив из 10 элементов целыми числами из диапазона [ - 6 ; 9].

И вывести все элементы массива на экран.

Gimsamat 5 мар. 2020 г., 20:30:55 | 5 - 9 классы

Составить программу , которая заполняет массив А[1?

Составить программу , которая заполняет массив А[1.

10] случайными целыми числами в диапазоне от 1 до 50 и выводит на экран минимальный элемент массива.

Polyakovae10 29 нояб. 2020 г., 01:20:23 | 5 - 9 классы

Задан массив из случайных чисел из ста элементов?

Задан массив из случайных чисел из ста элементов.

Найти минимальный элемент массива.

Составить блок - схему.

Cheburek98 22 дек. 2020 г., 11:54:32 | 5 - 9 классы

Написать программу, которая запрашивает массив из N элементов, а затем делает все элементы массива на минимальный элемент?

Написать программу, которая запрашивает массив из N элементов, а затем делает все элементы массива на минимальный элемент.

Протестировать программу на массивах размерностью 5 и 10 элементов.

Ольга230282 6 мая 2020 г., 11:48:16 | 5 - 9 классы

Составить программу, которая заполняет массив а [1?

Составить программу, которая заполняет массив а [1.

10] случайными целыми числами в диапазоне от 1 до 20 и находит минимальный элемент массива и его индекс.

010827ELINA 2 нояб. 2020 г., 22:43:09 | 5 - 9 классы

Заданы массивы А и В из N чисел (N = 10) случайным образом?

Заданы массивы А и В из N чисел (N = 10) случайным образом.

Сформировать новый массив, каждый элемент которого равен минимальному из соответствующих элементов этих массивов.

Катюшащенок 21 нояб. 2020 г., 01:23:06 | 10 - 11 классы

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элемен?

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элементов массива, расположенных между максимальным и минимальным элементами.

Сформировать из этих элементов новый массив.

Gubin20011 21 нояб. 2020 г., 08:01:00 | 5 - 9 классы

Написать программу, которая определяет в одномерном массиве, заполненном случайным образом, количество элементов, значения которых меньше числа, введенного с клавиатуры?

Написать программу, которая определяет в одномерном массиве, заполненном случайным образом, количество элементов, значения которых меньше числа, введенного с клавиатуры.

Если есть, то вывести эти элементы.

На этой странице сайта размещен вопрос Написать программу которая задает массив случайным образом и ищет минимальный элемент? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.