Дано натуральное число N найти количество нулей в этом числе?

Информатика | 5 - 9 классы

Дано натуральное число N найти количество нулей в этом числе.

Ответить на вопрос
Ответы (1)
IcePelmeshka 30 мар. 2020 г., 08:34:56

Var n, c : integer ;

begin c : = 0 ; read (n) ; while (n > ; 0) do begin if (n mod 10 = 0) then c : = c + 1 ; n : = n div 10 ; end ; write (c) ;

end.

Sebos 15 нояб. 2020 г., 10:40:26 | 10 - 11 классы

Паскаль?

Паскаль.

Дано число К.

Найти количество нулей.

Wowwic200 11 окт. 2020 г., 16:06:25 | 5 - 9 классы

Составить программу?

Составить программу.

Дано натуральное число n.

Подсчитать количество цифр этого числа.

Antonkhvorov 20 июн. 2020 г., 12:56:51 | 10 - 11 классы

1) дано натуральное а?

1) дано натуральное а.

Верно ли, что данное число состоит из 3 цифр?

2) дано натуральное число.

Верно ли, что в данном числе четыре цифры?

3) Даны два натуральных числа.

Определить в каком числе первая цифра больше.

4) Дано натуральное n.

Найти количество 6, входящих в данное число.

Нужно решить в программе паскаль.

Если поможет, то мы учим цикл в паскале, div, mod.

Schura97 3 июл. 2020 г., 10:20:09 | 10 - 11 классы

Помогите написать программу на PascalABCNET ВХОДНЫЕ ДАННЫЕ Задано натуральное число N?

Помогите написать программу на PascalABCNET ВХОДНЫЕ ДАННЫЕ Задано натуральное число N.

ВЫХОДНЫЕ ДАННЫЕ Определите количество нулей в его записи.

Denizqamzaeva 28 дек. 2020 г., 13:57:24 | 5 - 9 классы

Найти сумму делителей данного натурального числа?

Найти сумму делителей данного натурального числа.

Marina19821119 5 мая 2020 г., 17:14:32 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Найти количество цифр данного числа больших b(b вводится с клавиатуры).

Bekabaz 8 мар. 2020 г., 08:24:20 | 5 - 9 классы

Дано натуральное число n найти количество четных не равных нулю цифр этого числа (9 класс )напишите пожалуйста?

Дано натуральное число n найти количество четных не равных нулю цифр этого числа (9 класс )напишите пожалуйста.

Prishchepa 10 авг. 2020 г., 22:27:07 | 10 - 11 классы

3. Дано натуральное число?

3. Дано натуральное число.

Найти сумму его четных делителей и количество этих делителей.

Grandik69 22 окт. 2020 г., 12:08:56 | 5 - 9 классы

Даны три числа D?

Даны три числа D.

C. F.

Найти количество чисел больших нуля.

Sasha45u 24 нояб. 2020 г., 10:02:05 | 10 - 11 классы

2. Дано натуральное число N (N> 9)?

2. Дано натуральное число N (N> 9).

Определить количество нулей, идущих рядом в младших

разрядах данного числа N.

Например, N = 1020000.

Количество нулей равно четырем.

На этой странице находится вопрос Дано натуральное число N найти количество нулей в этом числе?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.