Задача 1?

Информатика | 5 - 9 классы

Задача 1.

Напишите программу на языке pascal : Ввести число, если это число отрицательное (например : - 5), то программа должна вывести "число - 5 отрицательное ", если число положительное (например : 452) то программа должна вывести "число 452 положительное".

На оценку 4 еще рассмотреть случай когда вводится число 0 На оценку 5 еще рассмотреть случай, когда используются метки для многократного введения чисел.

Ответить на вопрос
Ответы (1)
Maxs85 21 мая 2021 г., 10:12:25

/ / Pascal ABC.

Net

Var a : array[1.

1000] of longint ; n, i : longint ;

Begin

writeln('Введите количество чисел') ;

readln(n) ;

writeln('Введите числа') ;

for i : = 1 to n do

read(a[i]) ;

for i : = 1 to n do

if (a[i]0) then writeln('Число ', a[i], ' положительное')

else writeln('Число ', a[i], ' равно нулю') ;

End.

Zabka2 29 мар. 2021 г., 20:35:29 | 5 - 9 классы

Нужно написать программу на Pascal?

Нужно написать программу на Pascal.

Программа должна посчитать среднюю оценку ученика.

Например : "Введите ваши оценки : 54454", программа должна вывести : "Ваш средний балл : 4, 4".

Человек может вводить сколько угодно значений.

Perov04 7 авг. 2021 г., 14:20:05 | 5 - 9 классы

Пользователь вводит число n, программа должна вывести число наоборот?

Пользователь вводит число n, программа должна вывести число наоборот.

Помогите пожалуйста!

(Pascal).

Зайка113 25 июн. 2021 г., 02:01:10 | 10 - 11 классы

Напишите программу, которая в последовательности натуральных чисел определяет минимальное положительное число, кратное 5?

Напишите программу, которая в последовательности натуральных чисел определяет минимальное положительное число, кратное 5.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется положительное число, делящееся нацело на 5.

Количество чисел не превышает 1000.

Введённые числа по абсолютной величине не превышают 30 000.

Программа должна вывести одно число – минимальное положительное число, кратное 5.

Diman17114 29 мая 2021 г., 11:10:09 | 5 - 9 классы

Напишите программу, которая вводит трехзначное число и разбивает его на цифры?

Напишите программу, которая вводит трехзначное число и разбивает его на цифры.

Например, при вводе числа 123 программа должна вывести “1 2 3” (Python).

Maksim0807991 30 апр. 2021 г., 11:39:32 | 5 - 9 классы

Тест?

Тест.

На экран вывести вопрос и три варианта ответа, ввести с экрана вариант ответа.

Программа должна оценить ответ и в случае неправильного ответа написать правильный.

№2 Ввести с клавиатуры три числа, положительные возвести в квадрат, а отрицательные оставить без изменений.

№3 Ввести с клавиатуры три числа.

Вывести на экран наименьшее из них

Сделайте это на C + + плииз.

Ayqun023 10 авг. 2021 г., 20:20:15 | 10 - 11 классы

Задача : с клавиатуры вводится число от 1 до 1000?

Задача : с клавиатуры вводится число от 1 до 1000.

Программа должна вывести его прописью.

(Написать программу на Паскале).

Stetskyi1234 24 июн. 2021 г., 06:38:41 | 5 - 9 классы

Написать программу, возведения числа в квадрат, если оно положительное, иначе вывести на экран фразу, что число отрицательное?

Написать программу, возведения числа в квадрат, если оно положительное, иначе вывести на экран фразу, что число отрицательное.

Zinin08 19 июн. 2021 г., 17:01:11 | студенческий

Напишите программу, которая в последовательности целых чисел определяет максимальное отрицательное число, оканчивающееся на 2?

Напишите программу, которая в последовательности целых чисел определяет максимальное отрицательное число, оканчивающееся на 2.

Программа получает на вход двухмерный массив из 30 случайных чисел в диапазоне значений от - 160 до 160.

Программа должна вывести одно число - максимальное отрицательное число, оканчивающееся на 2 или вывести сообщение "Таких чисел нет".

Ввод и вывод массива организовать при помощи процедуры.

Gdanechka 7 апр. 2021 г., 23:01:29 | 5 - 9 классы

Напишите программу на Паскаль, которая в последовательности натуральных чисел определяет максимальное отрицательное число, оканчивающееся на 3?

Напишите программу на Паскаль, которая в последовательности натуральных чисел определяет максимальное отрицательное число, оканчивающееся на 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000.

Введенные числа по абсолютной величине не превышают 30 000.

Программа должна вывести одно число - максимальное отрицательное число, оканчивающееся на 3.

Madamgutickowa 29 нояб. 2021 г., 20:33:29 | 10 - 11 классы

10. Составить программу, осуществляющую ввод числовых переменных?

10. Составить программу, осуществляющую ввод числовых переменных.

При вводе положительного числа вывести информацию : «Число больше ноля», при вводе отрицательного числа – «Число меньше ноля», при вводе ноля – «Вы ввели ноль».

На этой странице сайта вы найдете ответы на вопрос Задача 1?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.