Задача на языке ПаскаляДано натуральное число N?

Информатика | 5 - 9 классы

Задача на языке Паскаля

Дано натуральное число N.

Напишите функцию int MinDigit (int n) (C / C + + ), function MinDigit (n : longint) : integer (Pascal) и int MaxDigit (int n) (C / C + + ), function MaxDigit (n : longint) : integer (Pascal), определяющую наименьшую и наибольшую цифры данного числа.

Формат входных данных

Задано единственное число

Формат выходных данных

Необходимо вывести наименьшую и наибольшую цифры данного числа через пробел.

Ответить на вопрос
Ответы (1)
Qwertytyqqqq 5 янв. 2020 г., 07:07:20

Сделать эту задачу можно двумя способами.

Первый - чисто арифметический.

Второй - более хитрый, через операции над строками.

Мы пойдем вторым путем, он короче и практичней, такой код будет требовать меньше ресурсов машины для реализации (что незаметно в таких маленьких задачках, но довольно критично в реальной жизни, поэтому учимся писать дальновидные коды).

Var n : longint ;

Function MinDigit(n : longint) : integer ;

var s, a : string ; c, i : integer ;

begin

str(n, s) ;

a : = s[1] ;

for i : = 2 to length(s) do if s[i]< ; a then a : = s[i] ;

val(a, n, c) ;

MinDigit : = n ;

end ;

Function MaxDigit(n : longint) : integer ;

var s, a : string ; c, i : integer ;

begin

str(n, s) ;

a : = s[1] ;

for i : = 2 to length(s) do if s[i]> ; a then a : = s[i] ;

val(a, n, c) ;

MaxDigit : = n ;

end ;

Begin

readln(n) ;

writeln(MinDigit(n), ' ', MaxDigit(n)) ;

End.

По факту переменную "c" можно убрать из функций и использовать вместо нее уже не нужную в конце "i", таким образом избавившись от одной переменной.

Но это не принципиально на самом деле, к тому жетак понятней, какая переменная за что отвечает.

Bogafan72 9 апр. 2020 г., 02:49:28 | 10 - 11 классы

Напишите функцию int reverse(int n) (C / C + + ), function reverse (n : integer) : integer (Pascal), которая переставляет цифры числа в обратном порядке ?

Напишите функцию int reverse(int n) (C / C + + ), function reverse (n : integer) : integer (Pascal), которая переставляет цифры числа в обратном порядке .

Формат входных данныхЗадано единственное числоФормат выходных данныхНеобходимо вывести цифры данного числа в обратном порядке.

Kartashovaa79 11 окт. 2020 г., 06:44:01 | 10 - 11 классы

Дано два натуральных числа N и M?

Дано два натуральных числа N и M.

Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел.

Незначащих нулей в найденном числе быть не должно.

Формат входных данных : Входной файл INPUT.

TXT содержит два натуральных числа N (10N10100) и M (10M10100), разделенных одним пробелом.

Формат выходных данных : Выходной файл OUTPUT.

TXT должен содержать найденное наименьшее число.

Лиина97 4 июн. 2020 г., 15:25:51 | 10 - 11 классы

Задается целое число N?

Задается целое число N.

Нужно вывести количество четных делителей числа N.

Формат входных данных Единственная строка входного файла содержит единственное целое число N(1< ; = N< ; = 1000) Формат выходных данных выведите ответ к задаче.

PFK 25 авг. 2020 г., 16:21:55 | 5 - 9 классы

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N?

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Формат входных данных Задано единственное число N.

Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Timi 25 мар. 2020 г., 02:44:19 | 10 - 11 классы

Дано натуральное число N ?

Дано натуральное число N .

Определить наименьшую и наибольшую цифры данного числа (Pascal ABC).

Клубничка311 29 дек. 2020 г., 21:54:23 | 5 - 9 классы

Дано натуральное трёхзначное число n?

Дано натуральное трёхзначное число n.

Найдите сумму и произведение цифр в нём.

Формат входных данных

Вводится целое число n (100≤n≤999)

Формат выходных данных

Требуется вывести сумму и произведение его цифр через пробел.

Дарья1266 15 окт. 2020 г., 09:20:24 | 5 - 9 классы

Напишите рекурсивную функцию вычисления суммы цифр натурального числа?

Напишите рекурсивную функцию вычисления суммы цифр натурального числа.

Формат входных данных На вход ваша программа получает одно натуральное число n (n< ; 216)(n< ; 216).

Формат выходных данных Выведите одно число — сумму цифр числа n.

Полинка1547 12 дек. 2020 г., 05:06:46 | 5 - 9 классы

Умоляю , Пожалуйста ?

Умоляю , Пожалуйста !

Напишите функцию int min (int a, int b, int c, int d) (C / C + + ), static int min (int a, int b, int c, int d) (Java) function min (a, b, c, d : integer) : integer (Pascal), находящую наименьшее из четырех данных чисел.

Входные данные Вводится четыре числа.

Выходные данные Необходимо вывести наименьшее из 4 - х данных чисел.

Inglis1111 12 нояб. 2020 г., 11:31:16 | 5 - 9 классы

Задача?

Задача.

Дано натуральное число N (1< ; = N< ; = 100000).

Требуется написать программу, определяющую для N, какая цифра больше – первая или последняя.

Формат входных данных : В единственной строке задано число N.

Формат выходных данных : В единственной строке необходимо вывести один символ : = , если цифры одинаковые, < ; , если первая цифра меньше последней, > ; , если первая цифра больше последней.

Akolesova2002 30 нояб. 2020 г., 01:46:11 | 5 - 9 классы

Дано натуральное число N?

Дано натуральное число N.

Напишите функцию (Pascal), вычисляющую сумму цифр числа N.

Входные данные

Задано единственное число N

Выходные данные

Необходимо вывести сумму цифр числа N.

Примеры

входные данные

12

выходные данные

3

ПРОГРАММА БЫЛА, НО ВВОДИЛ 12 И ВЫВОДИЛ ВМЕСТО 3, 0.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Задача на языке ПаскаляДано натуральное число N?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.