Используя линейный односвязный список найти введённое с клавиатуры число, удалить число стоящий перед найденным за 1 позицию и вставить число, введённый с клавиатуры, перед найденным ?

Информатика | 10 - 11 классы

Используя линейный односвязный список найти введённое с клавиатуры число, удалить число стоящий перед найденным за 1 позицию и вставить число, введённый с клавиатуры, перед найденным .

Pascal.

Ответить на вопрос
Ответы (1)
Semonjoker 15 окт. 2020 г., 10:32:29

/ / PascalABC.

NET 3.

2, сборка 1325 от 19.

10. 2016

begin var L : = new List< ; integer> ; ; Writeln('Вводите целые числа, окончание ввода по - 777') ; var n : integer ; repeat n : = ReadInteger ; if n< ; > ; - 777 then L.

Add(n) ; until n = - 777 ; Writeln('Исходный список') ; Writeln(L) ; n : = ReadInteger('Введите искомое число : ') ; var p : = L.

FindIndex(k - > ; k = n) ; / / искомый элемент if p< ; 0 then Writeln('Искомый элемент в списке не найден') else begin Writeln('Элемент ', L.

Item[p - 2], ' удален') ; L.

RemoveAt(p - 2) ; Writeln(L) ; / / удалили и убедились n : = ReadInteger('Введите число для вставки : ') ; L.

Insert(p - 1, n) ; Writeln(L) end

end.

Пример

Вводите целые числа, окончание ввода по - 777

1 6 12 73 - 15 34 18 0 24 - 777

Исходный список

[1, 6, 12, 73, - 15, 34, 18, 0, 24]

Введите искомое число : 34

Элемент 73 удален

[1, 6, 12, - 15, 34, 18, 0, 24]

Введите число для вставки : 1000

[1, 6, 12, - 15, 1000, 34, 18, 0, 24].

Anna41998 17 мая 2020 г., 10:50:55 | 5 - 9 классы

Вставить число, введённое с клавиатуры после первого отрицательного элемента массива?

Вставить число, введённое с клавиатуры после первого отрицательного элемента массива.

Если отрицательный элемент отсутствует, то вставить число в конец массива.

Volniyveter84 15 окт. 2020 г., 14:57:45 | 10 - 11 классы

Как найти среднее арифметическое однозначных чисел, введённых с клавиатуры n раз?

Как найти среднее арифметическое однозначных чисел, введённых с клавиатуры n раз?

Девочка551 25 мар. 2020 г., 13:47:38 | 5 - 9 классы

Cоставить программу определяющую является ли введённое с клавиатуры целое число чётным?

Cоставить программу определяющую является ли введённое с клавиатуры целое число чётным.

Sasa11a 28 авг. 2020 г., 17:37:38 | 1 - 4 классы

Написать программу которая определяет является ли введённое с клавиатуры натуральное число N простым числом (N< ; 32000)?

Написать программу которая определяет является ли введённое с клавиатуры натуральное число N простым числом (N< ; 32000).

Yulianna1111 22 дек. 2020 г., 01:14:39 | 5 - 9 классы

Составьте программу, определяющую, является ли введённое с клавиатуры целое число чётным?

Составьте программу, определяющую, является ли введённое с клавиатуры целое число чётным.

Olegos2000 31 мар. 2020 г., 11:07:46 | 10 - 11 классы

Для введённого с клавиатуры 6 - значного числа определить, являются ли все цифры числа нечетные?

Для введённого с клавиатуры 6 - значного числа определить, являются ли все цифры числа нечетные.

Написать программу на C + +.

Попаопопопо 20 мая 2020 г., 08:15:24 | 5 - 9 классы

1. Написать программу, которая определяет, является ли число, введённое с клавиатуры, отрицательным, вывести об этом сообщение на экран?

1. Написать программу, которая определяет, является ли число, введённое с клавиатуры, отрицательным, вывести об этом сообщение на экран.

2. Подсчитать сумму отдельно четных и нечетных чисел, введённым с клавиатуры.

Viktorianizova1606 24 нояб. 2020 г., 15:48:54 | 10 - 11 классы

Используя линейный односвязный список найти введённое с клавиатуры число, удалить число стоящий перед найденным за 1 позицию и вставить число, введённый с клавиатуры, перед найденным ?

Используя линейный односвязный список найти введённое с клавиатуры число, удалить число стоящий перед найденным за 1 позицию и вставить число, введённый с клавиатуры, перед найденным .

Pascal.

Через указатели {New(x) ; {выделение места в памяти для переменной типа Spisok} x ^ .

Data : = 3 ; { заполним поле Data первого элемента} x ^ .

Next : = Nil ; {заполним поле Next первого элемента : указатель в Nil } Head : = x ; {установим указатель головы списка на первый элемент}} - Пример.

ЮдинаСаша 3 дек. 2020 г., 02:00:05 | 5 - 9 классы

Найти сумму только четных чисел среди 10 введённых с клавиатуры?

Найти сумму только четных чисел среди 10 введённых с клавиатуры.

Kololot118 4 дек. 2020 г., 03:11:16 | 5 - 9 классы

1)Вывести числа кратные (11) от 10 до 100 в Turbo pascal2)С клавиатуры вводятся числа и последовательно перемножаются?

1)Вывести числа кратные (11) от 10 до 100 в Turbo pascal

2)С клавиатуры вводятся числа и последовательно перемножаются.

Найти кол - во введённых чисел, когда их произведение превысит 1000.

Прошу помощи.

На этой странице находится ответ на вопрос Используя линейный односвязный список найти введённое с клавиатуры число, удалить число стоящий перед найденным за 1 позицию и вставить число, введённый с клавиатуры, перед найденным ?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.