Написать программу которая определяет является ли введённое с клавиатуры натуральное число N простым числом (N< ; 32000)?

Информатика | 1 - 4 классы

Написать программу которая определяет является ли введённое с клавиатуры натуральное число N простым числом (N< ; 32000).

Ответить на вопрос
Ответы (1)
Artifex 28 авг. 2020 г., 17:37:39

Program test ;

uses utils ;

var n, i, sum, time : longint ; flag : boolean ;

begin readln(n) ; if n< ; 2 then flag : = false ; {Единица - не простое число} if n = 2 then flag : = true ; {2 - простое} if (n> ; 2) and (n mod 2 < ; > ; 0) then begin{ после двойки простые числа только нечетные} for i : = 1 to n do begin{проверяем что бы было только 2 делителя} sum : = sum + 1 ; end ; if sum = 2 then flag : = true ; end else flag : = false ; if flag then writeln('Число простое') else writeln('Число НЕ простое') ; time : = milliseconds ; writeln('Времени затрачено ', time : 10, ' ms.

') ;

end.

Все проверки сделаны для сокращения времени работы программы.

Девочка551 25 мар. 2020 г., 13:47:38 | 5 - 9 классы

Cоставить программу определяющую является ли введённое с клавиатуры целое число чётным?

Cоставить программу определяющую является ли введённое с клавиатуры целое число чётным.

Wewqeq 19 дек. 2020 г., 18:12:56 | 5 - 9 классы

Написать программу при которой с клавиатуры вводится натуральное число n не при восходящее 1000 и выводится произведение цифр этого числа?

Написать программу при которой с клавиатуры вводится натуральное число n не при восходящее 1000 и выводится произведение цифр этого числа.

Islam27061997 1 мая 2020 г., 14:57:44 | 10 - 11 классы

Программа на языке С Написать рекурсивную функцию, определяющую, является ли заданное натуральное число простым?

Программа на языке С Написать рекурсивную функцию, определяющую, является ли заданное натуральное число простым.

Миррррррр1 8 окт. 2020 г., 07:51:56 | 5 - 9 классы

Составьте программу определяющую, является ли число x простым?

Составьте программу определяющую, является ли число x простым.

Yulianna1111 22 дек. 2020 г., 01:14:39 | 5 - 9 классы

Составьте программу, определяющую, является ли введённое с клавиатуры целое число чётным?

Составьте программу, определяющую, является ли введённое с клавиатуры целое число чётным.

Olegos2000 31 мар. 2020 г., 11:07:46 | 10 - 11 классы

Для введённого с клавиатуры 6 - значного числа определить, являются ли все цифры числа нечетные?

Для введённого с клавиатуры 6 - значного числа определить, являются ли все цифры числа нечетные.

Написать программу на C + +.

Попаопопопо 20 мая 2020 г., 08:15:24 | 5 - 9 классы

1. Написать программу, которая определяет, является ли число, введённое с клавиатуры, отрицательным, вывести об этом сообщение на экран?

1. Написать программу, которая определяет, является ли число, введённое с клавиатуры, отрицательным, вывести об этом сообщение на экран.

2. Подсчитать сумму отдельно четных и нечетных чисел, введённым с клавиатуры.

Cat20051678 24 февр. 2020 г., 15:56:59 | 10 - 11 классы

Напишите программу, которая определяет, является ли введенное число простым?

Напишите программу, которая определяет, является ли введенное число простым.

Алина12532 27 авг. 2020 г., 07:19:39 | 5 - 9 классы

Составьте программу, которая определяет, является ли сумма цифр введённого целого трёхзначного числа чётным числом?

Составьте программу, которая определяет, является ли сумма цифр введённого целого трёхзначного числа чётным числом.

Zhansaya20031 11 дек. 2020 г., 19:14:02 | 10 - 11 классы

Напишите программу которая вводит с клавиатуры натуральное число n и определяет его факториал?

Напишите программу которая вводит с клавиатуры натуральное число n и определяет его факториал.

Вы находитесь на странице вопроса Написать программу которая определяет является ли введённое с клавиатуры натуральное число N простым числом (N&lt ; 32000)? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 1 - 4 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.