В целочисленных массивах a и b содержатся длины катетов десяти прямоугольных треугольников : a[i] - длина первого катета ; b[i] - длина второго катета i - го треугольника?

Информатика | 10 - 11 классы

В целочисленных массивах a и b содержатся длины катетов десяти прямоугольных треугольников : a[i] - длина первого катета ; b[i] - длина второго катета i - го треугольника.

Найдите треугольник с наибольшей площадью.

Выведите его номер, длины катетов и площадь.

Предусмотрите случай, когда таких треугольников несколько.

Ответить на вопрос
Ответы (1)
Dron96777 6 мар. 2020 г., 10:36:36

Const n = 10 ;

var a, b : array[1.

N] of integer ; i, si, smax : integer ;

begin Writeln('Введите парами длины катетов ', n, ' треугольников') ; smax : = 0 ; for i : = 1 to n do begin Read(a[i], b[i]) ; si : = a[i] * b[i] ; { пополам разделим потом максимальное } if si> ; smax then smax : = si end ; Writeln('Треугольник(и) с максимальной площадью, равной ', smax / 2, ' : ') ; for i : = 1 to n do if a[i] * b[i] = smax then Writeln('№', i, ' : ', a[i], 'x', b[i]) ; Writeln

end.

Пример работы

Введите парами длины катетов 10 треугольников

7 16 18 10 9 5 15 11 9 19 15 12 11 13 9 20 14 10 12 8

Треугольник(и) с максимальной площадью, равной 90 :

№2 : 18x10

№6 : 15x12

№8 : 9x20.

Directioner1D 9 нояб. 2020 г., 18:07:21 | 10 - 11 классы

Вычислите периметр и площадь прямоугольного треугольника по длинам двух его катетов?

Вычислите периметр и площадь прямоугольного треугольника по длинам двух его катетов.

Valeriakrivtso 13 апр. 2020 г., 00:28:43 | 5 - 9 классы

Написать программу в паскале Найти периметр и площадь прямоугольного треугольника, если даны длины его катетов a и b?

Написать программу в паскале Найти периметр и площадь прямоугольного треугольника, если даны длины его катетов a и b.

SlipKnoT98 24 апр. 2020 г., 17:26:39 | 5 - 9 классы

Составьте блок - схему алгоритма вычисления периметра и площади прямоугольного треугольника по длинам двух его катетов?

Составьте блок - схему алгоритма вычисления периметра и площади прямоугольного треугольника по длинам двух его катетов.

Нича1 24 мая 2020 г., 00:07:35 | 5 - 9 классы

Вычислить периметр и площадь прямоугольного треугольника по заданным длинам двух катетов а и b?

Вычислить периметр и площадь прямоугольного треугольника по заданным длинам двух катетов а и b.

JokerBloker 24 июн. 2020 г., 03:28:31 | 5 - 9 классы

С клавиатуры вводится 2 числа длинны катетов прямоугольного треугольника, вычислить перемитр и площадь треугольника?

С клавиатуры вводится 2 числа длинны катетов прямоугольного треугольника, вычислить перемитр и площадь треугольника?

Chapliginand 29 окт. 2020 г., 20:03:37 | 5 - 9 классы

3) заданы длины катетов треугольника?

3) заданы длины катетов треугольника.

Определить, является ли этот треугольник прямоугольным.

Формула для проверки a ^ 2 + b ^ 2 = c ^ 2.

Ronis01 26 сент. 2020 г., 19:34:21 | 10 - 11 классы

Даны катеты прямоугольного треугольника?

Даны катеты прямоугольного треугольника.

Найти его гипотенузу и площадь .

Паскаль.

Ттттт 16 сент. 2020 г., 23:47:14 | 10 - 11 классы

В прямоугольном треугольнике известны катет и гипотенуза(ввод с клавиатуры) найти другой катет?

В прямоугольном треугольнике известны катет и гипотенуза(ввод с клавиатуры) найти другой катет.

Xoma161rus 6 дек. 2020 г., 18:15:56 | 10 - 11 классы

В прямоугольном треугольнике известны катет и гипотенуза(ввод с клавиатуры) нацти другой катет?

В прямоугольном треугольнике известны катет и гипотенуза(ввод с клавиатуры) нацти другой катет.

Eakshinskaya 7 сент. 2020 г., 05:53:22 | 5 - 9 классы

В прямоугольном треугольнике известны катет и гипотенуза?

В прямоугольном треугольнике известны катет и гипотенуза.

Найдите другой катет.

Решить программным способом.

Если вам необходимо получить ответ на вопрос В целочисленных массивах a и b содержатся длины катетов десяти прямоугольных треугольников : a[i] - длина первого катета ; b[i] - длина второго катета i - го треугольника?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.