Разработать паскаль - программу, вычисляющую среднее арифметическое элементов матрицы?

Информатика | 10 - 11 классы

Разработать паскаль - программу, вычисляющую среднее арифметическое элементов матрицы.

Ответить на вопрос
Ответы (1)
DimaNiT 24 нояб. 2020 г., 06:14:18

. var

a : array [1.

100, 1.

100] of integer ;

n, m, i, j : byte ;

sr : real ;

sum : integer ;

begin clrscr ;

writeln('Введи кол - во строк : ') ;

readln(n) ;

writeln('Столобцов : ') ;

readln(m) ;

randomize ;

for i : = 1 to n do

for j : = 1 to m do a[i, j] : = random (10) + 0 ;

sum : = 0 ;

for i : = 1 to n do

for j : = 1 to m do sum : = sum + a[i, j] ;

sr : = sum / (n * m) ;

writeln('Среднее арифметичексое : ', sr) ;

readkey ;

end.

P. S.

Могу напутать с типами данных.

RotterDam 13 нояб. 2020 г., 18:48:23 | 10 - 11 классы

Ребята, девчата, тут такое затруднение?

Ребята, девчата, тут такое затруднение.

Нужна программа в паскале, только в паскале.

Условие :

Напишите программу которая вычисляет среднее арифметическое элементов таблицы А(3 * 8) .

Программа по двумерным массивам.

Marusialu 26 мар. 2020 г., 16:18:25 | 5 - 9 классы

Программа КуМир (НЕ ПАСКАЛЬ?

Программа КуМир (НЕ ПАСКАЛЬ!

КуМир!

РУССКАЯ ПРОГРАММА!

)Ввести с клавиатуры массив из 5 элементов, найти среднее арифметическое всех элементов массива.

Apvapavpva00 1 мар. 2020 г., 05:47:45 | 10 - 11 классы

Очень срочно?

Очень срочно!

Нужна ваша помощь!

Написать программу на паскале : сформировать матрицу и найти наименьшее среди средних арифметических элементов ее столбцов.

( В ответе достаточно рабочего кода).

Naka1tana 24 янв. 2020 г., 06:14:34 | 10 - 11 классы

Составить программу для нахождения среднего арифметического n элемента (паскаль)?

Составить программу для нахождения среднего арифметического n элемента (паскаль).

Карина19983012 11 июл. 2020 г., 21:10:14 | 10 - 11 классы

Напиши программу, вычисляющую среднее арифметическое заранее созданного массива случайных чисел из 10 элементов?

Напиши программу, вычисляющую среднее арифметическое заранее созданного массива случайных чисел из 10 элементов.

Ntv1978 2 окт. 2020 г., 11:05:37 | 10 - 11 классы

Очень срочно?

Очень срочно!

Нужна ваша помощь!

Написать программу на паскале : сформировать матрицу и найти наименьшее среди средних арифметических элементов ее столбцов.

( В ответе достаточно рабочего кода).

Kerimovparvaz 5 мар. 2020 г., 23:53:49 | 5 - 9 классы

Составте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет среднее арифметическое всех его элементов?

Составте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет среднее арифметическое всех его элементов.

Egor270899 28 дек. 2020 г., 14:51:34 | 5 - 9 классы

Вычислить среднее арифметическое отрицательных элементов вектора Q(21) p?

Вычислить среднее арифметическое отрицательных элементов вектора Q(21) p.

S. через программу паскаль.

Toruncova97 3 июл. 2020 г., 06:00:27 | 5 - 9 классы

Написать программу в Паскале, которая вычисляет среднее арифметическое ненулевых элементов массива М[1?

Написать программу в Паскале, которая вычисляет среднее арифметическое ненулевых элементов массива М[1.

100], элементы которого вычисляются по формуле : М[i] = sin(i) * cos(i) Очень нужно, пожалуйста.

Денис333337 13 сент. 2020 г., 17:12:06 | 10 - 11 классы

Помогите пожалуйста, я должна написать 6 лабораторных работ((?

Помогите пожалуйста, я должна написать 6 лабораторных работ((.

Написать программу на Паскале.

Дана матрица.

Вычислить среднее арифметическое четных элементов главной диагонали.

Вы открыли страницу вопроса Разработать паскаль - программу, вычисляющую среднее арифметическое элементов матрицы?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.