Вводится последовательность натуральных чисел?

Информатика | 10 - 11 классы

Вводится последовательность натуральных чисел.

Ноль – при - знак конца.

Подсчитайте, сколько раз в этой последовательности встре - чается максимальное кратное семи число, и выдайте полученный ре - зультат.

Ответить на вопрос
Ответы (1)
HunterDSK 11 янв. 2021 г., 10:42:49

Pascal / / В задании не сказано, что выводить, когда нет чисел, кратных 7, поэтому явывожу 0.

Var a, max : longint ;

begin

max : = 0 ;

a : = 1 ;

while a < ; > ; 0 do

begin

readln(a) ;

if (a mod 7 = 0)and(a> ; max) then max : = a ;

end ;

writeln(max) ;

end.

Pahan1312 18 янв. 2021 г., 20:32:48 | 5 - 9 классы

Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем?

Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем.

(a = 0 признак окончания ввода , ноль не входит в последовательность).

Программа должна вывести количество и сумму всех чисел последовательности.

Флешь223 6 февр. 2021 г., 09:20:30 | 10 - 11 классы

Вводится последовательность чисел Конец последовательности - 0 найти максимальное число?

Вводится последовательность чисел Конец последовательности - 0 найти максимальное число.

Паскаль абс.

КоМоЛоВаЮлИя 1 мар. 2021 г., 19:12:11 | 5 - 9 классы

Напишите программу, которая в последовательности натуральныхчисел определяет максимальное число, кратное 5?

Напишите программу, которая в последовательности натуральных

чисел определяет максимальное число, кратное 5.

Программа

получает на вход количество чисел в последовательности, а затем сами

числа.

В последовательности всегда имеется число, кратное 5.

Количество чисел не превышает 1000.

Введённые числа не превышают

30 000.

ТОЛЬКО ИСПОЛЬЗОВАТЬ НАДО ЦИКЛ repeat.

Asabirsyanova21pony 2 апр. 2021 г., 18:09:53 | 5 - 9 классы

С клавиатуры вводится произвольная последовательность положительных чисел за которыми слудет 0?

С клавиатуры вводится произвольная последовательность положительных чисел за которыми слудет 0.

Определить максимальное число в этой последовательности, количество четных чисел.

Dimapozzik 29 мар. 2021 г., 16:21:29 | 5 - 9 классы

Вводится последовательность чисел, признак конца ввода, ввод числа 0?

Вводится последовательность чисел, признак конца ввода, ввод числа 0.

Найти сумму чисел не кратных 7.

SOS.

Baronina79 2 сент. 2021 г., 07:23:46 | 5 - 9 классы

Напишите программу которая в последовательности натуральных чисел определяет количество всех чисел, кратных 6 и оканчивающихся на 0?

Напишите программу которая в последовательности натуральных чисел определяет количество всех чисел, кратных 6 и оканчивающихся на 0.

Программа получает на вход натуральные числа, кол - во введенных чисел неизвестно, последовательность чисел оканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Кол - во чисел не превышает 1000.

Введенные числа не превышают 30000.

Программа должна вывести одно число : кол - во всех чисел последовательности, кратных 6 и оканчивающихся на 0.

PROST100MAG 23 июн. 2021 г., 08:37:19 | 10 - 11 классы

1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел , кратных 6?

1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел , кратных 6.

Программа получает на вод натуральные числа, кол - во введенных чисел неизвестно, последовательность чисел заканчивается числом 0(0 - признак окончания ввода, не входит в последовательность).

Программа должна вывести одно число : сумма четырехзначных чисел , кратных 6.

2) Напишите программу , которая в последовательности натуральных чисел определяет максимальное число, кратно 3 и оканчивающиеся на 3.

Программа получает на вход кол - во чисел в последовательности, а заем сами числа.

В последовательности всегда имеется число, кратное 3 и оканчивающиеся на 3.

Кол - во чисел не превышает 1000.

Введенные числа не превышают 30 000.

Программа должна вывести одно число - максимальное число, кратное 3 и оканчивающиеся на 3.

Умник215 7 сент. 2021 г., 14:04:34 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5?

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 5.

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Программа должна вывести одно число — максимальное число, кратное 5.

ЯЗЫК ПРОГРАММИРОВАНИЯ PYTHON.

Kirillmashakirill 7 сент. 2021 г., 01:12:46 | 5 - 9 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается 0 (0 - признак окончания ввода, не входит в последовательность).

MrDrosh111 29 авг. 2021 г., 19:10:11 | 5 - 9 классы

Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 7 и оканчивающихся на 1?

Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 7 и оканчивающихся на 1.

Программа получает вход натуральные числа количество введённых чисел неизвестно последовательность чисел заканчивается числом 0(0 - признак окончания ввода не входит в последовательность).

Программа должна вывести одно число : сумму всех чисел кратных 7 и оканчивающихся на 1.

Вы находитесь на странице вопроса Вводится последовательность натуральных чисел? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.