Даю 30 баллов?

Информатика | 5 - 9 классы

Даю 30 баллов!

Написать программу для определения количества корней квадратного уравнения по коэффициентам a, b, c.

Ответить на вопрос
Ответы (2)
Alon22222 19 янв. 2020 г., 11:01:57

Program yrav ; var a, b, c, d, x1, x2, x : real ; begin writeln('Введите коэффиценты квадратного уравнения') ; readln(a, b, c) ; d : = b * b - 4 * a * c ; if d< ; 0 then writeln('корней нет') ; if (d> ; 0) and (a< ; > ; 0)and (b< ; > ; 0)and (c< ; > ; 0) then begin x1 : = ( - b + sqrt(d)) / (2 * a) ; x2 : = ( - b - sqrt(d)) / (2 * a) ; writeln('X1 = ', x1 : 6 : 3, ' X2 = ', x2 : 6 : 3) ; end ; if (a = 0)and(b< ; > ; 0)and(c< ; > ; 0) then begin x = - c / b ; writeln('Один корень уравнения Х = ', x : 6 : 3) ; end ; if (b = 0)and(c< ; 0) and(a< ; > ; 0) then begin x1 = sqrt( - c / a) ; x2 = - sqrt( - c / a) ; writeln('X1 = ', x1 : 6 : 3, ' X2 = ' , x2 : 6 : 3) ; end else writeln('Корней нет!

') ; if (a< ; > ; 0) and(b< ; > ; 0)and(c = 0) then begin x1 : = 0 ; x2 : = - b / a ; writeln('X1 = ', x1 : 6 : 3, ' X2 = ', x2 : 6 : 3) ; end ; end.

Викториямайер 19 янв. 2020 г., 11:02:04

/ / PascalABC.

NET 3.

1, сборка 1218 от 12.

04. 2016

begin var a, b, c : real ; Writeln('Введите коэффициенты квадратного уравнения (a b c)') ; Read(a, b, c) ; if a = 0 then begin Writeln('а = 0 делает уравнение линейным') ; if b = 0 then Writeln('Корней нет') else Writeln('Один корень ') end else begin var d : = b * b - 4 * a * c ; if d< ; 0 then Writeln('Нет действительных корней') else if d = 0 then Writeln('Один корень') else Writeln('Два корня') end

end.

Jordan02 9 июл. 2020 г., 22:44:31 | 10 - 11 классы

Номер 6?

Номер 6.

Составьте программу вычисления корней квадратного уравнения по данным значениям его коэффициентов( по программе Паскаль ) ПОМОГИТЕ ПОЖАЛУЙСТА !

NikOMON 2 февр. 2020 г., 23:09:12 | 10 - 11 классы

Коэффициенты a, b, c вводятся с клавиатуры?

Коэффициенты a, b, c вводятся с клавиатуры.

На экране выводится информация о значении корней квадратного уравнения.

_СОСТАВЬТЕ ПРОГРАММУ ПАСКАЛЬ.

Vgorelova62 29 мая 2020 г., 13:15:20 | 5 - 9 классы

1)составьте программу сортировки по озрастанию значений трех переменных : А, В, С 2) составьте программу вычислений корней квадратного уравнения по данным значениям его коэффициентов ребят помогите)?

1)составьте программу сортировки по озрастанию значений трех переменных : А, В, С 2) составьте программу вычислений корней квадратного уравнения по данным значениям его коэффициентов ребят помогите).

Beni 3 авг. 2020 г., 01:38:20 | 5 - 9 классы

Написать программу вычисления корней квадратного уравнения коэффициенты abc?

Написать программу вычисления корней квадратного уравнения коэффициенты abc.

Svetagribanova 5 окт. 2020 г., 00:16:31 | 5 - 9 классы

Срочно?

Срочно!

Помогите пожалуйста!

Программы паскаля

составьте программу решения квадратного уравнения ax2 + bx + c = 0 Коэффициенты a в с введите с клавиатуры.

Выведите на экран значения корней x1 x2 если уравнение имеет два корня, значение x, если уравнение имеет один корень, или сообщение "Нет корней", если уравнение не имеет корней.

Анна111556 23 мая 2020 г., 20:12:25 | 1 - 4 классы

Помогите пожалуйста с информатикой?

Помогите пожалуйста с информатикой!

Как находить корни квадратного уравнения в программе Паскаль!

Akk20152015 4 февр. 2020 г., 07:18:27 | 10 - 11 классы

Написать программу определения суммы двух введенных с клавиатуры чисел?

Написать программу определения суммы двух введенных с клавиатуры чисел.

(1 балл) Составить алгоритм и написать программу для нахождения суммы членов ряда (2 балла) : S = 5 + 6 + 7 + 8 + 9 + .

+ 28 Написать программу определения суммы цифр и количества цифр в заданном натуральном числе.

(3 балла).

KateBarnaeva 19 сент. 2020 г., 00:50:30 | 5 - 9 классы

Помогитеее?

Помогитеее!

Написать алгоритм и программу любого квадратного уравнения.

Annaharchenko 28 мар. 2020 г., 08:44:56 | 10 - 11 классы

Написать на Паскале программу для нахождения квадратного корня?

Написать на Паскале программу для нахождения квадратного корня.

Galyam 11 дек. 2020 г., 06:51:18 | 5 - 9 классы

Написать программу в Pascal ABC?

Написать программу в Pascal ABC.

Вычисление квадратного корня.

Данные ввести с клавиатуры.

На этой странице сайта размещен вопрос Даю 30 баллов? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.