Номер 6?

Информатика | 10 - 11 классы

Номер 6.

Составьте программу вычисления корней квадратного уравнения по данным значениям его коэффициентов( по программе Паскаль ) ПОМОГИТЕ ПОЖАЛУЙСТА !

Ответить на вопрос
Ответы (1)
Ortanov17 9 июл. 2020 г., 22:44:35

Var a, b, c, d : real ;

begin write('Введите значения коэффициентов квадратного уравнения : ') ; readln(a, b, c) ; if a = 0 then writeln('Это не квадратное уравнение!

') else begin D : = b * b - 4 * a * c ; if D > ; 0 then begin writeln('Уравнение имеет два корня : ') ; writeln('x1 = ', ( - b - sqrt(D)) / (2 * a)) ; writeln('x2 = ', ( - b + sqrt(D)) / (2 * a)) ; end else if D = 0 then begin writeln('Ураннение имеет один корень : ') ; writeln('x = ', - b / (2 * a)) ; end else writeln('Уравнение не имеет действительных корней') ; end ;

end.

НеВассерман1704 12 мар. 2020 г., 01:24:36 | 5 - 9 классы

Помогите, пожалуйста Составьте программу в паскале для вычисления квадратного корня из х?

Помогите, пожалуйста Составьте программу в паскале для вычисления квадратного корня из х.

NikOMON 2 февр. 2020 г., 23:09:12 | 10 - 11 классы

Коэффициенты a, b, c вводятся с клавиатуры?

Коэффициенты a, b, c вводятся с клавиатуры.

На экране выводится информация о значении корней квадратного уравнения.

_СОСТАВЬТЕ ПРОГРАММУ ПАСКАЛЬ.

Vgorelova62 29 мая 2020 г., 13:15:20 | 5 - 9 классы

1)составьте программу сортировки по озрастанию значений трех переменных : А, В, С 2) составьте программу вычислений корней квадратного уравнения по данным значениям его коэффициентов ребят помогите)?

1)составьте программу сортировки по озрастанию значений трех переменных : А, В, С 2) составьте программу вычислений корней квадратного уравнения по данным значениям его коэффициентов ребят помогите).

Наталия210 21 янв. 2020 г., 02:34:11 | 10 - 11 классы

Составьте программу вычисления суммы всех двузначных чисел?

Составьте программу вычисления суммы всех двузначных чисел.

Для Паскаля.

Beni 3 авг. 2020 г., 01:38:20 | 5 - 9 классы

Написать программу вычисления корней квадратного уравнения коэффициенты abc?

Написать программу вычисления корней квадратного уравнения коэффициенты abc.

Svetagribanova 5 окт. 2020 г., 00:16:31 | 5 - 9 классы

Срочно?

Срочно!

Помогите пожалуйста!

Программы паскаля

составьте программу решения квадратного уравнения ax2 + bx + c = 0 Коэффициенты a в с введите с клавиатуры.

Выведите на экран значения корней x1 x2 если уравнение имеет два корня, значение x, если уравнение имеет один корень, или сообщение "Нет корней", если уравнение не имеет корней.

Анна111556 23 мая 2020 г., 20:12:25 | 1 - 4 классы

Помогите пожалуйста с информатикой?

Помогите пожалуйста с информатикой!

Как находить корни квадратного уравнения в программе Паскаль!

VerochkaZubareva 2 сент. 2020 г., 06:44:45 | 1 - 4 классы

Составьте программу на вычисление числа 9 в степени, паскаль?

Составьте программу на вычисление числа 9 в степени, паскаль.

Annaharchenko 28 мар. 2020 г., 08:44:56 | 10 - 11 классы

Написать на Паскале программу для нахождения квадратного корня?

Написать на Паскале программу для нахождения квадратного корня.

Galyam 11 дек. 2020 г., 06:51:18 | 5 - 9 классы

Написать программу в Pascal ABC?

Написать программу в Pascal ABC.

Вычисление квадратного корня.

Данные ввести с клавиатуры.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Номер 6?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.