Срочно?

Информатика | 5 - 9 классы

Срочно!

Помогите пожалуйста!

Программы паскаля

составьте программу решения квадратного уравнения ax2 + bx + c = 0 Коэффициенты a в с введите с клавиатуры.

Выведите на экран значения корней x1 x2 если уравнение имеет два корня, значение x, если уравнение имеет один корень, или сообщение "Нет корней", если уравнение не имеет корней.

Ответить на вопрос
Ответы (1)
SV123456 5 окт. 2020 г., 00:16:33

Var a, b, c, d, x1, x2 : real ;

begin Write('Введите через пробел значения a, b, c : ') ; Readln(a, b, c) ; d : = sqr(b) - 4 * a * c ; if d < ; 0 then Writeln('Нет действительных корней') else if d = 0 then Writeln('Один корень ', - b / (2 * a)) else begin d : = sqrt(d) ; x1 : = ( - b - d) / (2 * a) ; x2 : = ( - b + d) / (2 * a) ; Writeln('x1 = ', x1, ', x2 = ', x2) end

end.

Тестовое решение :

Введите через пробел значения a, b, c : 4 3.

2 - 2

x1 = - 1.

2124038404636, x2 = 0.

412403840463596

$ax^2+bx+c=0 \\ D=b^2-4ac \\ x= \frac{-b\mp \sqrt{D}}{2a}$.

НеВассерман1704 12 мар. 2020 г., 01:24:36 | 5 - 9 классы

Помогите, пожалуйста Составьте программу в паскале для вычисления квадратного корня из х?

Помогите, пожалуйста Составьте программу в паскале для вычисления квадратного корня из х.

Krokodil65 13 окт. 2020 г., 09:42:39 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста.

Напишите программу по которой из текстового файла с именем kvur.

Txt будут прочитаны три числа : a, b, c - коэффициенты квадратного уравнения затем будут вычислены корни этого уравнения и выведены на экран и в текстовый файл korni.

Txt. на паскале.

Jordan02 9 июл. 2020 г., 22:44:31 | 10 - 11 классы

Номер 6?

Номер 6.

Составьте программу вычисления корней квадратного уравнения по данным значениям его коэффициентов( по программе Паскаль ) ПОМОГИТЕ ПОЖАЛУЙСТА !

NikOMON 2 февр. 2020 г., 23:09:12 | 10 - 11 классы

Коэффициенты a, b, c вводятся с клавиатуры?

Коэффициенты a, b, c вводятся с клавиатуры.

На экране выводится информация о значении корней квадратного уравнения.

_СОСТАВЬТЕ ПРОГРАММУ ПАСКАЛЬ.

Vgorelova62 29 мая 2020 г., 13:15:20 | 5 - 9 классы

1)составьте программу сортировки по озрастанию значений трех переменных : А, В, С 2) составьте программу вычислений корней квадратного уравнения по данным значениям его коэффициентов ребят помогите)?

1)составьте программу сортировки по озрастанию значений трех переменных : А, В, С 2) составьте программу вычислений корней квадратного уравнения по данным значениям его коэффициентов ребят помогите).

Beni 3 авг. 2020 г., 01:38:20 | 5 - 9 классы

Написать программу вычисления корней квадратного уравнения коэффициенты abc?

Написать программу вычисления корней квадратного уравнения коэффициенты abc.

Nikita11042000 8 дек. 2020 г., 12:38:15 | 10 - 11 классы

Напишите пожалуйста программу, которая вычислит корни квадратного уравнения?

Напишите пожалуйста программу, которая вычислит корни квадратного уравнения.

А, b, c вводим с клавиатуры.

(на паскале).

Анна111556 23 мая 2020 г., 20:12:25 | 1 - 4 классы

Помогите пожалуйста с информатикой?

Помогите пожалуйста с информатикой!

Как находить корни квадратного уравнения в программе Паскаль!

Valera6 9 июл. 2020 г., 01:07:16 | 5 - 9 классы

Составьте программу решения квадратного уравнения ax(x - в квадрате) + + bx + c = 0?

Составьте программу решения квадратного уравнения ax(x - в квадрате) + + bx + c = 0.

Коэффициенты a, b, c введите с клавиатуры.

Выведите на экран ЗНачения корней x1, x2, если уравнение имеет два корня, значение x, если уравнение имеет один корень, или сообщение < ; Нет корней> ; , если уравнение не имеет корней.

Nailkarimovf 19 янв. 2020 г., 11:01:56 | 5 - 9 классы

Даю 30 баллов?

Даю 30 баллов!

Написать программу для определения количества корней квадратного уравнения по коэффициентам a, b, c.

Если вам необходимо получить ответ на вопрос Срочно?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.