Вводится натуральное число?

Информатика | 10 - 11 классы

Вводится натуральное число.

Определить, является ли оно пол - ным квадратом.

Ответ выдать в форме YES | NO.

Ответить на вопрос
Ответы (1)
Zlo1111 2 сент. 2020 г., 03:52:48

Const m : array[false.

True] of String[3] = (' NO', 'YES') ;

Var n : Integer ;

Begin Readln(n) ; Writeln(m[n = sqr(trunc(sqrt(n)))]) ;

end.

Elena1986502 2 июл. 2020 г., 02:58:22 | 5 - 9 классы

Дано число А?

Дано число А.

Определить, является ли оно простым (простое это натуральное число имеющие ровно два различных натуральных делителя : пшеницы и само себя).

Otlichnayk 26 мая 2020 г., 10:12:34 | 5 - 9 классы

С клавиатуры вводится натуральное число n выясните является ли оно квадратом какого то натурального числа если является то выведите это число если нет то вывести - 1 например 4 является квадратом 2 а ?

С клавиатуры вводится натуральное число n выясните является ли оно квадратом какого то натурального числа если является то выведите это число если нет то вывести - 1 например 4 является квадратом 2 а 17 не является квадратом никакого числа.

Shkaranliza4 12 сент. 2020 г., 03:49:44 | 5 - 9 классы

Напишите программу в с + + с помощью switch : Пользователь вводит число?

Напишите программу в с + + с помощью switch : Пользователь вводит число.

Определить, является ли оно четным.

VOVA105 25 дек. 2020 г., 03:20:54 | 5 - 9 классы

Определить сумму квадратов первых N натуральных чисел (N вводится с клавиатуры)?

Определить сумму квадратов первых N натуральных чисел (N вводится с клавиатуры).

Kirilacs 21 янв. 2020 г., 18:21:52 | 10 - 11 классы

1. пользователь вводит натуральное число?

1. пользователь вводит натуральное число.

Определить среднее арифметическое цифр этого числа.

2. пользователь вводит натуральное число N.

Найти сумму всех натуральных чисел от 1 до N.

Galiyaabasheva 24 сент. 2020 г., 06:54:28 | 5 - 9 классы

Пользователь вводит целое число?

Пользователь вводит целое число.

Если оно является четным и при этом не находиться между 10 и 20, то вывести на экран его квадрат.

В противном случае напечатать исходное число.

Katushalovely 7 нояб. 2020 г., 20:37:54 | 10 - 11 классы

Вводится натуральное число?

Вводится натуральное число.

Определить, является ли оно полным квадратом.

Pascal.

TinkiVinkiDomosed 23 нояб. 2020 г., 17:40:40 | 10 - 11 классы

Вводится натуральное число?

Вводится натуральное число.

Определить, является ли оно пол - ным квадратом.

Ответ выдать в форме YES | NO.

Nikita234596 21 июл. 2020 г., 11:29:08 | 10 - 11 классы

Натуральное число называется совершенным, если оно равно сумме всех своих делителей, включая единицу и исключая само себя?

Натуральное число называется совершенным, если оно равно сумме всех своих делителей, включая единицу и исключая само себя.

Вводится натуральное число.

Проверьте его на совершенство и выдайте ответ «Да» или «Нет».

Подсчитайте количество операций в вашем ал - горитме и выпишите его в виде функции от параметра n, где n – вводи - мое число.

Плюс два балла за правильный эффективный алгоритм про - верки числа.

Arikemm1 25 окт. 2020 г., 13:47:10 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить является ли оно палиндромом.

Написать процедуру получения нового числа.

Паскаль.

На этой странице находится вопрос Вводится натуральное число?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.