Натуральное число называется совершенным, если оно равно сумме всех своих делителей, включая единицу и исключая само себя?

Информатика | 10 - 11 классы

Натуральное число называется совершенным, если оно равно сумме всех своих делителей, включая единицу и исключая само себя.

Вводится натуральное число.

Проверьте его на совершенство и выдайте ответ «Да» или «Нет».

Подсчитайте количество операций в вашем ал - горитме и выпишите его в виде функции от параметра n, где n – вводи - мое число.

Плюс два балла за правильный эффективный алгоритм про - верки числа.

Ответить на вопрос
Ответы (1)
Evelinastar 21 июл. 2020 г., 11:29:09

Var n, sum, del : integer ;

n1 : real ;

begin

sum : = 0 ;

repeat writeln ('Введите число') ; readln(n1) ;

until (n1> ; 0)and(n1 = round(n1)) ;

n : = round(n1) ;

for del : = 1 to n - 1 do / / ищем делители включая единицу и исключая само число

begin if (n mod del = 0) then / / если делится sum : = sum + del ; / / учитываем в сумме

end ;

if sum = n then writeln('Да')

else writeln('Нет')

end.

Вроде так, если я не сильно упорота.

Laylaakberova 15 янв. 2020 г., 02:13:56 | 5 - 9 классы

Натуральное число называется совершенным, если оно равно сумме всех своих собственных делителей, т?

Натуральное число называется совершенным, если оно равно сумме всех своих собственных делителей, т.

Е. делителей отличных от самого числа.

Примером совершенного числа является, например, 6 = 1 + 2 + 3.

Напишите программу, позволяющую вычислить, когда наступит следуюций совершенный год.

Salta3053005 16 нояб. 2020 г., 19:48:20 | 5 - 9 классы

Вывести все совершенные числа в промежутке от 1 до 100 ?

Вывести все совершенные числа в промежутке от 1 до 100 .

Совершенное число это натуральное число равное сумме своих собственных делителей(отличных от самого числа).

Kirilacs 21 янв. 2020 г., 18:21:52 | 10 - 11 классы

1. пользователь вводит натуральное число?

1. пользователь вводит натуральное число.

Определить среднее арифметическое цифр этого числа.

2. пользователь вводит натуральное число N.

Найти сумму всех натуральных чисел от 1 до N.

1Aruzhan3 21 дек. 2020 г., 05:14:14 | 5 - 9 классы

С клавиатуры вводится целое число K (K< ; = 5)?

С клавиатуры вводится целое число K (K< ; = 5).

Найти и вывести на экран первые К совершенных числа.

Совершенное число - - натурально число, равное сумме всех своих собственных делителей (т.

Е. всех положительных делителей, отличных от самого числа).

Лаура200011 29 мар. 2020 г., 12:30:09 | 5 - 9 классы

С клавиатуры вводится натуральное число n?

С клавиатуры вводится натуральное число n.

Посчитать сумму натурального числа от 1 до n?

DoonPop 22 нояб. 2020 г., 08:12:52 | 5 - 9 классы

С клавиатуры вводятся два натуральных числа a, b (a< ; = b)?

С клавиатуры вводятся два натуральных числа a, b (a< ; = b).

Найти в диапазоне от a до b (включая границы) число, имеющее максимальную сумму делителей.

(PASCAL) с применением функции.

TinkiVinkiDomosed 23 нояб. 2020 г., 17:40:40 | 10 - 11 классы

Вводится натуральное число?

Вводится натуральное число.

Определить, является ли оно пол - ным квадратом.

Ответ выдать в форме YES | NO.

Donierakramov 2 нояб. 2020 г., 04:52:03 | 5 - 9 классы

Для каждого натурального числа в промежутке [m ; n] вывести все делители, кроме единицы и самого числа?

Для каждого натурального числа в промежутке [m ; n] вывести все делители, кроме единицы и самого числа.

M и n вводятся с клавиатуры.

Выводить в формате число : делители.

MakShagun 2 сент. 2020 г., 03:52:47 | 10 - 11 классы

Вводится натуральное число?

Вводится натуральное число.

Определить, является ли оно пол - ным квадратом.

Ответ выдать в форме YES | NO.

TrueRocker 20 июл. 2020 г., 05:40:36 | 5 - 9 классы

С клавиатуры вводятся два натуральных числа a, b (a< ; = b)?

С клавиатуры вводятся два натуральных числа a, b (a< ; = b).

Найти в диапазоне от a до b (включая границы) число, имеющее максимальную сумму делителей.

(PASCAL).

На этой странице сайта вы найдете ответы на вопрос Натуральное число называется совершенным, если оно равно сумме всех своих делителей, включая единицу и исключая само себя?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.