Pascal?

Информатика | 5 - 9 классы

Pascal.

Даны три переменные вещественного типа : A, B, C.

Если их значения упо - рядочены по возрастанию или убыванию, то удвоить их ; в противном слу - чае заменить значение каждой переменной на противоположное.

Вывести новые значения переменных A, B, C.

Ответить на вопрос
Ответы (1)
Nastena20051231 18 мар. 2020 г., 02:48:48

Var a, b, c : real ;

begin Write('Введите через пробел три числа - > ; ') ; Readln(a, b, c) ; if ((a > ; b) and (b > ; c)) or ((a < ; b) and (b < ; c)) then begin a : = 2 * a ; b : = 2 * b ; c : = 2 * c end else begin a : = - a ; b : = - b ; c : = - c end ; writeln('Новые значения чисел : ', a, ', ', b, ', ', c)

end.

Тестовое решение :

Введите через пробел три числа - > ; 18 5 - 3

Новые значения чисел : 36, 10, - 6

Введите через пробел три числа - > ; - 6 0 5

Новые значения чисел : - 12, 0, 10

Введите через пробел три числа - > ; 11 20.

7 4. 9

Новые значения чисел : - 11, - 20.

7, - 4.

9.

Kristikkostrom 20 июн. 2020 г., 22:39:43 | 5 - 9 классы

1)присвоить переменой А сумму переменных В и С2)удвоить значение переменной х3)значение переменной х увеличить на 0?

1)присвоить переменой А сумму переменных В и С

2)удвоить значение переменной х

3)значение переменной х увеличить на 0.

1.

Sacha152002 6 июн. 2020 г., 00:06:14 | 10 - 11 классы

Составьте блок - схему алгоритма решения задачи и программу на языке Turbo Pascal, ввод данных организовать с клавиатуры?

Составьте блок - схему алгоритма решения задачи и программу на языке Turbo Pascal, ввод данных организовать с клавиатуры.

Поменять местами значения переменных А и B.

Вывести новые значения А и B.

Anastasiyanastiya 26 июн. 2020 г., 15:49:01 | 5 - 9 классы

Что происходит с предыдущим значением переменной после присваивания ей нового значения?

Что происходит с предыдущим значением переменной после присваивания ей нового значения?

Bsbannerok 7 дек. 2020 г., 15:41:03 | 1 - 4 классы

Написать программу, которая сможет определить, есть ли среди цифр заданного целого трёхзначного числа одинаковые?

Написать программу, которая сможет определить, есть ли среди цифр заданного целого трёхзначного числа одинаковые.

Даны три переменные вещественного типа : A, B, C.

Если их значения упорядочены по возрастанию или убыванию, то удвоить их ; в противном случае заменить значение каждой переменной на противоположное.

Вывести новые значения переменных A, B, C.

Костя0512 7 июл. 2020 г., 23:31:23 | 1 - 4 классы

Как в pascal в if прописать несколько значений переменной?

Как в pascal в if прописать несколько значений переменной.

Gfgeufq1 19 февр. 2020 г., 06:47:29 | 5 - 9 классы

Даны две переменные целого типа : A и B?

Даны две переменные целого типа : A и B.

Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения.

Вывести новые значения переменных A и B.

Надюшкабрюсова 9 мар. 2020 г., 16:44:41 | 10 - 11 классы

С# даны три переменные : x, y, z(входные данные)?

С# даны три переменные : x, y, z(входные данные).

Если их значения упорядочены по убыванию, то удвоить их.

В противном случае заменить значение каждой переменной на противоположное.

Pkirill57 4 янв. 2020 г., 21:32:30 | 5 - 9 классы

Задание1?

Задание1.

Значение переменной Х ввести с клавиатуры.

Переменной У присвоить значение 5.

Вывести на экран информацию «знач.

Х» + 5 = «итог.

Сумма».

Задание 2.

Переменной Х присвоить значение 7.

Переменной Р присвоить значение, равное квадрату Х.

Вывести значения переменных Х и Р (через запятую).

Значение Х увеличить на Х.

Переменной Р присвоить значение, равное корню квадратному из Х.

Вывести значения переменных Х и Р (через запятую).

DIKTANT 2 Задание 1.

Значение переменной Х присвоить в программе.

При неотрицательном значении Х переменной У присвоить значение, равное корню квадратному из Х.

В противном случае, переменной У присвоить значение, равное квадрату Х.

Вывести на экран значение Х и значение У.

Задание 2.

Двум произвольным переменным присвоить произвольным образом соответственно 2 числа.

Двум другим переменным присвоить значения, равные тангенсам двух предыдущих переменных.

Вывести на экран значения всех переменных, а так же сумму значений двух последних переменных.

Помогите сделать пож.

Просто1111111115 29 февр. 2020 г., 23:22:03 | 5 - 9 классы

СДЕЛАТЬ В PACKALABC Даны значения трех вещественных переменных а, b и с Обменять местами их значения при этом нельзя использовать никаких дополнительных переменных (a = b, b = c, c = a)?

СДЕЛАТЬ В PACKALABC Даны значения трех вещественных переменных а, b и с Обменять местами их значения при этом нельзя использовать никаких дополнительных переменных (a = b, b = c, c = a).

Goreff839 17 мар. 2020 г., 08:11:30 | 10 - 11 классы

PascalAbc?

PascalAbc.

Net написать программу Ввода - Вывода.

1. Разработать программу, которая предлагает пользователю ввести с клавиатуры значения трех переменных х1, х2, х3 (оператор readln()).

2. Выводит введенные значения в строчку, отводя на каждое число 6 позиций.

При этом необходимо вывести имена соответствующих переменных.

3. Присваивает переменным новые значения 42, 7 и 34 соответственно.

4. Выводит новые значения переменных в столбик, отводя для каждого значения 4 позиции.

При этом необходимо вывести имена соответствующих переменных.

Вы перешли к вопросу Pascal?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.