Пожалуйста?

Информатика | 5 - 9 классы

Пожалуйста!

Напишите линейную программу, в результате выполнения которой целочисленные переменные х и у об меняются значениями.

При этом нельзя использовать дополнительные переменные .

Найдя такой алгоритм, определите, в чем его недостаток по сравнению с методом обмена через третью переменную .

Можно ли его ли его применять для вещественных чисел?

Ответить на вопрос
Ответы (1)
Elinabataeva1 22 нояб. 2020 г., 12:29:46

Var a, b ; integer ;

Begin

Read(a, b) ;

A : = a + b ;

B : = a - b ;

A : = a - b ;

Write(a, b) ;

End.

Mmjulia123 18 июн. 2020 г., 09:37:40 | 10 - 11 классы

. Определите значение переменной a после выполнения фрагмента алгоритма ?

. Определите значение переменной a после выполнения фрагмента алгоритма :

Yamalinamarin 15 июн. 2020 г., 10:27:39 | 5 - 9 классы

Определите значения переменных х и у после выполнения фрагмента алгоритма?

Определите значения переменных х и у после выполнения фрагмента алгоритма.

Dilyadolmatova 15 февр. 2020 г., 11:35:40 | 5 - 9 классы

Напишите линейную программу, в результате выполнения которой целочисленные переменные x и y обмениваются значениями?

Напишите линейную программу, в результате выполнения которой целочисленные переменные x и y обмениваются значениями.

При этом нельзя использовать дополнительные переменные.

Arina19741 27 дек. 2020 г., 01:37:41 | 5 - 9 классы

Напишите линейную программу в результате выполнения которой в целочисленной переменной S получится перевернутое целое четырехзначное число k?

Напишите линейную программу в результате выполнения которой в целочисленной переменной S получится перевернутое целое четырехзначное число k.

Например : если k = 1357, то S = 7531.

Xxx1999 17 авг. 2020 г., 23:42:05 | 5 - 9 классы

Помогите))) 1) Определите значение переменной k после выполнения фрагмента алгоритма?

Помогите))) 1) Определите значение переменной k после выполнения фрагмента алгоритма.

2) Определите значение переменной s после выполнения фрагмента алгоритма.

Liliy1087 17 февр. 2020 г., 23:17:16 | 5 - 9 классы

Определите значение целочисленной переменной d после выполнения фрагмента алгоритма?

Определите значение целочисленной переменной d после выполнения фрагмента алгоритма.

Danja97 3 апр. 2020 г., 06:26:22 | 5 - 9 классы

Составьте программу, которая считывает с клавиатуры значения переменных а и b, затем меняет между собой значения этих переменных и выводит их на экран, без использования третьей переменной?

Составьте программу, которая считывает с клавиатуры значения переменных а и b, затем меняет между собой значения этих переменных и выводит их на экран, без использования третьей переменной.

Наидочка2015 26 авг. 2020 г., 07:08:07 | 5 - 9 классы

Определите значение переменной x после выполнения фрагмента алгоритма?

Определите значение переменной x после выполнения фрагмента алгоритма.

Lisyan 11 окт. 2020 г., 17:46:45 | 10 - 11 классы

Определите значение переменной s после выполнения фрагмента алгоритма?

Определите значение переменной s после выполнения фрагмента алгоритма.

Juliekravets 26 окт. 2020 г., 01:38:51 | 5 - 9 классы

Определите значение переменной X после выполнения фрагмента алгоритма?

Определите значение переменной X после выполнения фрагмента алгоритма.

На этой странице находится ответ на вопрос Пожалуйста?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.