Привет?

Информатика | 5 - 9 классы

Привет.

Напишите, пожалуйста, программу, которая будет вводить целые числа до тех пор, пока не будет введён нуль.

Подсчитать количество положительных и отрицательных чисел.

Ответить на вопрос
Ответы (1)
DGEKS 25 авг. 2020 г., 18:49:57

Program z ;

var a, i : integer ; max : real ;

begin

max : = 0 ;

i : = 0 ;

repeat writeln('Введите число') ; read(a) ;

max : = max + a ;

i : = i + 1 ;

until a = 0 ;

writeln('Сумма = ', max) ;

writeln('Средние значение = ', max / i) ;

end.

Vibornova 16 мар. 2020 г., 18:39:46 | 5 - 9 классы

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры?

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры.

Milavika1980 9 окт. 2020 г., 23:48:38 | 10 - 11 классы

Напишите программу, которая вводила бы целые числа и суммировала их до тех пор, пока пользователь не ввел число 0?

Напишите программу, которая вводила бы целые числа и суммировала их до тех пор, пока пользователь не ввел число 0.

Аня1210 5 июн. 2020 г., 08:29:44 | 5 - 9 классы

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом?

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом.

ROMSIS2013 24 окт. 2020 г., 03:11:07 | 5 - 9 классы

Напишите программу, в которой осуществляется ввод целых чисел ( ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального ( наибольшего) из введённых чисел?

Напишите программу, в которой осуществляется ввод целых чисел ( ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального ( наибольшего) из введённых чисел.

Используйте оператор repeat.

Viktoria3311 9 нояб. 2020 г., 18:19:25 | 5 - 9 классы

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введен нуль) и подсчет суммы и среднего арифметического введенных положительных чисел?

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введен нуль) и подсчет суммы и среднего арифметического введенных положительных чисел.

Используйте оператор repeat.

Фатима61 25 сент. 2020 г., 15:26:56 | 5 - 9 классы

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчет количества введеных чисел ?

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчет количества введеных чисел .

Используйте оператор while.

Решить в паскале.

Юляффка12 17 дек. 2020 г., 15:18:27 | 5 - 9 классы

Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел?

Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел.

Киса315 19 апр. 2020 г., 17:02:37 | 10 - 11 классы

Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел?

Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел.

Вводится число N, а затем N чисел.

Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.

C + +.

ГиперГолубь 19 апр. 2020 г., 15:49:51 | 10 - 11 классы

Напишите программу, которая вводит последовательность целых чисел заканчивающихся нулем, и определяет количество четных положительных чисел в этой последовательности?

Напишите программу, которая вводит последовательность целых чисел заканчивающихся нулем, и определяет количество четных положительных чисел в этой последовательности.

Lizik1709 6 нояб. 2020 г., 06:51:10 | 10 - 11 классы

1) Напишите программу, в которой осуществляется ввод целых чисел (пока не будет введён 0) и выведет на экран сумму положительных чисел, и произведение отрицательных введённых чисел?

1) Напишите программу, в которой осуществляется ввод целых чисел (пока не будет введён 0) и выведет на экран сумму положительных чисел, и произведение отрицательных введённых чисел.

Использовать цикл repeat.

2) Напишите программу, которая выводит на экран таблицу умножения на N, чисел от 0 до 10.

Помогите пожалуйста!

(.

Вы находитесь на странице вопроса Привет? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.