Вычислить значение суммы членов бесконечного ряда с заданной точностью и значение суммы, определяемое пределом суммы ряда (по формуле)?

Информатика | 10 - 11 классы

Вычислить значение суммы членов бесконечного ряда с заданной точностью и значение суммы, определяемое пределом суммы ряда (по формуле).

Напечатать значения сумм и число циклов ряда, вошедших в сумму.

Chx = (1 + x ^ 2 / 2!

) + (x ^ 4 / 4!

) + (x ^ 6 / 6!

) + .

+ x ^ 2n / (2n)!

Где x = 0.

7, e = 10 ^ - 4.

Ответить на вопрос
Ответы (1)
Natalyaplahuta 23 сент. 2020 г., 11:59:43

$\displaystyle Ch(x)=1+\sum_{i=1}^n \frac{x^{2n}}{(2n)!}=1+a_1+a_2+\dots+a_n \\ a_1= \frac{x^2}{2}, \ a_n= \frac{x^2\cdot a_{n-1}}{2n(2n-1)}$ / / PascalABC.

NET 3.

1, сборка 1200 от 13.

03. 2016

begin var x : = 0.

7 ; var eps : = 1e - 4 ; var a : = x * x / 2 ; var chx : = 1 + a ; var n : = 1 ; while a> ; = eps do begin Writeln('n = ', n, ' Ch(x) = ', chx) ; Inc(n) ; a : = a * x * x / ((2 * n) * (2 * n - 1)) ; chx : = chx + a end ; Writeln(' - - - - - - - - - - - - - - - - - - - - - - - - - - - - ') ; Writeln('n = ', n, ' Ch(x) = ', chx)

end.

Результат выполнения программы :

n = 1 Ch(x) = 1.

245

n = 2 Ch(x) = 1.

25500416666667

n = 3 Ch(x) = 1.

25516756805556 - - - - - - - - - - - - - - - - - - - - - - - - - - - -

n = 4 Ch(x) = 1.

25516899781771.

Nikita200348 8 мая 2020 г., 16:47:58 | 10 - 11 классы

Вычислить сумму Z = 1 + 2 + 3 + ?

Вычислить сумму Z = 1 + 2 + 3 + .

. Вычисления прекратить, когда значение Z превысит заданное значение A.

Yulikaftajkina 9 сент. 2020 г., 02:53:41 | 10 - 11 классы

Вычислите частичную сумму рядаS = 1 + 1 / 2 + 1 / 4 + 1 / 8 + ?

Вычислите частичную сумму ряда

S = 1 + 1 / 2 + 1 / 4 + 1 / 8 + .

Вычисления прекратите, когда модуль очередного слагаемого станет меньне 0, 001.

Проверьте, насколько сумма приблизилась к значению 2.

Красотка1250 13 июл. 2020 г., 06:17:32 | 10 - 11 классы

НАЙТИ СУММУ РЯДА?

НАЙТИ СУММУ РЯДА.

ПАСКАЛЬ.

ПОМОГИТЕ ПОЖАЛУЙСТА.

Dashkaantonova 10 февр. 2020 г., 03:30:59 | 5 - 9 классы

Дан ряд чисел от n1 до n2?

Дан ряд чисел от n1 до n2.

Посчитать в паскале сумму отрицательных чисел в этом ряду.

Щербинка2000 16 окт. 2020 г., 13:07:15 | 10 - 11 классы

Заполнить массив числами натурального ряда(1, 2?

Заполнить массив числами натурального ряда(1, 2.

) до тех пор пока их сумма не станет больше наперед заданного числа м вывести на печать сумму и число элементов массива.

Ghavrusha 4 янв. 2020 г., 15:21:38 | 10 - 11 классы

Напишите программу, которая вычисляет сумму первых n членов ряда ?

Напишите программу, которая вычисляет сумму первых n членов ряда .

Значение n вводится с клавиатуры.

Gulmira841 17 февр. 2020 г., 22:46:50 | 5 - 9 классы

Сумма ряда на языке паскаль?

Сумма ряда на языке паскаль.

Viktoriana9 15 мар. 2020 г., 07:09:37 | 10 - 11 классы

Дан ряд 3 / 4 + 4 / 9 + 5 / 16 + ?

Дан ряд 3 / 4 + 4 / 9 + 5 / 16 + .

Найти сумму 150 первых членов ряда.

Anastasiyaby4kova 2 окт. 2020 г., 07:51:00 | 5 - 9 классы

Дан числовой ряд и некоторое малое число ε (например, ε = 0, 00001)?

Дан числовой ряд и некоторое малое число ε (например, ε = 0, 00001).

Найти сумму тех членов ряда, модуль которых больше или равен заданному ε.

Формула.

Mrolegmega 5 дек. 2020 г., 05:12:55 | 10 - 11 классы

Как делать?

Как делать?

Ввести два целых числа x y определить что больше квадрат суммы или сумма квадратов, вывести ответы "квадрат суммы" или "сумма квадратов" или "значения равны".

В паскале подробно.

Вы зашли на страницу вопроса Вычислить значение суммы членов бесконечного ряда с заданной точностью и значение суммы, определяемое пределом суммы ряда (по формуле)?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.