Вывести на экран значения массива из 100 элементов по спирали?

Информатика | 5 - 9 классы

Вывести на экран значения массива из 100 элементов по спирали.

Будем понимать под этим следующее : выводить по 10 элементов в каждой строке, при этом каждая вторая строка должна выводиться "задом наперед" : сначала последние элементы строки, а затем первые.

Ответить на вопрос
Ответы (1)
Max8962 1 июл. 2020 г., 12:07:09

/ / Pascal ABC.

NET 3.

1 сборка 1219

Const

n = 100 ;

Var

ar : array[1.

N] of integer ;

i, j : integer ;

begin

writeln('Array : ') ;

for i : = 1 to 100 do

begin ar[i] : = i ; write(ar[i] : 4) ;

end ;

writeln ;

writeln('Result : ') ;

for i : = 0 to 9 do

if not(odd(i)) then begin for j : = 1 to 10 do write(ar[i * 10 + j] : 4) ; writeln ; end else begin for j : = 10 downto 1 do write(ar[i * 10 + j] : 4) ; writeln ; end ;

end.

Boginskayavp 17 мар. 2020 г., 15:31:22 | 5 - 9 классы

Составьте программу , которая позволяет вводить с клавиатуры элементы массива а [1?

Составьте программу , которая позволяет вводить с клавиатуры элементы массива а [1.

12], а затем выводит на экран в первую строку первые пять элементов массива, во вторую - остальные пять элементов.

Anna3567 19 янв. 2020 г., 11:31:44 | 10 - 11 классы

Cоставить алгоритм и программу для :1)Заполнения лвумерного массива (6x4) произвольными значениями и вывода его на экран?

Cоставить алгоритм и программу для :

1)Заполнения лвумерного массива (6x4) произвольными значениями и вывода его на экран!

2)Подсчета произведения элементов по строкам и вывода на экран номеров строк и соответствующих произведений элементов!

3)Нахождения строки с максимальным произведением элементов и вывода на экран ее номера (номеров) и произведения элементов!

4) Выделения 1 - го столбца в отдельный массив и сортировки его по возврастанию методом прямого выбора.

Mishonok00 1 февр. 2020 г., 15:06:14 | 5 - 9 классы

1. Сгенерировать массив 8х14, вывести на экран?

1. Сгенерировать массив 8х14, вывести на экран.

Из чётных элементов этого массива, больших среднего арифметического нечётных элементов сформировать линейный массив, Вывести его на экран.

2. Сгенерировать массив 10х10, вывести на экран, найти сумму каждой строки.

Упорядочить строки в порядке возрастания суммы строки.

Результирующий массив вывести на экран.

Vikatrjokina 14 июл. 2020 г., 04:48:56 | 5 - 9 классы

Составьте программу , которая позволяет вводить с клавиатуры элементы массива a[1?

Составьте программу , которая позволяет вводить с клавиатуры элементы массива a[1.

10], а затем выводить на экран в первую строку первые пять элементов, а во - воторую - остальные пять.

Nu12 22 июл. 2020 г., 04:41:44 | 5 - 9 классы

Составьте программу, которая позволяет вводить с клавиатуры элементы массива a [1?

Составьте программу, которая позволяет вводить с клавиатуры элементы массива a [1.

10], а затем выводит на экран в первую строку первые 5 элементов массива, во вторую остальные 5 элементов.

Гасанова1 2 дек. 2020 г., 12:53:07 | 5 - 9 классы

1. Создать массив из 20 - ти случайных чисел(значения от 0 до 100)?

1. Создать массив из 20 - ти случайных чисел(значения от 0 до 100).

Вывести на экран значения массива строкой.

Вычислить сумму элементов массива!

2. Создать массив из 20 - ти случайных чисел(значения от 0 до 100).

Вывести на экран значения массива строкой.

Вычислить количество элементов массива!

MilliVanilli1 22 июл. 2020 г., 18:53:28 | 5 - 9 классы

Помогите составить программу заполнения массива, состоящего из 17 элементов, случайными целыми числами их промежутка [ - 50 ; + 50]?

Помогите составить программу заполнения массива, состоящего из 17 элементов, случайными целыми числами их промежутка [ - 50 ; + 50].

Вывести на экран сначала все элементы массива, а затем с новой строки элементы с четными индексами.

Катерина706 18 янв. 2020 г., 03:57:13 | 5 - 9 классы

Найдите сумму всех элементов двумерного массива и сумму элементов каждой строки?

Найдите сумму всех элементов двумерного массива и сумму элементов каждой строки.

(паскаль).

Jador1 26 сент. 2020 г., 10:03:20 | 10 - 11 классы

Двумерные массивы?

Двумерные массивы.

Дан двумерный массив чисел.

Первый нечетный элемент каждой строки удвоить (предполагается, что в каждой строке есть нечетный элемент).

Vasyapupkin201 2 июл. 2020 г., 19:43:53 | 5 - 9 классы

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран?

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран.

Язык Паскаль.

На этой странице вы найдете ответ на вопрос Вывести на экран значения массива из 100 элементов по спирали?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.