Помогите составить программу заполнения массива, состоящего из 17 элементов, случайными целыми числами их промежутка [ - 50 ; + 50]?

Информатика | 5 - 9 классы

Помогите составить программу заполнения массива, состоящего из 17 элементов, случайными целыми числами их промежутка [ - 50 ; + 50].

Вывести на экран сначала все элементы массива, а затем с новой строки элементы с четными индексами.

Ответить на вопрос
Ответы (1)
Wesret 22 июл. 2020 г., 18:53:33

Последняя часть вопроса поставлена некорректно.

Массив может в общем случае индексироваться, начиная с любого целого числа, например, с нуля или с единицы.

В случае индексирования от нуля, четные индексы будут иметь первый, третий, пятый и т.

Д. по порядку элементы, а при нумерации от единицы - второй, четвертый, шестой и т.

Д. Будем считать, что индекс массива совпадает с порядковым номером элемента, т.

Е. индексация в массиве идет от единицы, тогда выводу подлежат второй, четвертый, шестой и т.

Д. элементы.

1. Современный "короткий" вариант / / PascalABC.

NET 3.

1, сборка 1190 от 05.

03. 2016

begin var a : = ArrRandom(17, - 50, 50) ; a.

Println ; a.

Where((x, i) - > ; Odd(i)).

Println

end.

Тестовое решение : - 6 35 - 48 - 50 - 16 - 36 20 16 - 10 32 - 4 34 46 - 45 14 13 - 36

35 - 50 - 36 16 32 34 - 45 13

2.

Традиционный ("школьный" вариант) - так до сих пор учат в школах / / PascalABC.

NET 3.

1, сборка 1190 от 05.

03. 2016

const n = 17 ;

var a : array[1.

N] of integer ; i : integer ;

begin Randomize ; for i : = 1 to n do begin a[i] : = Random(101) - 50 ; Write(a[i], ' ') end ; Writeln ; i : = 2 ; while i< ; = n do begin Write(a[i], ' ') ; i : = i + 2 end ; Writeln

end.

Тестовое решение :

27 - 29 10 - 35 - 48 - 45 0 4 - 50 - 13 17 - 41 12 26 38 26 23 - 29 - 35 - 45 4 - 13 - 41 26 26.

Zenks 10 мар. 2020 г., 02:56:58 | 10 - 11 классы

Найди все четные по значению элементы массива?

Найди все четные по значению элементы массива.

Вывести на экран значение элементов и их индекс.

Ввод элементов массива с клавиатуры.

Программа пишется на языке Паскаль.

Nina1234567 4 мая 2020 г., 21:31:44 | 5 - 9 классы

Составьте программу, которая заполняет массив а[1?

Составьте программу, которая заполняет массив а[1.

10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает.

Выведите на экран исходный и полученный массивы.

Ghjkknbbv 21 дек. 2020 г., 09:04:39 | 1 - 4 классы

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами?

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами.

Требуется вывести массив на экран компьютера и найти индекс последнего по счету в массиве отрицательного элемента.

Menshih5536 22 июн. 2020 г., 02:08:28 | 5 - 9 классы

Напишите программу, которая случайным образом заполняет массив из 10 элементов целыми числами из диапазона [ - 6 ; 9]?

Напишите программу, которая случайным образом заполняет массив из 10 элементов целыми числами из диапазона [ - 6 ; 9].

И вывести все элементы массива на экран.

Alinaiva 14 февр. 2020 г., 17:49:42 | 10 - 11 классы

Составьте программу ввода с клавиатуры элементов массива а [1?

Составьте программу ввода с клавиатуры элементов массива а [1.

10] и вывода на экран элементов с четными значениями и четными индексами.

Лерик22 22 апр. 2020 г., 08:40:45 | 5 - 9 классы

Составить программу заполнения массива из 7 элементов числами от 1 до 30 с помощью генератора случайных чисел и вывести значения его элементов в строку через запятую?

Составить программу заполнения массива из 7 элементов числами от 1 до 30 с помощью генератора случайных чисел и вывести значения его элементов в строку через запятую.

2001viola 24 янв. 2020 г., 05:33:36 | 5 - 9 классы

Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25?

Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25.

Программа должна :

1)выводить на экран сначала все элементы массива, стоящие на чётных местах, а затем - все элементы массива, стоящие на нечётных местах ;

2)вывести на экран сумму всех элементов массива, значение которых кратны 3 или 5.

3)найти минимальное значение и максимальное значение элементов массива.

Diana98n 10 июн. 2020 г., 21:33:13 | 10 - 11 классы

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс?

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс.

Заменить все четные элементы значением максимального элемента.

Полученный массив вывести на экран.

Murastam 8 сент. 2020 г., 06:07:42 | 5 - 9 классы

Составьте программу ввода с клавиатуры элементов массива а[1?

Составьте программу ввода с клавиатуры элементов массива а[1.

10] и вывода на экран элементов с четными индексами.

НастяЕлизарова 12 сент. 2020 г., 02:22:04 | 5 - 9 классы

Составьте программу ввода с клавиатуры элементов массива а [1?

Составьте программу ввода с клавиатуры элементов массива а [1.

10] и вывода на экран элементов с четными значениями и четными индексами.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Помогите составить программу заполнения массива, состоящего из 17 элементов, случайными целыми числами их промежутка [ - 50 ; + 50]?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.