Напишите сколько сможете программ для решения вот таких задач : If1?

Информатика | 5 - 9 классы

Напишите сколько сможете программ для решения вот таких задач : If1.

Дано целое число.

Если оно является положительным, то прибавить к нему 1 ; в противном случае не изменять его.

Вывести полученное число.

If2. Дано целое число.

Если оно является положительным, то прибавить к нему1 ; в противном случае вычесть из него2.

Вывести полученное число.

If3. Дано целое число.

Если оно является положительным, то прибавить к нему 1 ; если отрицательным, то вычесть из него 2 ; если нулевым, то заменить его на 10.

Вывести полученное число.

Помогите очень надо.

Ответить на вопрос
Ответы (1)
Ден655456 20 мая 2020 г., 16:54:11

1. Var x : longint ;

Begin

Readln(x) ;

if (x> ; = 0) then

x : = x + 1 ;

Writeln('Полученное число : ', x) ;

Readln(x) ; / / Эту строчку можно не писать, но она останавливает программу, чтобы ты мог посмотреть на результат.

End. 2.

Var x : longint ;

Begin

Readln(x) ;

if (x> ; = 0) then

x : = x + 1

else x : = x - 2 ;

Writeln('Полученное число : ', x) ;

Readln(x) ; / / Опять же

end.

3. Var x : longint ;

Begin

Readln(x) ;

if (x> ; 0) then

x : = x + 1

else if (x< ; 0) then x : = x - 2

else x : = 10 ;

Writeln('Полученное число : ', x) ;

Readln(x) ; / / Опять же

end.

Pfrolov02 10 сент. 2020 г., 11:04:37 | 5 - 9 классы

Ввести число?

Ввести число.

Если оно неотрицательно, вычесть из него 50, в противном случае прибавить к нему 100.

Mar2 24 авг. 2020 г., 16:05:56 | 5 - 9 классы

1) дано целое число, если оно положительное то прибавить к нему 1, а если в противном случаи, то не изменять и написать результат 2) дано число от 1 до 7(ввести) В зависимости от значений напичатать д?

1) дано целое число, если оно положительное то прибавить к нему 1, а если в противном случаи, то не изменять и написать результат 2) дано число от 1 до 7(ввести) В зависимости от значений напичатать дни недели пониднльник - 1 и т.

Д.

Danikmateyko 16 окт. 2020 г., 18:23:38 | 10 - 11 классы

Дано целое число?

Дано целое число.

Если оно является положительным.

То прибавить к нему 1 ; если же отрицательным то вычесть 2 Вывести полученное число пожалуйста на c + +.

Anastasiu844 11 авг. 2020 г., 14:29:26 | 10 - 11 классы

Дано целое число?

Дано целое число.

Если оно является положительным, то прибавить к нему 1 ; в противном случае не изменятьего.

Вывести полученное число.

8889674 5 февр. 2020 г., 20:27:53 | 5 - 9 классы

1. Дано двузначное число?

1. Дано двузначное число.

Найти разность и частное его цифр.

2. Дано целое число.

Если оно является положительным то прибавить к нему 1.

Емли нулевым то заменить его на 10.

3. Дано двузначное число.

Вывести его левую цифру, потом правую.

4. Дано целое число, определить является ли оно четным.

5. даны два целых числа.

Найти сумму всех целых чисел от а до в.

Написать программы (паскаль).

Denisovaulya17 22 янв. 2020 г., 05:44:02 | 10 - 11 классы

Дано целое число?

Дано целое число.

Если оно является положительным, то прибавить к нему 1 ; в противном случае не изменять его .

Вывести полученное число.

PolyI 23 июн. 2020 г., 07:48:43 | 10 - 11 классы

Программа с + + ?

Программа с + + .

Дано целое число.

Если оно является положительным, то прибавить к нему 1 ; если отрицательным, то вычесть из него 2 ; если нулевым, то заменить его на 10.

Вывести полученное число.

Darya08052000 30 мая 2020 г., 12:27:30 | 10 - 11 классы

Дано целое число ?

Дано целое число .

Если оно является положительным, то умножить его на 3 ; в противном случае не изменять его.

Вывести полученное число.

Elonokha2002 31 мая 2020 г., 22:06:31 | 5 - 9 классы

Задачи практикума по языку Паскаль?

Задачи практикума по языку Паскаль.

Условный оператор.

Дано целое число.

Если оно является положительным, то прибавить к нему 1 ; в противном случае вычесть из него 2.

Вывести полученное число.

Входные данные : ввести целое число X ( - 1000< ; = X < ; = 1000).

Выходные данные : вывести полученное число Х.

Evroline643 8 окт. 2020 г., 04:08:57 | 1 - 4 классы

Дано целое число?

Дано целое число.

Если оно является положительным, то прибавить к нему 1, в противоположном случае вычесть из него 2.

Вывести полученное число.

На этой странице сайта вы найдете ответы на вопрос Напишите сколько сможете программ для решения вот таких задач : If1?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.