Написать алгоритм и программу которая определяет сколько раз в данном слове встречается буквосочитание "пол"?

Информатика | 10 - 11 классы

Написать алгоритм и программу которая определяет сколько раз в данном слове встречается буквосочитание "пол".

Ответить на вопрос
Ответы (1)
Imbaok 23 мая 2020 г., 09:27:47

Function checkstring( s : string ) : integer ;

var i, k, len : integer ;

begin len : = length(s) ;

k : = 0 ;

for i : = 1 to len do

begin

if ( s[i] = 'п' ) then

if s[ i + 1 ] = 'о' then

if s[ i + 2 ] = 'л' then inc(k) ;

end ;

checkstring : = k ;

end ;

var str : string ;

rez : integer ;

begin

write('Введите слово : ') ;

readln(str) ;

rez : = checkstring(str) ;

if rez > ; 0 then writeln('Буквосочетание "пол" встречается в слове в количестве : ', rez)

else writeln('Буквосочетание "пол" в слове не встречается') ;

end.

Rasputinaekate 4 янв. 2020 г., 21:14:13 | 10 - 11 классы

Написать программу, которая определяет, сколько различных чисел находится вмассивеЯзык Си?

Написать программу, которая определяет, сколько различных чисел находится вмассиве

Язык Си.

Хотя бы алгоритм.

Alekseeva20044 19 нояб. 2020 г., 21:52:38 | 10 - 11 классы

Программа в Pascal 1?

Программа в Pascal 1.

Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м.

2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о.

Gulchatayogly 26 апр. 2020 г., 08:30:02 | 5 - 9 классы

Напишите программу на языке программирования (или составьте алгоритм)?

Напишите программу на языке программирования (или составьте алгоритм).

Дано натуральное число n.

Определите, сколько раз цифра «7» встречается в записи данного числа.

НиккаМинаж 2 мар. 2020 г., 13:46:04 | 5 - 9 классы

Дано трёхзначное число ?

Дано трёхзначное число .

Напишите программу , которая определяет :

Шум4 12 мар. 2020 г., 08:05:30 | 5 - 9 классы

Дан рост трех друзей?

Дан рост трех друзей.

Как написать программу которая определяет их среднийрост на языке PascalABC?

Машуля2013 20 апр. 2020 г., 00:08:51 | 10 - 11 классы

Написать программу которая определяет все слова оканчивающиеся на "ая"?

Написать программу которая определяет все слова оканчивающиеся на "ая".

Про100Снежинка 17 окт. 2020 г., 20:38:25 | 10 - 11 классы

Дана строка, состоящая из 50 символов?

Дана строка, состоящая из 50 символов.

Составьте программу, используя процедуру которая определяет сколько раз встречается в строке слог ‘ea’.

Ииачсаомо 23 апр. 2020 г., 18:48:27 | 10 - 11 классы

Дана страка символов, содержашая слова, то есть группы символов, разделеные пробелами( не менее одного)?

Дана страка символов, содержашая слова, то есть группы символов, разделеные пробелами( не менее одного).

Составте программу, которая определяет , сколько раз в тексте встречается задоное слово».

Нетпкп 2 нояб. 2020 г., 19:51:47 | 5 - 9 классы

Написать программу на Паскале, определяющую, сколько раз число 10 встречается среди элементов таблицы А(n) , состоящей из целых чисел?

Написать программу на Паскале, определяющую, сколько раз число 10 встречается среди элементов таблицы А(n) , состоящей из целых чисел.

Mironova1999 15 апр. 2020 г., 22:35:22 | 5 - 9 классы

Напишите программу , которая определяет , сколько раз встречается в строке слог "MA" ?

Напишите программу , которая определяет , сколько раз встречается в строке слог "MA" ;

Перед вами страница с вопросом Написать алгоритм и программу которая определяет сколько раз в данном слове встречается буквосочитание "пол"?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.