Требуется использовать язык Паскаль Даны три целых числа A, B, C?

Информатика | 5 - 9 классы

Требуется использовать язык Паскаль Даны три целых числа A, B, C.

Значения чисел вводятся с клавиатуры.

Определить количество нулей среди данных чисел.

Результат вывести на экран.

Ответить на вопрос
Ответы (2)
GKatya26 23 янв. 2020 г., 06:36:26

Если строго по тексту задачи то получится так :

var a, b, c, n : integer ;

begin readln(a, b, c) ; if a = 0 then n : = n + 1 ; if b = 0 then n : = n + 1 ; if c = 0 then n : = n + 1 ; writeln(n) ;

end.

Ldubchenko 23 янв. 2020 г., 06:36:33

Var a, b, c, ch, n : integer ;

begin

writeln('введите три числа : ') ;

readln(a, b, c) ;

n : = 0 ;

while (a< ; > ; 0) do begin

ch : = a mod 10 ;

if ch = 0 then n : = n + 1 ;

a : = a div 10 ;

end ;

writeln('нулей в первом числе = ', n) ;

n : = 0 ;

while (b< ; > ; 0) do begin

ch : = b mod 10 ;

if ch = 0 then n : = n + 1 ;

b : = b div 10 ;

end ;

writeln('нулей во втором числе = ', n) ;

n : = 0 ;

while (c< ; > ; 0) do begin

ch : = c mod 10 ;

if ch = 0 then n : = n + 1 ;

c : = c div 10 ;

end ;

writeln('нулей в третьем числе = ', n) ;

end.

Zarechnev03 31 мая 2020 г., 23:07:23 | 10 - 11 классы

Вводить с клавиатуры 10 целых чисел, выдать на экран количество положительных чисел, количество отрицательных , количество нулевых?

Вводить с клавиатуры 10 целых чисел, выдать на экран количество положительных чисел, количество отрицательных , количество нулевых.

SuSanNa268 22 дек. 2020 г., 18:10:12 | 5 - 9 классы

Помогите с паскалем?

Помогите с паскалем.

С клавиатуры вводятся 5 натуральных чисел.

Определить, есть ли среди них числа, которые нацело делятся на 5 (вывести их на экран).

Витанка 8 окт. 2020 г., 13:52:58 | 10 - 11 классы

С клавиатуры вводятся целые числа?

С клавиатуры вводятся целые числа.

Признаком конца ввода чисел является 0.

Изменить знак отрицательных чисел на положительный.

Результаты вывести на экран.

Nastena2805 2 апр. 2020 г., 04:43:43 | 10 - 11 классы

Погите пожалуйста?

Погите пожалуйста.

Нужно написать задачи на языке Паскаль.

1. С клавиатуры заполнить целочисленный одномерный массив.

Вывести неотрицательные элементы массива.

2. дан одномерный массив целых чисел.

Определить каких элементов больше, максимальных и минимальных 3.

Дан одномерный массив целых чисел.

Подсчитать количество элементов, равных заданному массиву x.

Число х вводится с клавиатуры.

Dodydyd 13 янв. 2020 г., 18:54:23 | 10 - 11 классы

Даны три целых числа?

Даны три целых числа.

Определить, сколько среди них положительных чисел.

Составить программу на языке Паскаль.

Dasha999922 2 сент. 2020 г., 16:30:56 | 5 - 9 классы

Написать программу в паскаль?

Написать программу в паскаль.

Из всех двузначных чисел вывести на экран те из них, сумма цифр которых равна А.

(А вводится с клавиатуры).

Indira3927 7 авг. 2020 г., 05:44:57 | 5 - 9 классы

Требуется использовать язык Паскаль Даны три целых числа A, B, C?

Требуется использовать язык Паскаль Даны три целых числа A, B, C.

Значения чисел вводятся с клавиатуры.

Определить количество нулей среди данных чисел.

Результат вывести на экран.

Dimonorel1990 6 мар. 2020 г., 23:58:51 | 5 - 9 классы

Даны три целых числа A, B, C?

Даны три целых числа A, B, C.

Значение чисел вводятся с клавиатуры.

Определить максимальное значение средних данных чисел.

Результат вывести на экран.

Polinaro323 18 сент. 2020 г., 02:51:10 | 10 - 11 классы

Даны три числа?

Даны три числа.

Если среди нет нулей, то вычислить и вывести произведение этих чисел.

ИраИлюхина2006 16 дек. 2020 г., 20:49:45 | 5 - 9 классы

Помогите, пожалуйста, написать программы?

Помогите, пожалуйста, написать программы!

Очень нужно!

Язык - паскаль!

1) вычислить количество введенных с клавиатуры чисел.

Окончанием служит ввод значения x.

2) вывести максимальное из чисел, вводимых с клавиатуры.

Окончанием служит ввод значения x.

3) вывести произведение 20 чисел вводимых с клавиатуры.

4) вычислить произведение чисел, вводимых с клавиатуры.

Окончанием служит ввод значения x.

На этой странице сайта размещен вопрос Требуется использовать язык Паскаль Даны три целых числа A, B, C? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.