Вводить с клавиатуры 10 целых чисел, выдать на экран количество положительных чисел, количество отрицательных , количество нулевых?

Информатика | 10 - 11 классы

Вводить с клавиатуры 10 целых чисел, выдать на экран количество положительных чисел, количество отрицательных , количество нулевых.

Ответить на вопрос
Ответы (1)
Logooo74 31 мая 2020 г., 23:07:26

Код Pascal

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

var

a : array [1.

10] of integer ;

i, p, o, n : byte ;

begin

for i : = 1 to 10 do

begin

write('Введите ', i, ' число : ') ;

readln(a[i]) ;

end ;

for i : = 1 to 10 do

begin

if (a[i] > ; 0) then inc(p)

else

if (a[i] < ; 0) then inc (o)

else

inc(n) ;

end ;

writeln('Количество положительных элементов = ', p) ;

writeln('Количество отрицательных элементов = ', o) ;

writeln('Количество нулевых элементов = ', n) ;

end.

Сень123 26 сент. 2020 г., 08:30:05 | 5 - 9 классы

ПОМОГИТЕ С ПАСКАЛЕМ?

ПОМОГИТЕ С ПАСКАЛЕМ.

С клавиатуры вводятся 7 целых чисел.

Вычислить количество отрицательных членов этой последовательности.

Aleksandr20103 4 мар. 2020 г., 15:22:42 | 5 - 9 классы

С клавиатуры последовательно вводится 10 чисел?

С клавиатуры последовательно вводится 10 чисел.

Найти количество положительных чисел.

Срочноо!

Решите пожалуйста на Паскале.

Димке 10 окт. 2020 г., 03:51:27 | 10 - 11 классы

Написать программу : c клавиатуры последовательно вводятся числа, пока не введут 0?

Написать программу : c клавиатуры последовательно вводятся числа, пока не введут 0.

Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.

Витанка 8 окт. 2020 г., 13:52:58 | 10 - 11 классы

С клавиатуры вводятся целые числа?

С клавиатуры вводятся целые числа.

Признаком конца ввода чисел является 0.

Изменить знак отрицательных чисел на положительный.

Результаты вывести на экран.

Zhenk2011 20 июн. 2020 г., 10:41:16 | 10 - 11 классы

Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран : а) количество нулей в последовательности ; б) количество положительных чисел ; в) количество отрицательных чисел?

Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран : а) количество нулей в последовательности ; б) количество положительных чисел ; в) количество отрицательных чисел.

( На языке Паскаль С + + ).

Анастасия90220 8 апр. 2020 г., 00:44:03 | 5 - 9 классы

Вводятся 5 целых чисел вывести количество отрицательных ?

Вводятся 5 целых чисел вывести количество отрицательных .

Помогите плиззз!

Mahamusatova 29 дек. 2020 г., 20:31:57 | 10 - 11 классы

Пожалуйста, помогите?

Пожалуйста, помогите!

Срочно!

В ПАСКАЛЕ : 1) найти количество положительных целых чисел от 45 до 215 ; 2) Найти сумму положительных целых чисел от - 50 до 200, кратных 5 и 8 ; 3) Найти сумму и количество отрицательных четных целых чисел, введенных с клавиатуры.

Печать результата по вводу числа 0.

Юляффка12 17 дек. 2020 г., 15:18:27 | 5 - 9 классы

Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел?

Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел.

Maksimdonchenko 3 дек. 2020 г., 10:14:31 | 10 - 11 классы

Пусть с клавиатуры вводятся последовательно N целых чисел?

Пусть с клавиатуры вводятся последовательно N целых чисел.

Найти количество двухзначных чисел.

1Демон1 31 дек. 2020 г., 04:01:46 | 10 - 11 классы

С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем?

С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем.

Найти количество отрицательных чисел и сумму чисел кратных 4.

На этой странице вы найдете ответ на вопрос Вводить с клавиатуры 10 целых чисел, выдать на экран количество положительных чисел, количество отрицательных , количество нулевых?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.