Найти наибольший общий делитель следующих чисел(16 32 40 64 80 128)?

Информатика | 10 - 11 классы

Найти наибольший общий делитель следующих чисел(16 32 40 64 80 128).

Использовать процедуру для нахождения общего делителя.

ПАСКАЛЬ!

Ответить на вопрос
Ответы (1)
Iliaznatnov 7 апр. 2020 г., 05:52:59

Думаю нет большой разницы между процедурой и функцией, просто функция куда удобнее.

Для нахождения нода используется алгоритм Эвклида / / PascalABC.

Net

function NOD(A, B : integer) : integer ;

begin while A < ; > ; B do if A > ; B then A : = A - B else B : = B - A ; NOD : = A ;

end ;

procedure pNOD(A, B : integer ; var NOD : integer) ;

begin while A < ; > ; B do if A > ; B then A : = A - B else B : = B - A ; NOD : = A ;

end ;

begin var a : Array of integer : = (16, 32, 40, 64, 80, 128) ; var n : = a[low(a)] ; for var i : = low(a) to high(a) do pNOD(n, a[i], n) ; Writeln(n) ;

end.

Samitatokova 20 июл. 2020 г., 02:00:27 | 5 - 9 классы

Даны два числа?

Даны два числа.

Найти их наибольший общий делитель.

(Паскаль).

VMEAGH2114 20 окт. 2020 г., 01:31:49 | 5 - 9 классы

Срочно?

Срочно!

Очень надо!

Напишите программу вычисления наименьшего общего кратного следующих четырех чисел : 36 54 18 и 15.

Используйте процедуру вычисления общего делителя двух чисел.

Elenaladvi 1 февр. 2020 г., 05:25:09 | 5 - 9 классы

Написать программу в Pascal ABC для нахождения наибольшего общего делителя произвольных десяти целых двухзначных чисел с помощью алгоритма евклиада(procedure)?

Написать программу в Pascal ABC для нахождения наибольшего общего делителя произвольных десяти целых двухзначных чисел с помощью алгоритма евклиада(procedure).

Preydadavid 21 сент. 2020 г., 21:18:24 | 10 - 11 классы

Найти все делители натурального числа n?

Найти все делители натурального числа n.

Решить через процедуру и функцию в паскале, помогите плиз.

Ann2408 25 июл. 2020 г., 01:25:15 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

Напишите функцию, (через процедуру ) которая находит наибольший общий делитель двух натуральных чисел.

Пример : Введите два натуральных числа : 7006652 112307574 НОД(7006652, 112307574) = 1234.

Popowaani 16 нояб. 2020 г., 21:29:29 | 5 - 9 классы

Найти наибольший общий делитель чисел A, B, C, создав функцию для нахождения НОД двух натуральных чисел?

Найти наибольший общий делитель чисел A, B, C, создав функцию для нахождения НОД двух натуральных чисел.

Zarina150486 10 февр. 2020 г., 21:11:27 | 5 - 9 классы

Составьте программу нахождения наибольшего общего делителя трех чисел используя следующую формулу нод(а, в, с) = нод(нод (а, в), с) Не используйте слово function так как мы его не изучали ещё?

Составьте программу нахождения наибольшего общего делителя трех чисел используя следующую формулу нод(а, в, с) = нод(нод (а, в), с) Не используйте слово function так как мы его не изучали ещё.

Очень срочно заранее спасибо \.

Mariabrakorenko 13 мар. 2020 г., 23:39:26 | 5 - 9 классы

Пользователь вводит с клавиатуры n - чисел определить : Сколько среди них простых чисел?

Пользователь вводит с клавиатуры n - чисел определить : Сколько среди них простых чисел.

Наибольший общий делитель всех этих чисел.

Число у которого делителей боль, чем у всех остальных.

ПАСКАЛЬ ПРОЦЕДУРЫ И ФУНКЦИИ!

Dev0shkA 21 авг. 2020 г., 05:48:29 | 10 - 11 классы

Записать алгоритм нахождения наибольшего общего делителя двух натуральных чисел?

Записать алгоритм нахождения наибольшего общего делителя двух натуральных чисел.

Zhurina2013 27 мая 2020 г., 18:33:30 | 5 - 9 классы

Помогите составить программу 1?

Помогите составить программу 1.

Нужна программа на тему Алгоритма Евклида, составьте пожалуйста, чтобы в паскаль её забить.

Программа для нахождения наибольшего общего делителя.

Вы находитесь на странице вопроса Найти наибольший общий делитель следующих чисел(16 32 40 64 80 128)? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.