Написать программу в Pascal ABC для нахождения наибольшего общего делителя произвольных десяти целых двухзначных чисел с помощью алгоритма евклиада(procedure)?

Информатика | 5 - 9 классы

Написать программу в Pascal ABC для нахождения наибольшего общего делителя произвольных десяти целых двухзначных чисел с помощью алгоритма евклиада(procedure).

Ответить на вопрос
Ответы (1)
Bekulan2002 1 февр. 2020 г., 05:25:15

/ / PascalABC.

NET 3.

0, сборка 1110

procedure Euclid(a, b : integer ; var gcd : integer) ;

var t : integer ;

begin while b< ; > ; 0 do begin a : = a mod b ; t : = b ; b : = a ; a : = t end ; gcd : = a

end ;

var i, a, b, c : integer ;

begin Randomize ; for i : = 1 to 10 do begin a : = Random(99) + 1 ; b : = Random(99) + 1 ; Euclid(a, b, c) ; Writeln('НОД(', a, ', ', b, ') = ', c) end

end.

Тестовое решение :

НОД(32, 68) = 4

НОД(80, 68) = 4

НОД(36, 19) = 1

НОД(4, 61) = 1

НОД(46, 72) = 2

НОД(55, 53) = 1

НОД(75, 76) = 1

НОД(27, 96) = 3

НОД(98, 82) = 2

НОД(46, 23) = 23.

Vik10629003a 4 окт. 2020 г., 06:47:42 | 5 - 9 классы

Составить программу нахождения среднего арифметического и среднего геометрического модулей двух чисел (Pascal ABC)?

Составить программу нахождения среднего арифметического и среднего геометрического модулей двух чисел (Pascal ABC).

Winterbottom 13 июн. 2020 г., 22:55:51 | 5 - 9 классы

Дано целое число N?

Дано целое число N.

Составить программу нахождения количества цифр числа (Pascal ABC).

Maxkz 9 нояб. 2020 г., 18:58:30 | 10 - 11 классы

Pascal ABC написать программу?

Pascal ABC написать программу.

DreamSweets555 2 мар. 2020 г., 17:35:42 | 5 - 9 классы

Нужна помощь?

Нужна помощь!

Нужно написать программу в Pascal ABC вычисляющую сумму цифр двухзначного числа.

8 класс.

Tolkachewa 6 апр. 2020 г., 19:43:05 | 5 - 9 классы

Cоставте программу которая вычесляет произведение 10 произвольных целых двухзначных чисел (Цикл с предусловием , Pascal)?

Cоставте программу которая вычесляет произведение 10 произвольных целых двухзначных чисел (Цикл с предусловием , Pascal).

RIKA555 9 июн. 2020 г., 10:08:41 | 5 - 9 классы

Составить программу для нахождения количества таких трехзначных чисел Фибоначчи, которые делятся на сумму своих цифр нацело?

Составить программу для нахождения количества таких трехзначных чисел Фибоначчи, которые делятся на сумму своих цифр нацело.

Программа - Pascal ABC.

Dev0shkA 21 авг. 2020 г., 05:48:29 | 10 - 11 классы

Записать алгоритм нахождения наибольшего общего делителя двух натуральных чисел?

Записать алгоритм нахождения наибольшего общего делителя двух натуральных чисел.

Zhurina2013 27 мая 2020 г., 18:33:30 | 5 - 9 классы

Помогите составить программу 1?

Помогите составить программу 1.

Нужна программа на тему Алгоритма Евклида, составьте пожалуйста, чтобы в паскаль её забить.

Программа для нахождения наибольшего общего делителя.

Иосиф2 8 апр. 2020 г., 23:56:33 | 10 - 11 классы

1) Написать программу, находящую для натурального числа все его натуральные делители?

1) Написать программу, находящую для натурального числа все его натуральные делители.

2) Написать программу, вычисляющую наибольший общий делитель двух натуральных чисел.

09877012 23 нояб. 2020 г., 17:03:47 | 5 - 9 классы

Написать программы в PASCAL ABC?

Написать программы в PASCAL ABC.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Написать программу в Pascal ABC для нахождения наибольшего общего делителя произвольных десяти целых двухзначных чисел с помощью алгоритма евклиада(procedure)?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.