СРОЧНО?

Информатика | 5 - 9 классы

СРОЧНО!

Напишите функцию, (через процедуру ) которая находит наибольший общий делитель двух натуральных чисел.

Пример : Введите два натуральных числа : 7006652 112307574 НОД(7006652, 112307574) = 1234.

Ответить на вопрос
Ответы (1)
R4mb0bay7 25 июл. 2020 г., 01:25:21

Function gcd(a, b : longint) : longint ; / / Нахождение НОД

var i : longint ;

begin while b < ; > ; 0 do begin a : = a mod b ; i : = b ; b : = a ; a : = i end ; gcd : = a

end ;

var a, b : longint ;

begin Write('Введите два натуральных числа : ') ; Readln(a, b) ; Writeln('НОД(', a, ', ', b, ') = ', gcd(a, b))

end.

Тестовое решение :

Введите два натуральных числа : 7006652 112307574

НОД(7006652, 112307574) = 1234.

Zbbzbzb 2 июл. 2020 г., 01:19:50 | 5 - 9 классы

Напишите рекурсивную функцию, которая раскладывает число на простые сомножители?

Напишите рекурсивную функцию, которая раскладывает число на простые сомножители.

Пример : Введите натуральное число : 378 378 = 2 * 3 * 3 * 3 * 7.

Preydadavid 21 сент. 2020 г., 21:18:24 | 10 - 11 классы

Найти все делители натурального числа n?

Найти все делители натурального числа n.

Решить через процедуру и функцию в паскале, помогите плиз.

Typoi7 17 янв. 2020 г., 04:06:57 | 5 - 9 классы

Напишите процедуру , которая принимает параметр - натуральное число N - и выводит на экран линию из N символов ' - ' Пример : Введите N 10 - - - - - - - - - -?

Напишите процедуру , которая принимает параметр - натуральное число N - и выводит на экран линию из N символов ' - ' Пример : Введите N 10 - - - - - - - - - -.

Popowaani 16 нояб. 2020 г., 21:29:29 | 5 - 9 классы

Найти наибольший общий делитель чисел A, B, C, создав функцию для нахождения НОД двух натуральных чисел?

Найти наибольший общий делитель чисел A, B, C, создав функцию для нахождения НОД двух натуральных чисел.

Konfffetka10 23 февр. 2020 г., 15:29:15 | 10 - 11 классы

Напишите рекурсивную функцию, которая раскладывает число на простые сомножители?

Напишите рекурсивную функцию, которая раскладывает число на простые сомножители.

Пример : Введите натуральное число : 378 378 = 2 * 3 * 3 * 3 * 7.

Настюфка12 8 дек. 2020 г., 06:36:42 | 10 - 11 классы

А)Напишите процедуру(или через глобальные переменные), которая вычесляет произведение отрицательных элементов вектора?

А)Напишите процедуру(или через глобальные переменные), которая вычесляет произведение отрицательных элементов вектора.

Б)Напишите процедуру которая находит и заносит в массив простые числа меньше чем заданного(любого числа)натурального числа.

Lizzi4458 17 июн. 2020 г., 07:20:47 | 10 - 11 классы

Напишите процедуру, которая переставляет три переданные ей числа в порядке возрастания?

Напишите процедуру, которая переставляет три переданные ей числа в порядке возрастания.

Пример : Введите три натуральных числа : 10 15 5 5 10 15 Для С + + (питон).

Mariabrakorenko 13 мар. 2020 г., 23:39:26 | 5 - 9 классы

Пользователь вводит с клавиатуры n - чисел определить : Сколько среди них простых чисел?

Пользователь вводит с клавиатуры n - чисел определить : Сколько среди них простых чисел.

Наибольший общий делитель всех этих чисел.

Число у которого делителей боль, чем у всех остальных.

ПАСКАЛЬ ПРОЦЕДУРЫ И ФУНКЦИИ!

Dev0shkA 21 авг. 2020 г., 05:48:29 | 10 - 11 классы

Записать алгоритм нахождения наибольшего общего делителя двух натуральных чисел?

Записать алгоритм нахождения наибольшего общего делителя двух натуральных чисел.

Иосиф2 8 апр. 2020 г., 23:56:33 | 10 - 11 классы

1) Написать программу, находящую для натурального числа все его натуральные делители?

1) Написать программу, находящую для натурального числа все его натуральные делители.

2) Написать программу, вычисляющую наибольший общий делитель двух натуральных чисел.

Вы открыли страницу вопроса СРОЧНО?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.