Найти наибольший общий делитель чисел A, B, C, создав функцию для нахождения НОД двух натуральных чисел?

Информатика | 5 - 9 классы

Найти наибольший общий делитель чисел A, B, C, создав функцию для нахождения НОД двух натуральных чисел.

Ответить на вопрос
Ответы (1)
9032826945 16 нояб. 2020 г., 21:29:32

Program NOD(output) ;

function nod (a1, a2 : integer) : integer ;

begin

nod : = abs (a1 mod a2) ;

writeln(#7) ;

nod (a1, a2) ;

end ;

var a, b, c, d : integer ;

begin

readln (a, b, c) ;

d : = nod(nod(a, b), c) ;

writeln(d) ;

readln ;

end.

Дашенька1000999999 20 июл. 2020 г., 03:25:24 | 5 - 9 классы

Составьте программу нахождения произведения двух наибольших из трех введенных с клавиатуры чисел?

Составьте программу нахождения произведения двух наибольших из трех введенных с клавиатуры чисел.

Nataliviktorovna 30 нояб. 2020 г., 13:10:24 | 5 - 9 классы

Составьте программу нахождения наименьшего общего кратного (НОК) двух чисел, используя формулу : А * В = НОД(А * В) * НОК(А, В)?

Составьте программу нахождения наименьшего общего кратного (НОК) двух чисел, используя формулу : А * В = НОД(А * В) * НОК(А, В).

(по алгоритму Евклида на Паскале).

Elenaladvi 1 февр. 2020 г., 05:25:09 | 5 - 9 классы

Написать программу в Pascal ABC для нахождения наибольшего общего делителя произвольных десяти целых двухзначных чисел с помощью алгоритма евклиада(procedure)?

Написать программу в Pascal ABC для нахождения наибольшего общего делителя произвольных десяти целых двухзначных чисел с помощью алгоритма евклиада(procedure).

Ann2408 25 июл. 2020 г., 01:25:15 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

Напишите функцию, (через процедуру ) которая находит наибольший общий делитель двух натуральных чисел.

Пример : Введите два натуральных числа : 7006652 112307574 НОД(7006652, 112307574) = 1234.

Marshemello 18 июл. 2020 г., 09:15:22 | 5 - 9 классы

Составьте программу нахождения наименьшего общего кратного двух чисел используйте формулу A * B = НОД (А, В) * НОК (А, В)?

Составьте программу нахождения наименьшего общего кратного двух чисел используйте формулу A * B = НОД (А, В) * НОК (А, В).

Pushok112 7 апр. 2020 г., 05:52:53 | 10 - 11 классы

Найти наибольший общий делитель следующих чисел(16 32 40 64 80 128)?

Найти наибольший общий делитель следующих чисел(16 32 40 64 80 128).

Использовать процедуру для нахождения общего делителя.

ПАСКАЛЬ!

Zarina150486 10 февр. 2020 г., 21:11:27 | 5 - 9 классы

Составьте программу нахождения наибольшего общего делителя трех чисел используя следующую формулу нод(а, в, с) = нод(нод (а, в), с) Не используйте слово function так как мы его не изучали ещё?

Составьте программу нахождения наибольшего общего делителя трех чисел используя следующую формулу нод(а, в, с) = нод(нод (а, в), с) Не используйте слово function так как мы его не изучали ещё.

Очень срочно заранее спасибо \.

Mariabrakorenko 13 мар. 2020 г., 23:39:26 | 5 - 9 классы

Пользователь вводит с клавиатуры n - чисел определить : Сколько среди них простых чисел?

Пользователь вводит с клавиатуры n - чисел определить : Сколько среди них простых чисел.

Наибольший общий делитель всех этих чисел.

Число у которого делителей боль, чем у всех остальных.

ПАСКАЛЬ ПРОЦЕДУРЫ И ФУНКЦИИ!

Dev0shkA 21 авг. 2020 г., 05:48:29 | 10 - 11 классы

Записать алгоритм нахождения наибольшего общего делителя двух натуральных чисел?

Записать алгоритм нахождения наибольшего общего делителя двух натуральных чисел.

Иосиф2 8 апр. 2020 г., 23:56:33 | 10 - 11 классы

1) Написать программу, находящую для натурального числа все его натуральные делители?

1) Написать программу, находящую для натурального числа все его натуральные делители.

2) Написать программу, вычисляющую наибольший общий делитель двух натуральных чисел.

На этой странице находится вопрос Найти наибольший общий делитель чисел A, B, C, создав функцию для нахождения НОД двух натуральных чисел?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.