Помогите решить пожалуйста По данному натуральному числу N найдите сумму чисел 1 + 1 / 1?

Информатика | 5 - 9 классы

Помогите решить пожалуйста По данному натуральному числу N найдите сумму чисел 1 + 1 / 1!

+ 1 / 2!

+ 1 / 3!

+ . + 1 / N.

Количество действий должно быть пропорционально N.

Входные данные Задано единственное число N Выходные данные Необходимо вывести результат вычисления в виде действительного числа c точностью до 5 знаков после запятой.

Примеры Входные данные 1 Выходные данные 2.

Ответить на вопрос
Ответы (1)
Amanghaliieva20 22 мар. 2020 г., 01:22:43

Var i, n : integer ; s, t : real ;

begin write('n = ') ; readln(n) ; s : = 1 ; t : = 1 ; i : = 1 ; repeat t : = t / i ; s : = s + t ; i : = i + 1 ; until i> ; n ;

writeln('сумма ряда : ', s : 7 : 5) ;

end.

Anastasia19jeni 1 нояб. 2020 г., 06:21:23 | 10 - 11 классы

Даны два целых числа?

Даны два целых числа.

Определить, какое из них больше или определить их равенство.

Вывести знак '> ; ' если первое число больше, знак '< ; ' если второе число больше, знак ' = ' если числа равны.

Входные данные : Выходные данные : Во входном потоке в первой строке через пробел заданы целые числа A и B ( - 30000 < ; A, B < ; 30000).

В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : 5 7 Пример выходного файла (output.

Txt) : < ;

PFK 25 авг. 2020 г., 16:21:55 | 5 - 9 классы

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N?

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Формат входных данных Задано единственное число N.

Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Virus1420 1 окт. 2020 г., 07:10:54 | 5 - 9 классы

Вычислите сумму данных N натуральных чисел?

Вычислите сумму данных N натуральных чисел.

Входные данные Вводится число N, а затем N чисел, сумму которых необходимо вычислить.

Выходные данные Выведите единственное число - сумму введенных чисел.

В Pascal ABC.

Schura97 3 июл. 2020 г., 10:20:09 | 10 - 11 классы

Помогите написать программу на PascalABCNET ВХОДНЫЕ ДАННЫЕ Задано натуральное число N?

Помогите написать программу на PascalABCNET ВХОДНЫЕ ДАННЫЕ Задано натуральное число N.

ВЫХОДНЫЕ ДАННЫЕ Определите количество нулей в его записи.

Ilililililil 19 окт. 2020 г., 06:29:49 | 5 - 9 классы

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ?

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ!

25баллов Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Входные данные Задано единственное целое число N Выходные данные Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Примеры входные данные 15 выходные данные 1 4 9.

Ммутыл 16 нояб. 2020 г., 15:25:50 | 5 - 9 классы

ПРОШУ ПОМОГИТЕ ОЧЕНЬ СРОЧНО Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 < ; = x < ; = 30000)?

ПРОШУ ПОМОГИТЕ ОЧЕНЬ СРОЧНО Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 < ; = x < ; = 30000).

Входные данные Вводится натуральное число x.

Выходные данные Выведите наименьший делитель числа x, отличный от 1.

Примеры входные данные 2 выходные данные 2 входные данные 6 выходные данные 2.

Целуйкиса 2 авг. 2020 г., 12:14:05 | 5 - 9 классы

Напишите программу, которая строит "линию" из знаков ' - ' заданной длины?

Напишите программу, которая строит "линию" из знаков ' - ' заданной длины.

Используйте процедуру.

Входные данные Входная строка содержит единственное натуральное число – длину линии N .

Выходные данные Программа должна вывести N знаков ' - '.

ПРОГРАММА - PYTHON !

Только PYTHON !

Balashovamarin 2 июл. 2020 г., 18:04:30 | 5 - 9 классы

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное?

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное.

Входные данные : Входная строка содержит единственное натуральное число.

Выходные данные : Если введённое число – трёхзначное, нужно вывести ответ YES, если нет, то вывести ответ NO.

ЛизаПоняша 25 дек. 2020 г., 09:24:13 | 10 - 11 классы

Напишите программу, которая возводит натуральное число A в натуральную степень B ?

Напишите программу, которая возводит натуральное число A в натуральную степень B .

Входные данные

Входная строка содержит два числа, A и B , разделённые пробелом.

Гарантируется, что 1 ≤ A , B ≤ 1000 .

Выходные данные

Программа должна вывести одно число : A в степени B .

Примеры

входные данные

2 6

выходные данные

64.

Паскаль ABC 1.

8.

Akolesova2002 30 нояб. 2020 г., 01:46:11 | 5 - 9 классы

Дано натуральное число N?

Дано натуральное число N.

Напишите функцию (Pascal), вычисляющую сумму цифр числа N.

Входные данные

Задано единственное число N

Выходные данные

Необходимо вывести сумму цифр числа N.

Примеры

входные данные

12

выходные данные

3

ПРОГРАММА БЫЛА, НО ВВОДИЛ 12 И ВЫВОДИЛ ВМЕСТО 3, 0.

На этой странице находится ответ на вопрос Помогите решить пожалуйста По данному натуральному числу N найдите сумму чисел 1 + 1 / 1?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.