Дано трёхзначное число?

Информатика | 5 - 9 классы

Дано трёхзначное число.

Напишите программу, которая определяет : есть ли среди цифр заданного целого трёхзначного числа одинаковые ; Пример входных данных : 123 121 122 Пример выходных данных : Нет Да Да.

Ответить на вопрос
Ответы (1)
Tanysha16 10 дек. 2020 г., 10:29:44

Усложнённый вариант(всё работает исправно, при вводе больше или меньше 3 чисел выводится сообщение "Это не трёхзначное число!

") :

var

i, a, d : integer ;

s : string ;

begin

writeln('Введите трёхзначное число ') ;

read(s) ;

d : = length(s) ;

if d< ; > ; 3 then

write('Это не трёхзначное число!

') ;

if d = 3 then

if (s[1] = s[2])or(s[1] = s[3])or(s[2] = s[3]) then

write('Да')

else

write('Нет') ;

end.

Простой вариант(выводится ошибка если цифр больше или меньше трёх!

) :

var

i, a, d : integer ;

s : string ;

begin

writeln('Введите трёхзначное число ') ;

read(s) ;

if (s[1] = s[2])or(s[1] = s[3])or(s[2] = s[3]) then

write('Да')

else

write('Нет') ;

end.

Даю 2 варианта, так - как незнаю, проходили ли вы функцию "length" или нет.

Если нет, то препад заподозрит что вы списали откуда нибудь или вам кто - то подсказал.

НАстик1111 10 нояб. 2020 г., 08:04:40 | 5 - 9 классы

Дано трёхзначное число?

Дано трёхзначное число.

Напишите программу которая определяет есть ли среди цифр заданного целого трёхзначного числа одинаковые.

НиккаМинаж 2 мар. 2020 г., 13:46:04 | 5 - 9 классы

Дано трёхзначное число ?

Дано трёхзначное число .

Напишите программу , которая определяет :

Kovanov2014 27 окт. 2020 г., 02:37:24 | 10 - 11 классы

Дано трёхзначное число?

Дано трёхзначное число.

Найти среди цифр этого числа, максимальное.

Программа в Паскале.

Sabanchievb13 11 нояб. 2020 г., 14:24:14 | 5 - 9 классы

Помогитееее Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые?

Помогитееее Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые.

MERIVko76 18 мая 2020 г., 19:28:13 | 5 - 9 классы

Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые?

Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые.

Мухтар7 11 авг. 2020 г., 21:59:02 | 5 - 9 классы

Дано трехзначное число Напишите программу которая определяет есть ли среди цифр заданного целого трехзначного числа одинаковые?

Дано трехзначное число Напишите программу которая определяет есть ли среди цифр заданного целого трехзначного числа одинаковые.

Balashovamarin 2 июл. 2020 г., 18:04:30 | 5 - 9 классы

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное?

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное.

Входные данные : Входная строка содержит единственное натуральное число.

Выходные данные : Если введённое число – трёхзначное, нужно вывести ответ YES, если нет, то вывести ответ NO.

ТАРАНТУЛ2004 25 дек. 2020 г., 10:54:01 | 5 - 9 классы

Напишите программу в Boland Pascal?

Напишите программу в Boland Pascal.

ЗАДАНО ТРЕХЗНАЧное числою напечатать в обратном порядке .

Входные данные Целое трехзначное число.

Выходные данные Целое трехзначное число напечатать в обратном порядке Пример входных данных423 .

Пример выходных данных 324.

Serjana 9 окт. 2020 г., 05:42:28 | 10 - 11 классы

Уровень B?

Уровень B.

Задача M.

Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 5221 выходные данные YES входные данные 1232 выходные данные NO

Уровень C.

Задача O.

Две одинаковые цифры Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом (как, например, 212).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 212 выходные данные YES входные данные 12345 выходные данные NO.

Akolesova2002 30 нояб. 2020 г., 01:46:11 | 5 - 9 классы

Дано натуральное число N?

Дано натуральное число N.

Напишите функцию (Pascal), вычисляющую сумму цифр числа N.

Входные данные

Задано единственное число N

Выходные данные

Необходимо вывести сумму цифр числа N.

Примеры

входные данные

12

выходные данные

3

ПРОГРАММА БЫЛА, НО ВВОДИЛ 12 И ВЫВОДИЛ ВМЕСТО 3, 0.

Вы находитесь на странице вопроса Дано трёхзначное число? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.