Здравствуйте, помогите пожалуйста решить задание по информатике : дано вещественное число А?

Информатика | 10 - 11 классы

Здравствуйте, помогите пожалуйста решить задание по информатике : дано вещественное число А.

Используя операцию умножения получить А28 за шесть операций.

Спасибо.

Ответить на вопрос
Ответы (1)
Makyar1999 7 янв. 2020 г., 14:32:05

Program Anastas65 ;

var

A, X, Y : integer ;

begin write('Введите число A ') ; readln(A) ; writeln(' * * * Alphaeus * * * ') ; writeln(' * * * Получение А ^ 28 за 6 ходов * * * ') ; X : = A * A ; / / получаем А ^ 2 Y : = X * A ; / / получаем А ^ 3 X : = X * X ; / / получаем А ^ 4 Y : = Y * X ; / / получаем А ^ 7 Y : = Y * Y ; / / получаем А ^ 14 Y : = Y * Y ; / / получаем А ^ 28 writeln(' Результат = ', Y) ; writeln(' * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * ') ;

end.

Wewenami2 8 сент. 2020 г., 17:23:57 | 5 - 9 классы

Дано а?

Дано а.

Не используя никаких функций и никаких операций , кроме умножения, получить а ^ 8 за три операции.

А ^ 10 и а ^ 16 за четыре операции нужно напистаь программу, что - то никак не разебрусь, помогите, пожалуйста.

MDKa 1 сент. 2020 г., 08:09:48 | 5 - 9 классы

Помогите, пожалуйста : * Составить программу, которая для данной величины А, не используя никаких функций и никаких операций, кроме умножения, вычисляет А15 (А в пятнадцатой степени) за пять операций?

Помогите, пожалуйста : * Составить программу, которая для данной величины А, не используя никаких функций и никаких операций, кроме умножения, вычисляет А15 (А в пятнадцатой степени) за пять операций.

Veronikanev16 30 сент. 2020 г., 02:54:10 | 5 - 9 классы

Составить программу, решающую следующую задачу : Дано число а?

Составить программу, решающую следующую задачу : Дано число а.

Не пользуясь никакими другими операциями, кроме умножения, получить : за 3 операции.

Svetlanafg1 1 авг. 2020 г., 10:00:31 | 10 - 11 классы

Здравствуйте, помогите пожалуйста с информатикой?

Здравствуйте, помогите пожалуйста с информатикой.

Задание : Дано существенное число А.

Используя операцию умножения, получить А15 за пять операций.

Оля4В 17 апр. 2020 г., 22:08:12 | 10 - 11 классы

Составить алгоритм для решения задачи?

Составить алгоритм для решения задачи.

Дано значение a.

Не используя никаких функций и никаких операций, кроме умножения, получить значение a ^ 8 за три операции и a ^ 10 за четыре операции.

Ekaterlnakozlova 27 мар. 2020 г., 07:46:06 | 5 - 9 классы

Ввести два целых числа , найти их произведение не используя операцию умножения?

Ввести два целых числа , найти их произведение не используя операцию умножения.

Antonkvi 12 июл. 2020 г., 12:57:40 | 5 - 9 классы

Выполните операцию умножения над двоичными числами : а)1011 * 11 ; объясните пожалуйста)?

Выполните операцию умножения над двоичными числами : а)1011 * 11 ; объясните пожалуйста).

Dima12345678987 22 июл. 2020 г., 03:33:39 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Используя операцию деления нацело, надо вывести первую цифру данного числа (cотни).

Вича2003 7 февр. 2020 г., 03:46:23 | 5 - 9 классы

Дано действительное число a?

Дано действительное число a.

Не пользуясь никакими другими арифметическими операциями, кроме умножения, получить а9 ( в девятой степени) за четыре операции.

И как это всё записать в паскале ?

Помогите мне пожалуйста !

Заранее спасибо !

Zemzyrova2006 25 сент. 2020 г., 20:00:15 | 10 - 11 классы

Ввести целое число, найти его квадрат, не используя операцию умножения?

Ввести целое число, найти его квадрат, не используя операцию умножения.

(Составьте алгоритм).

Если вам необходимо получить ответ на вопрос Здравствуйте, помогите пожалуйста решить задание по информатике : дано вещественное число А?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.