Дан массив из N чисел?

Информатика | 5 - 9 классы

Дан массив из N чисел.

N - четное.

Написать программу, меняющую местами элементы с четными и нечетными номерами.

Плиз помогите оч надо.

Ответить на вопрос
Ответы (1)
Nika14071997 20 окт. 2020 г., 09:41:30

Program Yolo ;

Uses Crt ;

Const N = 16 ;

Var Mass : array [1.

N] of integer ; Back : integer ; i : byte ;

Begin

Randomize ;

ClrScr ;

Writeln('Исходная матрица [ - 15 ; 15] : ') ;

For i : = 1 to N do Begin Mass[i] : = Random(31) - 15 ; Write(Mass[i] : 4) ; End ;

Writeln ;

For i : = 1 to N do If i mod 2< ; > ; 0 then Begin Back : = Mass[i] ; Mass[i] : = Mass[i + 1] ; Mass[i + 1] : = Back ; End ;

Writeln('Отформотированный матрица : ') ;

For i : = 1 to N do Write(Mass[i] : 4) ;

Readln ;

End.

Dfyz192837465 22 янв. 2020 г., 10:09:25 | 10 - 11 классы

Написать программу на языке паскаль ?

Написать программу на языке паскаль .

ПЖЛ ПОМАГИТЕ дан одновременный массив из п целых чисел .

Составить программу вычисления суммы элементов стоящих на четных местах.

Надежда19841 23 июл. 2020 г., 09:17:50 | 10 - 11 классы

Дан одномерный массив целых чисел?

Дан одномерный массив целых чисел.

Найти сумму всех четных элементов массива, стоящих на четных местах (имеющих четные номера).

Массив задается с помощью генератора случайных чисел.

Если можно с блок - схемой.

Lizakan021 27 сент. 2020 г., 01:14:13 | 10 - 11 классы

Дан массив из 10 элементов найти сумму элементов с четными номерами?

Дан массив из 10 элементов найти сумму элементов с четными номерами.

Написать программу на языке программирования.

Kettyyy 20 февр. 2020 г., 13:02:02 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Все нечетные элементы удвоить, я четные умень­шить вдвое.

Misha032 7 июн. 2020 г., 16:08:37 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Напечатать все четные элементы.

Vitaly198703 11 сент. 2020 г., 05:36:00 | 10 - 11 классы

Ввести два целочисленныхмассива − по 10 элементов в каждом?

Ввести два целочисленныхмассива − по 10 элементов в каждом.

Сформировать новый массив, на четных местах которого будут элементы с нечетными индексами из первого массива, а нанечетных – с четными индексами из второго.

Написать программу на паскале.

ЛанаЛо 18 июл. 2020 г., 14:36:57 | 10 - 11 классы

Даны два массива?

Даны два массива.

Получить третий массив который на четных номерах элементы второго массива на нечетных элементы первого массива.

Решите пожалуйста через pascal ABC и опишите программу.

Yusufbek 16 мар. 2020 г., 22:47:12 | 5 - 9 классы

Массив содержит N случайных двузначных чисел?

Массив содержит N случайных двузначных чисел.

Определить сколько в данном массиве четных чисел.

Вывести все его элементы с нечетными номерами.

Kourov 6 окт. 2020 г., 22:33:10 | 10 - 11 классы

Cоставить программу в паскале?

Cоставить программу в паскале.

В одномерном массиве произвольных чисел вычислить произведение четных и нечетных элементов.

Fricasso 21 нояб. 2020 г., 02:46:06 | 5 - 9 классы

Дан массив из N элементов?

Дан массив из N элементов.

Найти сумму элементов с четными номерами и отдельно – с нечетными номерами.

Вы находитесь на странице вопроса Дан массив из N чисел? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.